Comodo Internet Security 2020 v12.2.2.7036 Released.

Hi All,

We are pleased to announce the release of Comodo Internet Security 2020 v12.2.2.7036.
Here are the details:

Online Setup Details:

Comodo Internet Security Premium
Size: 4.78 MB (5,020,536 bytes)
MD5: e40d8cb2bc789f96b855432b597ce22a
SHA1: 90c2577e94cb2b1556abd50baebd52f0b4605bf6

Comodo Antivirus
Size: 4.78 MB (5,020,544 bytes)
MD5: c38447813fa58fc72995a9ddbdc63828
SHA1: 20b8637365fc6d25b89a7d6e3cded050c2213c4b

Comodo Firewall
Size: 4.78 MB (5,020,536 bytes)
MD5: d6ac13d92c620cd65aa26679c8c1c88a
SHA1: 4ddbcc0d12db905988fb35fcdd757a212ee32347

Offline Setup Details:

Comodo Internet Security Premium
Size: 80.9 MB (84,903,920 bytes)
MD5: b319a61c88f9b85f7b7680efd16bb0db
SHA1: 41c1d789a55e7c4290efef1ceb36d70c817e29dd

Comparing to previous release CIS

− Migrated virtually all HTTP URLs to HTTPs.
− Folder Protection

− Upgrade over install doesn’t work
− Https website filtering no longer works on Chrome 78
− Chrome crashes in Containment
− CIS creates error while unplugging USB
− Uninstallation & Installation failed
− Uninstallation of Comodo KillSwitch and Cleaning Essentials
− Freezes in Win10 build 1909/1903

*Please note, this release has been rolled out for new users.
We shall be rolling out updates for existing users over the next few weeks.

Best Regards,

Edit Note: Download links are updated.

stable and safe

Thank you so much for this latest stable version!
I will be installing and testing it shortly.
I hope this will be a solid release! :-TU

UPDATE: So far .7036 appears to be quite stable. Nothing negative to report at this time. It appears to be a good stable replacement to .6882 .


I exited the v12.2.2.7036 Beta Firewall (without uninstalling) and then ran the new v12.2.2.7036 FW online installer, then rebooted. Hopefully I didn’t need to uninstall guys?
And these were all 64 bit links? So far everything seems to be in order.

Glad to have this Software update. Thanks to Melih and the team for bringing this out!!

Diagnostics finds a network error that it cannot fix: Network Status=“Failed” Error="0x0000007a.

Also I set the FW up to use the Comodo DNS servers which should be:
• Preferred DNS :
• Alternate DNS :

However, the install set these instead:
• Preferred DNS :
• Alternate DNS :

The links to the installers don’t work!

Just tried it !
All the links are working.

I installed the new version over the previous one (6882) and it installed fine.

Thanks for this release !

Link does not work for me: 404 not found, nginx. No matter what I do.

Tried the links again, all downloads are fine !

Hello prodex,

I’ve tried. All links are working. Do you have a clean host? I mean could you please make sure there is no IP in your host corresponding to ?

Thank you,

Aha, that was the problem!

I had previously set the hosts file to include in order to download and install the RC.

Thanks for your help!

Thanks for the prompt answers.

Then I created now this problem putting DNS in the clean host.
New try!

The HOST was I didn’t think of, but now I put it in my head! Download successful! :slight_smile:

Downloaded offline installer and did an update over the previous full release. Reboot - can’t complete installation due to lack of permissions - I was on as Admin.
Ran the clean-up tool then installed 6882 again as 7036 wouldn’t install even after cleaning up.
I’ll wait for the on-line update and hope that it’ll work.

Downloaded the offline version; uninstalled the RC (which was an update test). Installed the new version; rebooted and imported my Config and File List; updated again to get the Recognizers and rebooted again

No problems whatsoever and everything running just as expected . . . . many thanks - it was worth the wait :-TU

Is the old version still available on the WEB site (6914) will the new version be made available soon also in all the links of the website?

will beta 1 be updated automatically to new release or not?

not that it matters much since I expect I have to do clean install anyways (prev. experiences instigate so).

** Also just updated with KB4550945 to the latest Win10 build 1909 (18363.815) and no problems with that either :slight_smile:

Thank you !
Congratulations to the team :-TU

Service Control Manager
Event-ID 7000
The “COMODO Internet Security Helper Service” failed to start due to the following error:
The service did not respond to the start or control request in a timely fashion.
Event-ID 7009
A timeout was reached (120000 milliseconds) while waiting for the COMODO Internet Security Helper service to connect.
Event-ID 7000
The “Software Protection Service” failed to start due to the following error:
The service did not respond to the start or control request in a timely fashion.
Event-ID 7009
A timeout was reached (120000 milliseconds) while waiting for the sppsvc service to connect.

I went back to 6882.