Problems with certificates [split topic]

There appears to be a problem with an SSL Certificate on one of the servers and they’re aware of it

It’s working in the UK at the moment

Just to make sure the problem is still known…

When attempting to download the installers, I’m getting the following: Unable to communicate securely with peer: requested domain name does not match the server’s certificate. HTTP Strict Transport Security: false HTTP Public Key Pinning: false uses an invalid security certificate. The certificate is only valid for the following names: *, Error code: SSL_ERROR_BAD_CERT_DOMAIN

On the same systems, CIS will not update. It errors out stating “Error: 0x80072f8f - Content decoding has failed”.

I suspect the two issues are linked to the certificate error referenced earlier in the thread.


works for me so no problems here.

link to the current definitions that I can try to see if they will download for import? This below is the database update page for versions 5.8 below and above

That link wil give you the current definitions

Wow… it looks like windows 2004 made some changes. Hopefully comodo can fix this asap

Not sure if others are facing this problem but I’ve been getting an error when trying to update the virus database
'Content decoding has failed"

When I tried to download the virus database from Comodo Anti Malware Database Latest Version & Additions 2022
It’s taking me to a site with an expired certificate -
I hope this is an official site, just need you guys to update your certificates.

In the mean time I was able to get a different link by using a VPN, so I’ve updated the Proxy and Host Settings to use instead, seems to be downloading now, but unfortunately I did a clean reinstall of CIS and now the update is 400mb and speeds are pretty slow.

Fingers crossed it all works out.

I reported that link for you

The issue I see is the cert expired Feb, 2020.

Im glade you found a solution to that, hopefully they can fix that issue ASAP. :slight_smile:

offline installer link error

And again this error again, I think version 7036 is still buggy !!!

Please fix !

The offline installer download link on the first page of this thread works for me.
I can download the offline installer file.

I think there isn’t anything to fix I’ve gotten no problems updateing cis. Perhaps you can find there a solution:;msg898178#msg898178

Did you change your hosts-file?

See attachment!

For me too!


Really ? They fixed it before !

Look here:

I didn´t do anything to the HOST file !

Are there other people in Asia/Australia/New Zealand also having a problem with updating? Prallo. What version of Windows are you on? It looks like a problem with the CDN. I hope it gets picked up and fixed.

Hello pangkk,

Could you please share the link from your side.
and also
Please cross-check with [url= [/url]this.

Hello prallo,Yes we already fixed that.
Do you having this issue for a long time or else it started from today?

From yesterday !
And the error code is the same as before !

I uninstalled CIS, reinstalled it, same error.

I uninstalled CIS with the Comodo uninstaller, reinstalled it, same error.

Hello prallo, Are you sure ? Did you modified your host entries?

No, I didn´t modify the host file.

Okay,Please wait.
Let me check with the team and return back to you.

@ prallo,Reported to corresponding team and they are checking in it.Hopefully it will be resolved.

Still not solved !