COMODO Internet Security 3.10.102363.531 Bug Reports

COMODO Internet Security 3.10 is the last version of the “version 3 series” of both the Firewall, Antivirus, Defense+ and the other technologies. To simplify; This is the last CIS version before COMODO Internet Security 4.0, Which will include a Brand new usability GUI overhaul, Time Machine and so on. Please do not post any questions, comments, etc on CIS v4! This is for CIS 3.10 bug reports ONLY and discussion.

ANY bugs existing with COMODO Internet Security needs to be posted here. This way developers can fix any issues in CIS v4.0 that replicate in CIS v3.10 and make sure they don’t exist in CIS 4.0, and have all these bugs in one place right here. IF However an emergency fix needs to be made, Then it will be fixed in a 3.10 build BEFORE 4.0.

Please remember, details are required for all bug reports so developers can quickly reproduce the bug, indentify it and then fix it. If new builds are released for CIS 3.10 because of emergency fixes, I will update the thread title.

Please post all bug reports & BSOD’s here relating to CIS version 3.10 and make sure to include:

  1. Your Operating System (32 or 64 bit) and Service Pack revision (Instructions for XP and Vista)
  2. Other Security and Utility Software Installed
  3. Step by step description to reproduce the issue
  4. How you tried to resolve the problem
  5. Upload Memory Dumps on crash if you encounter any
  6. Attach screenshots to your posts to clarify the issue further
  7. Please put any False Positive Reporting here
  8. Any other information you can think of

Non Related Bug Reports/Discussion will be moved or deleted if necessary. Bug Reports please keep an eye on developer responses too if they ask a question.

EDIT: First Emergency Fix available. COMODO Internet Security 3.10.102363.531 has been released here.

[b]3.10.102363.531 Changes
FIXED! DOS applications crash when CIS is installed
FIXED! SafeSurf is not uninstalled automatically with the update
FIXED! SpySweeper incompatibility

EDIT: Sunday, July 19th, 2009: There will be no more releases of the version 3 series any long. COMODO Internet Security 3.10.102363.531 was the last version, Now the developers are working on version 4. Please keep going with bug reports so they don’t replicate in v4.


I’m using Windows 7 x64 RC1 just freshly installed. I disabled Windows Firewall and Defender and had Spyware Blaster installed. The problem I am having is that every time I do something, I get an alert for services.exe. The option to select it as a trusted app or define it as a system file was grayed out so I could only allow or deny. Even when installing something and I switch to Installation Mode, I would get a ton of alerts for services.exe. The only services.exe it could be is C:\Windows\System32\services.exe. It’s really annoying having to click allow like 20 times to install something or to even run it. It’s just way too many alerts and there was no way to trust the app through the pop-ups so I uninstalled CIS for now. I guess that file needs to be added to the Windows System files list. Luckily the RTM is July 13th, so hopefully all Win 7 bugs can be ironed out around then. :slight_smile:

Also, I noticed that it logs a ton of outgoing connections. I think it listed about 25 of the same one which was connecting to over UDP. That’s standard PC to router talk, so why it’s listing the connection that many times, I don’t know when in the past it was always a same amount like 5. Unless the RC build has some serious issues and really is connecting that many times compared to Windows Vista and even Beta 1. So, I point this out so it can be investigated. :slight_smile:



I’ve just encountered a cfp.exe crash.

  1. Vista Home Premium 64Bit SP2
  2. Avira Antivir free (on-demand only), Windows Defender (real-time), Malwarebytes Anti-malware free, SuperAntiSpyware free, portable CCleaner
  3. I just clicked on the number of active processes in the main window of CIS’s interface and the crash happened. However cmdagent.exe was still running.
  4. Restarting CIS helps.
  5. Attached
  6. Windows Firewall is disabled.
    I’m on Proactive Security. My settings in CIS are as follows:

Firewall: Safe Mode; stealth my ports to everyone, protect the ARP cache, block gratuitous ARP frames, first three boxes checked in the “Miscellaneous” tab.

Defense+: Clean PC Mode; trust the applications digitally signed by TSV.

I’m not on a virtual system. Windows Firewall is disabled. Administrator account with UAC disabled.

Hope this will help!

PS: Would it be possible to make cmdagent.exe reinitiate cfp.exe in the event of a crash of the latter? I’d appreciate an answer from the devs.
Thank you!

[attachment deleted by admin]

Here’s mine (firewall bugs forum):

Using Vista Ultimate x64 SP2 using Symantec Antivirus.

The new 3.10 version is unusable for me.

Internet speed is normal but the connecting phase of a connection is dead slow like 5-10seconds.

Disabling the firewall and everything is back to normal.

Did a normal upgrade first and noticed the problem.
Then i did a uninstall and a clean install and it didn’t fix the thing.

So going back to the 3.9.

Edit: Seems like the 3.9 isn’t woking either anymore :-[

Getting the error “Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item” when attempting to access certain files (installs, uninstalls and some .exe). Did not occur until after .530 update.

Google search indicated that AVG users had run into this (not that I use it), and yes, turning off Comodo Antivirus clears the problem (but leaves me rather exposed).

Windows XP-32 SP3 (w/ June updates)

Edit: Fell back (new install) to .529 (interesting that online update gives you .530, but downloading CIS package gives you .529) - problem eliminated.

i can’t seem to get the update going…it stops at 30% for a while and then it says update failed…tried doing it many a times…
using it on winxp

  1. Your Operating System (32 or 64 bit) and Service Pack revision
    Win7 RC (7200) 32bit
  2. Other Security and Utility Software Installed
  3. Step by step description to reproduce the issue
    Plug in a new Fllash Pendrive which the system hasn’t seen before. As the system installs the device drivers, you get tons of popups fro services.exe. Ticking remember doesn’t seem to make any difference.
  4. How you tried to resolve the problem
    Cannot resolve
  5. Upload Memory Dumps on crash if you encounter any
  6. Attach screenshots to your posts to clarify the issue further
  7. Please put any False Positive Reporting here
  8. Any other information you can think of

This didn’t occur with any of the 3.9’s I tried. Only started happening with 3.10

Here is one from me;new#new

Ok, now its gettin funny.
CIS has updated a few hours ago, but as soon the download has started I got an access violation error, but update has completed after this. I rebooted my machine, anything seems to be fine.

But: I can’t launch XMPlay anymore (This file has been tampered, … see screenshot).
Also CIS has detected 2 false positives (?), one the regfilter.exe from dvb viewer, the other one was fadeinout.dll from mpeg2schnitt. (see the other screenshot)
I cross checked with antivir and microsofts revenge (microsoft security essentials), they say all files are fine.

Im frustrated about why I can’t launch xmplay anymore. I re-downloaded it again, same problem. Yesterday it works fine.

Edit: I forgot: I still use win7 x64 (build 7100)

[attachment deleted by admin]

Hello folks,

  1. Windows XP Professional SP3 32-bit
  2. Avira Antivir Premium (real time), Prevx 3.0.165 (real time), Windows Defender (real-time), Malwarebytes Anti-malware 1.38 free (on demand), SuperAntiSpyware 4.26.1006 free (on demand)
  3. All firewall alert windows show up over sized. Defense+ alert windows show up in normal size.
  4. I have tried to click in “fewer options” and “more options” to bring the firewall alert windows to its normal size, but it doesn’t help.
  5. Attached
  6. This problem started after a clean install of CIS 3.10.102194.530 when using CIS 3.10.101801.529 (clean install) there was no problem with the alert windows. My CIS settings are as follows: Firewall: Custom Policy Mode and Defense+: Training Mode

See you later,

Aeolis :wink:

[attachment deleted by admin]

  1. Your Operating System : Vista 32 sp2

  2. Other Security and Utility Software Installed : No

  3. Step by step description to reproduce the issue : Install Cyberlink Powerdvd. Install CIS. Try to open a videofile. Powerdvd should now stop working. This must be because of CIS
    because I do not get this problem without CIS installed.

  4. How you tried to resolve the problem : Uninstall CIS.

Is I go to “my protected files” and add and browse and I look under my computer then it shows my C: and D: drives but not my E: drive. D: and E: are both CD/DVD drives.

Windows Vista SP2 32 bit.

[attachment deleted by admin]

my OS : winxp sp3
I have also experienced the same problem went through by Legendkiller. update started from 5% and ended at 30% then halt .

clean install of 3.10…530 couple of times
70-80 mb download is shown in Traffic window by cmdagent.exe and it can’t finish its job
virus signature database version : 1157
What should I do now??? give me some light… :-[ :-[ :-[ :-[ ??? ??? ??? ??? ???

[attachment deleted by admin]

Excellent program and free which is important.

Upgraded for 3.9 to 3.10
Using Vista X64

I have 3 program problems.
Getright Pro, SysLogWatcherPersonal, FRAPS

These 3 programs hang at startup with CPU usage at %20 or so.

If i install GetrightPro, FRAPS and SYSlogWatcherPers, and run immediately, they will work.

its only on startup after logging in those 3 seem to hange for some weird reason.

Im still working on it.

I’m am on a Windows XP Home SP3 PC (see details in my signature)

OK, I’m using emule… ok I’m using utorrent… but I see that the number of inbound & outbound connections keeps rising from this morning (when I installed .530)

Normally, in similar cases, I had about 60/70 connections

I think that the counter is no more periodically reset :comodorocks:

[attachment deleted by admin]

Hi, I have noticed ever since I upgraded to CIS 3.10.102194.530 that when CIS catches a bad file it says that it has quarantined it, but it never appears in the quarantine. The file is deleted though. This happens with either the real time scanner or on demand. To make this even stranger some files are properly quarantined. With the high number of false positives that CIS currently has, this is a huge problem that needs to be addressed.

-I am using Windows XP SP3 (32 bit)
-The only security application that I am using is CIS 3.10.102194.530
-Both the D+ and firewall are set to safe mode
-The exact same thing happened to me with CIS 3.10.102194.529
-I am always logged in as an administrator

Edit: I no longer am experiencing this problem. If it appears I will re-post. If anyone else experiences it please feel free to post it on the forums.

XP pro Spk 3 32 bit.
Avast 3.8. 4.8, SpySweeper 6.1 (No antivirus). WinPatrol Plus.
CIS 3.10.102194.530 Firewall and proactive Security installed clean with no other security app on at the time of installment.
Spy Sweeper scans usually takes 7 minutes on my PC. After installing 3.10 the scan times vary from 22 to 27 minutes, it stays on different .exe, .dll files for a while and then it keeps going. Also HHD is making an awful sound.
I have not done anything to solve this problem because this happened before with CIS 3.8.
Thank you for reading.

Edit: Upps Avast 4.8

Windows Vista 32 bit

I also get a major jump in outbound connections. With 3.9 i get 30-60. With 3.10 i get 330. I am not the only one seeing this jump.

3.10 also stopped blocking the following network traffic

Application: windows Operating system
Protocal: UDP
Source IP:
Source Port: 67

3.9 blocks it fine. In fact in one hour it blocked 320 intrusion attempts.

  1. Your Operating System (32 or 64 bit) and Service Pack revision XP Home SP2 32 bit
  2. Other Security Software Installed None
  3. Step by step description to reproduce the issue After clean install of 3.10 all worked fine except I could not access my 16 bit Quicken application. Got an error message that it cannot run. (“Attempt to access invalid address”).
  4. How you tried to resolve the problem Tried a system restore - did not work. Did a paragon image restore and went back to 3.9
  5. Upload Memory Dumps on crash if you encounter any None
  6. Attach screenshots to your posts to clarify the issue further None
  7. Please put any False Positive Reporting here
  8. Any other information you can think of


See here as well;msg305222#msg305222