COMODO Internet Security 3.10.102363.531 Bug Reports

Using XPHome SP-3 with all critical updates installed on a x32 CPU.

Was using CIS 3.9…507 without problem (Firewall and D+ only installed, both set to “safe” mode).

Updated yesterday to 3.10…529 (x32) as a clean installation (after first exporting my configuration), without apparent problem. Installed only Firewall and D+ and imported my previously exported configuration. Today I tried to open MS Works Database Ver 7.0 and received the dreaded “Application Failed to Initialize, error code: 0xc0000018”. First tried to repair database program, then uninstalled and re-installed works. No deal.

Did a system restore to yesterday (prior to CIS update) and MS Works Database opened, but CIS was hosed with bizarre colors, no theme or language options on setup, and no product version visible in the “about” window. I didn’t trust the CIS to protect me, uninstalled it, and did another clean installation of 3.10…529. Again, database program wouldn’t open.

Uninstalled CIS and with no CIS installed (not doing any further system restores) database worked perfectly. Reinstalled 3.9…507, reimported my configuration, and database is still working.

Clearly there is some code in CIS 9.10 that is causing the problem.

Another bug that still exists is discussed here

1. Your Operating System (32 or 64 bit) and Service Pack revision (Instructions for XP and Vista)
Win 7 RC 7100 x64

2. Other Security and Utility Software Installed
Microsoft Essentials Security ( and i have uninstalled AV of Comodo )

3. Step by step description to reproduce the issue
Since this latest version is installed, when i try to connect to Battle.Net server with Starcraft BroodWar, i know its very old game but worked before… then Starcraft can’t recognize its own version so it refuse me to enter Battle Net. If Comodo is completely uninstalled, then it works. I tried to use training mode of Defense+ and Firewall but, this doesn’t help to solve the issue. I don’t know how to diagnose because Comodo doesn’t show any alert.

4. How you tried to resolve the problem
I tried to Disable Defense+ and Firewall, and uninstalled Comodo. Only when Comodo is removed then my game works normally. Please note, with 3.9 version i don’t have any issue of this kind.

5. Upload Memory Dumps on crash if you encounter any

6. Attach screenshots to your posts to clarify the issue further

  1. Windows XP Professional SP3 32-bit
  2. Malwarebytes Anti-malware 1.38 free (on demand)
  3. AV shows no message that eicar has been detected/quarantined if Automatically quarantine threats found during scanning is checked.
  4. Only uncheking it will work.
  5. N/A
  6. This problem has happen with some malware in 3.9 it now happens with 3.10 with the eicar test file.


Hi guys.

My system is my signature.

Related to CIS 3.10 and Spy Sweeper 6.1 (only antispyware) slow sweeps or hang ups.

I excluded all SS processes from Buffer overflow protection as advised by OmeletGuy early on. Still got hung up at 27 minutes into the sweep. Deactivated D+ completely; However, SS still took almost 20 minutes to finish. Exited CIS 3.10 from sys tray and it took SS 17 minutes to finish the full scan.

So I reinstalled CIS 3.9 again and SS is back to normal with full sweeps at 7 minutes.

Please see attachments.

[attachment deleted by admin]

Got also a Bug!

First of all, sorry for my Bad english.

I use CIS 3.x for a long time, whitout the AV Modul.
Since the Update from Today (to Version 3.10.xxxx), i got 2 probs.
If i start the IE8 and afte the surfing i shut them down, after i have in the Taskmanger 3 Entries from a aktive IE and the CPU is to 99% in use, permanently. I have to terminate this 3 tasks by hand, after this, the System works normal. Whith the FireFox 3 it is exactly the same problem. only the Opera has no problems and work fine like always. After Uninstalling Comodo 3.10 and Comodo Safer Surf, the problem has gone and all works fine again. After Re-Installing CIS 3.10 (whitout AV Modul) the Problem is back again. My System: AMD Athlon 64 3200+, 1Gig DDR400, Asus A8N-SLI SE nForce4 Chipset, nVidia GeForce 9800GT 512MB, Creative Labs Audigy 2ZS, WinXP pro 32bit Service Pack 3, Avira AntiVir Personal, a2 free. All with the newest Drivers

Windows XP SP3 (English, 32 bit)
CIS 3.10 Firewall, NOD32 v4.0 Antivirus

Several MMORPGs use a program called gameguard for security. It’s a very aggressive piece of software which requires high privilidiges to work.
In CIS 3.9 (and lower) there were problems with gameguard and the Defense+ part. With D+ turned on, and gameguard started all the “user name” disappeared in the task manager (see sceenshot) and it proved impossible to login to Windows Live Messenger. Turning D+ off (completly/reboot) solved these problems.

[s]CIS 3.10 is however a greater problem. Even with D+ already fully disabled, and just the firewalll running the “user name” still disappears on the task manager (crtl+shift+esc when gameguard (rev 1352) is running) But now it is impossible to start ANY program at all. So when gameguard is active, i can’t launch any other program. Programs already open can be used normally.

Turning D+ on or off makes no change. Running in “proactive defense” or “internet security” or “firewall security” doesn’t make any changes.[/s]

An old topic runs here (of the previous problem)

After a clean install of CIS 3.10 (rather than the upgrade from 3.9) the problem is changed a bit
With D+ enabled the taskamanger user names disappear, and i fail to start any program. But with D+ turned off everything works again.
How could it be that a clean install of CIS helped, and that the upgrade processes caused new problems?

[attachment deleted by admin]


Windows XP Pro, SP3
CIS 3.10 Firewall, NOD32 v4.0 Antivirus

I put in a bug report because of the similar problem in running “16 bit” applications (after installing COMODO 3.10.102194.530), I can run cmd and get to virtual DOS window. When running old dos files, they come back with “the system cannot execute the specified program”. Running them in windows results in "“attempt to access invalid address.” error message.

I noticed that ntvdm.exe becomes a task, but wowexec.exe & opware16.exe do not start.

Also, when running FireFox I would have more than one instance in processes (task manager) and after closing the browser, firefox.exe remained as a running task. Even happens if FireFox is opened in safemode with all add-ons and plug-ins disabled. (It hogs about 95% of CPU time, requiring manual stopping of all firefox tasks). Same when using IE8.

I did shutdown COMODO, then stopped its services (Task Manager), but the faults remained. Next I went to msconfig and stopped the comodo services from starting, rebooted and still had the same problems.

Last step was uninstalling Comodo, reboot, and try opening, closing browsers, try running 16 bit applications. Guess what, they all work as should be. (and no more processes having to be stopped).


Ok. Since I have to register to post on this forum, this is another thing that is pissing me off. See, my problem is likely a little different from other people’s and only started when I updated the Comodo Firewall to the newest version, yesterday (Friday night) or earlier today (Saturday morning). My problem is that I can no longer use my virtual drive program when Comodo Firewall is active. The details and specifics are below:

Today when I tried to use my virtual drive program, that being DaemonTools, to load up and use an image file with my computer for viewing, it wouldn’t work. The virtual drive program wouldn’t even load up. When I try to open up the virtual drive program now, with all the settings set (Firewall and Defense+ set to “Safe Mode”), I get a pop-up window as shown in the accompanying attachment (daemontools.jpg). Because I recently (Friday) also updated my isobuster program, I uninstalled that to see if that was the problem. The problem still persisted.

When I finally disabled the Firewall and Defense+ options on Comodo Firewall, I was able to re-install the virtual drive program of DaemonTools with no problems, and even use it. For reference, I am using version 4.08HE (32-bit) of DaemonTools which is available through Besides the program, it also installs a .sys file called sptd.sys, which stands for SCSI Pass Through Direct (SPTD) layer. This is required for the program to work. Of note, the program installed the file to the directory of c:\Windows\system32\drivers.

As I do want to mention, before this lastest update to the newest version of Comodo Firewall, the virtual drive program worked with NO problems. And even though the version I use for the virtual drive program is a little older, as there are a few updates since I got my version, this should not be an issue since when the new version of Comodo Firewall came within the last day or two, only after it was updated did this problem occur.

Now since I became aware that Comodo was the problem, I tried testing it with reactivating the firewall. When I reactivate the Firewall portion and set it back to “Safe Mode”, the virtual drive program still worked with no problems. When I reactivated the Defense+ option back to “Safe Mode”, the virtual drive program did not work. Even when I set the Defense+ option to “Training Mode”, it still did not work. So something new in the Defense+ engine has to be conflicting with the virtual drive program and/or driver installed to use it properly.

Now, for the numbers thingie to post:

  1. Your Operating System (32 or 64 bit) and Service Pack revision (Instructions for XP and Vista):

    I use Windows XP Home with Service Pack 3 installed, 32-bit

  2. Other Security and Utility Software Installed

    Although none of the other security software has created a conflict like this, I do use Avast Home Edition 4.8, a-squared free (lastest version although it is only on demand use, not active use), and I use Windows Defender.

  3. Step by step description to reproduce the issue

    Well, the easiest way to reproduce this issue is to go to and download any version I guess of daemon-tools and try to install it, as it will first try to install the sptd.sys file and after that, ask you to reboot your computer and then it will try to install the daemon-tools program. It should install the sptd.sys file with no problems but it will then fail on the daemon-tools program install. Even with the newer version available online, that is the free version, that failed to install also while the firewall’s defense+ setting was active.

  4. How you tried to resolve the problem

    Read above. I was able to test the installation by deactivating the Defense+ settings and with that deactivated, the virtual drive program was then able to be installed and also used. The Firewall settings did not affect the virtual drive program it seems. When the Defense+ settings were reset to anything like “Safe Mode”, the virtual drive program was no longer working.

  5. Upload Memory Dumps on crash if you encounter any

    None are available.

  6. Attach screenshots to your posts to clarify the issue further

    See the attached photo for the result of when you try to run the program while the Defense+ settings are active and set, like to “Safe Mode”.

    Just in case the photo can’t be seen, it says the following:
    “Initialization error 0.
    This program requires at least Windows 2000 with SPTD 1.37 or higher.
    Kernel debugger must be deactivated.”

  7. Please put any False Positive Reporting here

    None are available.

  8. Any other information you can think of

    Why this issue has arisen with this new release, I have no idea. Although there is a work around, I do like having my Defense+ settings active while on my computer and connected to the Internet. And also, having to disable and reboot my computer each time I want to use the virtual drive program is kind of annoying. I just hope you are able to resolve this issue so that I can use the virtual drive program without any problems while also using Comodo Firewall with all the settings active. As I said, this issue just started a day ago after updating Comodo to the new version and never was a problem before.

[attachment deleted by admin]

Same problem as NeilG

When trying to run ‘command’ , I get ‘attempt to access invalid address’. ‘ntvdm.exe’ runs as a task, I am unable to kill the process. Browsing via Firefox (3.5) is slow, I can close it without problems though.

Win XP Pro SP3 (32 bit)
COMODO 3.10.102194.530
Avast 4.8.1335

CIS 3.10 .529 and then .530

  1. Operating System: Windows XP Pro SP3 32bit

  2. Other Security and Utility Software Installed: none

  3. Step by step description to reproduce the issue:
    The same problem as NeilG and cerebrus have indicated above, (and here in Russian CIS forum) with 16-bit and DOS applications

  4. How you tried to resolve the problem: A lot of SIC components settings, disabling components…
    The only solution is found - complete uninstallation of CIS

5,6,7,8. -//-

  1. Asus X50R laptop

  2. Vista Home Premium 32-bit SP2, user account has admin rights, UAC is disabled

  3. no other security sw

  4. Comodo Firewall is usually in Custom Policy mode, D+ in Safe Mode, Antivirus is not installed.

  5. Problem description: I use conman.exe (console manager) console program to launch and manage multiple instances of FAR file manager (ancient console program). With previous CIS version (3.9) I had no problems, with 3.10 conman.exe window fails to close after quitting the last FAR window (have to force closing it by clicking on the x icon on the window), it fails to launch new instances of FAR (within the same conman window) and generally conman key shortcuts and commands don’t work. In short, conman.exe does not work anymore.

Reproducing the problem: “conman.exe far.exe” starts up FAR within conman in a window, F10 in FAR exits FAR and it also should close the window, but it doesn’t. Instead, FAR closes and leaves a fully black window behind (the window frame and title bar are still normal, it’s like a normal console window without any text). Clicking on the x button closes the window. Apart from F10 (exit FAR), conman keyboard shortcuts (spawn another FAR instance, etc) don’t work.

  1. Disabling Defense+ doesn’t help, permanently disabling D+ or uninstalling CIS solves the problem. Clearing all D+ rules also didn’t help.

  2. no crashes

  3. screenshots wouldn’t help

  4. I deleted all rules relating to conman.exe or far.exe and expected D+ to ask me questions pertaining to keyboard hooks, direct disk access, etc but that didn’t happen.

Hey Everyone. :slight_smile:

Just a reminder… Some posts are being split to the COMODO Internet Security 3.10 Bug Report Discussion Thread. Because they are Either Non Bug Reports, NON-Responses to Developers, Responses to Users, And Other Discussion.

We need to keep this thread just for bug reports, and the other thread for discussion. People are already posting in that thread in reply to your bug reports, So keep an eye on them. It’s a little difficult but we need to work with this system together, Since CIS 4.0 is not out till end of year or next year. :slight_smile: Read first post of this Thread, Responses to developers are are off course OK! :wink:

This makes it a WHOLE lot easier for developers to read bug reports and making sure they don’t come up in CIS 4.0 so this is the most effective way.

So after this post… :slight_smile: Thanks guys. :slight_smile:


  1. Windows XP SP3 x32
  2. Comodo Memory Firewall, Avira Antivir Personal
  3. Boot up PC, allow all startup program to run, run Granado Espada, Xtrap will restart the pc due to interference of some sort.
  4. I disabled Defense+ permanently and it starts to run normally again. All start up programs are also running.
  5. Unable to make screenshot of the Xtrap error message due to Xtrap immediately restarting the PC. Only remember it’s relating to something about a kernel and program…
  6. Problem only started when I updated Comodo Firewall to the latest update available. (4th July 2009)

Comodo Firewall is really good for me ever since I started using. I hope I will be using the D+ disabling only as a temporary fix. :-TU

This version of CIS prevents SpeedFan (v. 4.37) from launching properly. Perfmon reports 95+% of processor time is spent on Speedfan, which doesn’t get to the normal launch panel.

  1. Your Operating System (32 or 64 bit) and Service Pack revision (Instructions for XP and Vista)

Win 7 X64 v. 7232

  1. Other Security and Utility Software Installed


  1. Step by step description to reproduce the issue

Install Speedfan on a clean PC. Observe normal start. Close Speed fan. Install CIS. open Speedfan. Observe failed start.

  1. How you tried to resolve the problem

Reinstalled both apps. Set speedfan as a trusted app.

Overview - Browser (both IE & Firefox) remained active in memory after terminating application and hogged the processors. The process can be killed in Task Manager. It looks like a conflict with Safe Surf.

CIS 3.10.102194.530

Operating Systems
(a) XP Home 32 bit SP3
(b) Vista Home Premium 32 bit SP1

other security software - Comodo SafeSurf

To reproduce fault, start browser (Internet Explorer or Firefox) and then close browser. Look at Task Manager and order processes by CPU usage. Browser .exe remains active using nearly all processor resources. On a dual processor machine it hogs just one processor. It can be stopped in Task Manager

Reinstalled CIS without Safesurf on Vista machine → cured problem
Removed Safesurf from XP machine, rebooted → cured problem.

I did a clean install but I can’t update the AV.

??? ??? ???

  1. WinXP SP2

  2. Avast 4.8 antivirus

  3. Problem with DAEMON 4.00HE run after update. Reinstall or upgrade DAEMON is impossible (always displayed error message during installation).

  4. Just one solution is the downgrade the CIS to 3.9.95478.509 version.

  1. Windows XP Professional SP3 32-bit
  2. Malwarebytes Anti-malware 1.38 free (on demand)
  3. AV shows no when updating even if CIS has Displayed Ballon Messages.
  4. Its random some times it does some times it does not.
  5. N/A
  6. This problem happens with some AV update, FP fixes seem to show a popup, When a update has a new malware additions no popup hapens. This sometimes does not happen.


It seems we have a bug with 16 bit applicaitons. We will fix this issue this week. Until we fix it, a temporary fix would be renaming guard32.dll in c:\windows\system32\guard32.dll to something else and restarting your computer. When we update CIS, you can restore it back.

Sorry for the inconvenience.