attempt to access invalid adress

After updating to CIS 3.10.102194.530 I can not execute It fails with “Attempt to access invalid address.” Trying from the CMD promt the message is “The system cannot execute the specified program.” Before updating CIS it worked flawlessly. Both my systems are affected. :frowning:

My main system:
Dell Dimension 8400, 32 bit CPU
OS: Windows XP Professional SP version 2002 SP3
Virusscanner: Avast 4.8 Home edition
CIS 3.10.102194.530
Logitec, Soundblaster software
Dell Photo AIO Printer 922 software
D+ and firewall running in safe mode
Problem is the same for administrators and limited users.

I see the same problem so it is not just your system.

Same problem here !!!

same here. for weeks i did not play in dosmode so i can not trace it back to the update, but now!! :frowning:

Oh my god, so that’s it! I’ve spent the past two days (missing some work) trying to figure it out. So how do you roll this thing back?

I too seem to be having the same problem, after updating to 3.10.102194.530. Have run a virus scan in safe mode, came up with nothing. Will run a rootkit detection later. Hopefully it is due to comodo.

XP Pro SP3

Here is another thread about it. So am guessing it is Comodo.

3.10.102194.530 major problem: Kills DOS programs!

What are your CIS settings guys?

Can someone attach so i can try to find a solution.


Are all of these issues with XP? I haven’t seen it under windows 7.

Seams to be XP only, Vista and W7 are fine.

G’day, is not at fault.

I put in a bug report because of the similar problem in running “16 bit” applications (XP SP3, COMODO 3.10.102194.530), I can run cmd and get to virtual DOS window. When running old dos files, they come back with “the system cannot execute the specified program”.

I noticed that ntvdm.exe becomes a task, but wowexec.exe & opware16.exe did not start.

Also, when running FireFox I would have more than one instance in processes (task manager) and after closing the browser, firefox.exe remained as a running task. Even happens if FireFox is opened in safemode with all add-ons and plug-ins disabled. (It hogs about 95% of CPU time, requiring manual stopping of all firefox tasks). Same when using IE8.

I did shutdown COMODO, then stopped its services (Task Manager), but the faults remained. Next I went to msconfig and stopped the comodo services from starting, rebooted and still had the same problems.

Last step was uninstalling Comodo, reboot, and try opening, closing browsers, try running 16 bit applications. Guess what, they all work as should be. (and no more processes having to be stopped).


Was fiddling around, I can observe similar things happening as NeilG Now have four instances of ntvdm.exe running, I cannot kill any of them. Firefox lags for me, browsing is a problem. However, I can shut it down properly. Am running FF 3.5.

EDIT: Wrong Spelling.

I have the problem on Vista SP1 32bit. will not start. It says it is not a valid win32 application.

My problem is caused by explorer only being allowed to run an .exe file and not a .com file. If I allow .com files as well in computer security policy runs OK.

Reply #12 under that thread worked for me, although going back to 3.9.95478.509 would be safer.

From the head developer:

If I try accessing the command prompt typing or navigating to <> on my HDD, it does not work. However, if I type it works like it used to before the update.

I am on Windows XP SP3 and Product Version


Hi Guys

Please read here:


Yesterday I’ve done the last update (531) and now all is working fine !