CFP v3.0.7.208 Beta Bug Reports [Closed]

Pls post bugs relating to CFP v3.0.7.208 Beta in this thread.
thanks
Melih


Edit by Soya: [u][b]Known Bugs[/b][/u]: 1. Profile option may crash on Vista x32 and x64. 2. Show balloon option changes goes into effect after firewall application is restarted.

[font=Comic Sans MS]Please uninstall any existing CFP version before installing this or whenever you’re about to install non-final versions. This is important to avoid stability issues.

Only way i know to reproduce this is to just open up “View Active Connections” and thats all.After a few moments it crashes for me.Only major applications i have opened are Firefox and Shareaza.Im on Vista x86 2gb ram athlon64 X2 4800+.The crash happens consistently.

Ok,something i just noticed,if i close Shareaza down then the crashing stops.I have “View Active Connections” open and im just idling and no crash yet in almost 5min of letting it sit.I will repost the screenshot

Another note,after opening Shareaza back up and trying “View Active Connections” again,i instantly get the crash.So it apparently has something to do with this app.

[attachment deleted by admin]

I don’t know if I should post this is bug part of forum, but I’ll do it anyways.
I installed CPF 3 BETA in safe mode, rebooted and it started fine. But Firefox and MSIE wouldn’t work.
So I rebooted again. This time I got a BSOD.

SESSION3_INITIALIZATION_FAILED

STOP: 0x0000006F (0xC0000022, 0x00000006, 0x00000006, 0x00000006)

No minidump since it crashed before windows booted.

Ragwing

EDIT: Thought I’d include some more information.
Running 32-bits Windows XP PRO, 2.1 Ghz, 768 MB RAM.
Other software running: Avast Home 4.7, BOClean, TeaTimer, SnoopFree 1.0.7 and CMG 1.0 BETA

Well, one “bug” that I have happen to me quite often, is that every week I lose most of my settings…and this week ALL my Predefined Policies are gone, ALL my Network Security Policy Global Rules are gone…nothing!
Oh, and my “View Firewall Events” log seems to be not working anymore. Where it used to fill a page almost immediately, for the last week it says “No items to show”, even tho I Know that UDP port 33852 was blocked numerous times, it stills shows empty.

I finally had to turn the Defence + settings down to Learn All because it would constantly forget what I had allowed and every few days (about a week) I would have to go thru a Landslide of popups again, all for items I had already declared. I just got so overwhelmed that I turned it down just to have some peace…seriously, I couldn’t get ANYTHING done! So many popups that most of my time was taken up dealing with those.

I guess my biggest bug with the product so far is that it can’t seem to remember anything yet, hopefully the Beta build can address this issue.

Dave

Chappy wrong thread :D. The beta was released today so try it out :D.

Many thanks for this release, it looks nice!

I have XP SP2. Three observandums,

  1. If I go to “Firewall / Common Tasks”, and click “View Firewall Events”, the log is opened as expected. However, nothing happens when I click “More…”.

  2. CPF didn’t prompt for Firefox, IE7, Pidgin or Google Earth, in terms of connections (Defense+ did notice). They got internet access without asking me. Maybe this is because of a white list?

  3. Alt+Tab; the icon gets very “pixely” (is that how you express it in English), as if it was upsized from a smaller icon. Minor bug. :wink:

Thanks,
/LA

EDIT EDIT EDIT
As for #2, forget about it. I marked everything as “safe” during installation, which explains why these programs were allowed! Sorry Comodo for this false bug report!

Today???

I thought it said the 16th?
Ooops…heheh-heh…guess I better get the new build d’loaded and get er set up…THX for the heads-up Coolio!!

Dave

P.S. - Actually, the thread for the Beta build JUST appeared at the top (above this thread) for me after I refreshed from this posting, so now I see where to get it!
Ok, so lets hope this build remember the rules! I’m going to start from scratch with this new build instead of saving config settings and transferring. I can’t wait till we go Publc Release with this puppy!!

This happened to me too… I downloaded and isntalled latest build for x64… Im on XPx64…
Then installed normally and rebooted… After reboot everything went fine, but Firefox and IE didnt load any pages… They were allowed etc. I use Avast too, tried to turn it off but didnt help. Tried to turn Comodo off, didnt help… :stuck_out_tongue:

And now after uninstalling Comodo, everything works as usual…

Strange, I haven’t had any of the bugs you have experienced except for the “pixely” icon lol ;D

Anyways on a more serious note, I must be lucky because I have experienced no bugs whatsoever, I’ve tried reproducing the bugs mentioned above but have not been able to :-\

I’m using Windows XP SP2 as a test environment.

Now that you mention Avast…
I think I read something about changing Avast web shield redirect port from 80 to 12020 or something.

Ragwing

And it does ask you to allow/block Firefox and those programs, when you execute them?

I should add that for observandum #1, it did occur the second time I tried it. First time it worked.

/LA

Ps. I was too afraid of those alpha versions, but I’m trying this beta - I’m very proud to be a little part of this development! Thanks!

I got the same 6F bluescreen and the More button not workng when I first installed the firewall with BOClean and AVG running and had to go to safe mode to uninstall it using the uninstaller from the Start menu. The installation would not complete correctly either. It sat there for 10 minutes before I finally clicked on it and it said to restart without the setup screen for the Trusted Zone showing up.

The next install I disabled both of the above programs and it installed without a hitch and I have rebooted multiple times with no problems. Everything works as it is supposed to so far.

Guess the antivirus and BOClean was stopping something from working right.

Running nice and smooth now.

Using WinXP Pro (x32).

jasper

After rebooting, waited until desktop loaded, then tried to open CFP3b from systray icon. Seemed like it did nothing. After a few minutes I tried the desktop shortcut. Same thing; no apparent response. No menu available from systray icon on right-click. It just sat there like a rock.

Finally, about 3 minutes later, it opened the gui, and the context menu (in the middle of the screen).

Looking around, checked D+ Logs, where there were two events for BOC. Clicked on “more” to open the detailed view. It showed to be on D+ Today (that was highlighted) and there were tons of entries for System being blocked on ports 137, out to 138; all LAN traffic. Thought that was odd; checking other D+ areas were blank, then back to Today was blank as well.

Checked the FW Today, boom! There were all the blocked System entries, right where they should be.

Seems there are still some oopsies! with the logs…

LM

PS: During install (in SafeMode) the Profiler window showed up completely behind the install window; I didn’t even know it was there for several minutes. I was waiting for the installer to finish, and finally dragged it around the screen a bit to kick it into gear; then I noticed the Profiler. Profiler, once run, seemed like it paused a long time, several times; dragging the window a little bit got it started again.

Yes that’s correct, so far I’ve had no issues about Comodo asking me about applications, seems strange that some people are and others aren’t.

Remember: Defense + manages applications, the Firewall part manages network…

So think of Defense + as the application monitor but with very advanced HIPS.

Maybe I confused those things a bit, I don’t know for sure. But I do think that I executed Google Earth (and maybe the others as well) with just a little Defense+ message, no big alert that required an answer from me.

Tried to reproduce this (rebooted), but I can’t get it to happen again. It works now, though it didn’t work before.


Another minor thing: installed BOClean 4.25. Wished to close a Defense+ message (image below), but it didn’t go away no matter how much I clicked the “x”.

/LA

[attachment deleted by admin]

I didn’t install in safe-mode or anything. Although I did take the precaution of disabling CMG first… just in case. First impressions… very impressive.

On the first restart… I naturally opened the GUI. I added both trusted & blocked stuff (via tasks). Then I noticed that every single display within the GUI was blank/empty. I checked CFPs registry path & that was OK. I exited CFP (closing CFP.EXE) & restarted it. All there with one minor exception. Not tried another reboot yet.

Minor exception: My Customized Safe List files are not showing up from within the GUI… but, they are there.

edit

Hiya,
just found one minor bug:
I went to “Firewall Stealth Configuration” and set “I’d like to be completely invisible”. Comodo replies that The firewall is set accordingly. When I go back to check, the default (?) “I’d like to be completely visible from within a trusted network” is set.
Otherwise v3 seems to work nicely (thouggh I haven’t tried a lot of the many possible settings).
Cheerio,
grampa.

I have to try that… Will report tomorrow…

Every 2nd time I start CFP, my LAN network zone gets permuted from x.y.z.0-x.y.z.255
TO: 0.z.y.x-255.z.y.x
This happens consistently! AND I experienced the SAME strange permutations in the alpha version.

In the beta version I can not forward a port correctly through uTorrent, even though I have defined uTorrent as a trusted app. In the alpha version I could specify a single listening port for uTorrent and it worked! (my port IS forwarded correctly in my router). I also find it strange that uTorrent can not pass the port forwarding test even after I have shut down CFP - some CFP security policy seems to continue after shutting down CFP!!!. ONLY if I set the firewall to allow all OR the LAN network zone permutiation mentioned above is in effect, uTorrent passes the port forwarding test.

EDIT: I just discovered that I needed a Global rule to allow my port. I guess any application rules are no good if they are not allowed in the global rules…
(R)

Now writing after 1 AM, I also find it very annoying that the Firewall Events log seems to have STOPPED at midnight (no events on the 10th of august…), even though CFP has certainly blocked a lot since midnight (uTorrent for instance…).

PS. I am running Vista 32.