CFP v3.0.7.208 Beta Bug Reports [Closed]

Windows Security Center (XP Pro) doesn’t seem to detect Comodo properly for me. It says “COMODO Firewall Pro reports that it is currently turned off.”

Comodo beta seems to be working fine though.

Not really; D+ is more like ABA and most other advanced configs from 2.4, plus CAVS HIPS, plus more plus more…

There is AppMon as part of the FW side. It’s in Network Policy. Default settings are Learn Safe; you shouldn’t see FW alerts for known apps (if you did the safelist scan); I noticed it said this meant it would approve components of those safelisted apps - it didnt’ say it would approve the apps. But I haven’t seen an FW popup yet.

I’m also wondering how the “stealth” settings are supposed to work, especially for the middle one (ask me about stealth, for FW experts - sorry I don’t remember exact, I’m not at a v3 computer right now). If you utilize that, it creates a NetMon (FW Network Policy, Global Settings) rule to Allow All In. Nothing there to indicate a prompt to the user. Is there something else that configures that prompt?


As a test, I tried to run SoulSeek. This is configured to listen on port 2234. Comodo learnt the app and is set to allow all incoming and outgoing IP traffice from/to any IP address.

SoulSeek has a firewall and router checking feature, which reports that port 2234/tcp appears to be closed. I can see in the firewall log that Comodo is indeed blocking traffic received on port 2234.


I have had Comodo windows completely lock up (“Not Responding”) twice now trying to View Active Connections. I don’t get any error dialog. I can’t seem to end the Comodo Applications, and I can’t kill the cfp.exe process - I have to reboot.

You need to add a network rule saying 2234 coming in is ok.

Read here:;msg2529#msg2529

That was for the version 2 but should be easy enough to follow if you find where the network rules are located.

Probably self-defense, atleast you know now that even if a program freezes cpf it will remain alive :D.

This happens with many applications and may be your computer setup itself causing this.

Using 32bit Vista. Had Alpha installed, worked OK. Tried to install Beta Ran the .msi, It said I must first uninstall the current (Alpha) version, and prompted me to do so. Did so, and it requested a reboot. After reboot, tried to install the beta but it gives this error and terminates: “You seem to be having Comodo Firewall Pro - BETA installed using an older version of installer. Please go to 'Start > Control Panel > Add/Remove Programs section and uninstall Comodo Firewall Pro - BETA” … However it is already uninstalled. Stuck. What to do?

Note, I can’t re-install the old version and try to uninstall it again. Running the alpha installer says “This is an old version” and terminates.

Still stuck. Can’t get Beta to even start with install. Something need be cleaned out of registry, perhaps?

Any ideas appreciated.

EDIT: That was it. Removed Comodo-related entries in registry and was able to install Beta.

Ok, I have one too
When installing the new Beta I get the following error window pop up:

The file “inspect.sys” on Comodo firewall driver disk is needed…

Ummm what driver disk??? 0 I just ran an EXE file. - Will try to uninstall what it installed and try again later…

Me 3. Allow all, exit firewall, nothing worked. Only uninstalling solved the problem.
I also have Avast!, 3 strikes you’re out? heh, not literally, but i tend to agree that this is the problem. I’ll reinstall tomorrow.

Same issue that I had with version - My Network Icon in the system tray is still missing.

Another issue too, my anti-virus application keeps saying “C:\ProgramData\Comodo\Common\DB\DDB\DLL\327.sld” is infected with a virus.

ok, got another one, and this one to me is a real BIG one…

After DELETING every single pre-defined rule I could find in the firewall (I really do not like a program defining what is safe, I prefer to do that myself), I decided to test it out by opening one or two programs onto the Internet…

Comodo DOES NOT stop Internet Explorer from communicating with the Internet (remembering of course that I have deleted all predefined rules from Comodo) -0 it quite happily connected to the net, but loaded any page I wanted it to do.

This to me is a very serious security breech, if there are no rules at all, then in theory Comodo should notify me if ANYTHING wants to get out, wether its a browser or a virus…

Ohh I almost forgot to mention one other little thing…

I cannot end task on cmdagent.exe in task manager (this is after I have exited the firewall on the taskbar itself) - how come?? is there a reason I cannot end task on cmdagent.exe??
I would have thought if I wanted to close all instances of a program for a reason, I should be allowed to… (In this case I wanted to close all instances so I could uninstall it ready for reinstalling…)

Cannot get the log to work if I have the date set current. I have no log entries in the first window but the More window will show all of the entries listed in yesterday and have today’s date.

If I set my system date to yesterday then I get log entries showing as current in all log windows.

This is weird as it all worked before. Might need to do a reinstall again to see if that fixes it.


EDIT: Did a reinstall of the firewall and still no log entries for the current day. Will keep digging.

Perhaps the bug is that it did not delete the rules? The GUI shows no rules, but where it matters (registry?) they are still there?

Not completely sure but that could be termination protection stopping you from doing that

Same problem here. Getting security center icon in sys. tray and pop-up.

I ended up doing a Winsock fix as my connection was messed up by the BSOD’s. I finally got the V3 beta and CAVS and CBOC to play together nice. I even have my logs back. This started when I installed CMG and things went to heck after that.

Now I can boot without getting BSOD’s and I am able to change settings on all 3 programs without any trouble.

By the way, I love this firewall.


Same thing here!


I never had to do that with V2. It doesn’t seem necessary now either - I’ve got it working now, but I don’t know why, what I did etc :wink:

I believe uPnP uses port 2869 which is handled by svchost.exe. This is currently set to “Outgoing Only” (is that the default?). Comodo was blocking this activity, so I tried various times to make svchost.exe a trusted app, and then restart my router and SoulSeek to get it to make uPnP requests again. I was still getting blocked activity in the firewall events window.

I went to Shields Up ( and did a port scan, which showed that the port was open when the application was running. I closed the application, and the port scan status then showed stealth. Everything now seems fine. My svchost.exe is still “outgoing only”, and I have not entered a global rule for port 2234.

I think you were saying I needed a global rule before “block all incoming requests” to allow port 2234 incoming traffic. However, SoulSeek application rule allows all IP In and Out from IP Any to IP Any, so surely it isn’t necessary to tell Comodo to allow 2234 inbound as a global rule (which wouldn’t then block it if the app wasn’t running?).

The IP address node values seem to get reversed when I restart Comodo. eg. I had entered a network zone “ -”, which now says “ -”.

There are multiple (three) rules for BOClean, but they all show exactly the same properties when I click “Edit…”. See image below.

(Running XP SP2 32bit)


[attachment deleted by admin]