Latest update ruined functionality of some MMORPG games

Yes. With the latest update, 2Moons, 9Dragons and Silkroad online- that uses NProtect Gameguard for anti-hack , anti-bots, not functioning anymore. I uninstalled CFP in order to play again thsose games. I think NProtect Gameguard uses a rootkit sistem to install a sort of “shield” in order to protect those games from hacking, and CFP blocked somehow functionality of "trusted " rootkit. Even if i shut down CFP , those games not start anymore, 2Moons restart instantly my system when try and start the game…

Same here razor 74. My son’s on-line game FLYFF which uses NProtect GameGuard resets my computer everytime NProtect is in the “authenticating…” stage. I completely uninstalled version and clean-installed version which completely solved the problem.

I see the problem…

IMPROVED! Increased D+ ability to protect itself from already installed rootkits.
Nprotect probably scans comodo to make sure its not used for hacking and when comodo refuses to be scanned nprotect refuses to start the game :D.

The problem is - i didn’t find any solution to problem. Any rule i created to Gameguard.des snd any gameguard file - even to game executables and laucers( i set a trusted rule for all), not solved the problem. Gameguard logo stay much longer on the screen when game starts, and in the moment when game try to initialise, the computer suddenly restart without any dump memory… After i uninstall CFP, anything returns to normal. Maybe you can insert an exception for that type of game protection, or a predefined rule, or the posibility the user can create a rule for Nprotect Gameguard.

So some1 knows how to solve or i need to install v in order to play?? (:AGY)

Can you play if Defense+ set to disabled (right click icon in tray->Defense+ ->disabled)?
Is anything related shown in the Defense+ log after unsuccessful attempts to launch game?

No. It’s strange because , even if i shut down the firewall - games don’t start. Only if i uninstall the firewall problems gone… In logs don’t see anything. I’l try again and see if is anything noticeable in D+ logs. :frowning: This type of games uses mor executables when initialises. First start a sort of launcer witch search first for servers status and updates if any is available. This launcer execute Gameguard and 2 other executables of the game. Gameguard validate system environment , and if everything is ok , set permission to execute the main game executable. This big problem apear between gameguard initialisation and main game executable initialisation, after that system fail and restart…

As i understand correctly you didn’t have this problem with previous 3.0.21 version. Is that right? If so, do you have this problem if identical settings for 3.0.22 version are used?

Can you please disable Defense+ permanently (Defense+ → Advanced → Defense+ Settings), restart computer and report whether problem is gone.

I played again 2Moons with latest CFP installed. I disable first temporary D+ and nothing new is happening… After that, i shut down CFP and the same problem. In D+ log is nothing about Gameguard or any other executable. I didn’t try to disable D+ permanently. I will try now and see what’s happening …

Yes, with D+ permanently disabled, games start normally. And again - yes with previous version and the same setting (imported in latest version) everything works perfectly. In conclusion - D+ permanently disabled has the same effect with CFP uninstalled…

Can you please check whether this solves problem for you with defense+ enabled:
Under Computer Security Policy locate COMODO Firewall Pro group, click edit ->protection settings->interprocess memory access->NO->apply everywhere.

:frowning: I checked, and problem persist. With interproces memory activated there is no difference… And I checked Gameguard.des and GameMon.des and interproces memory is “NO” too…

Any new ideea about this problem?

try set fw+defence to learn mode for while a run the games, may be help…

Same happens with Cabal Online (uses Game Guard). I get BSOD them moment Game Guard loads, and for me only solution was to remove Comodo Firewall, since disabling didnt help. I attached 3 mini dump files.
My OS is Windows XP sp2
PC: AMD Athlon XP 3200+,1 GB ram

[attachment deleted by admin]


We need to give the CFP Devs a little more time. This issue was reported at the weekend & if they’re at work early, they’re probably still staring at the coffee machine at the moment (US office time). In short, they’re probably not specifically aware of this issue as yet.

Works with D+ disabled permanently. It’s the only one solution for the moment…

BTW for the mods. Gameguard incorporate a self protection for security module…

Since they’ve had a few cups of coffee by now, I sent a PM to the CFP Devs & pointed them at this topic.


anything new ? coz i play to muonline and i had some BSOD, sadly i had to remove CFP, so now im waiting for some news…

Hi grislou, welcome to the forums.

I don’t know, I’ll send another PM (Personal Message) to the Devs & try to find out the status.