COMODO Internet Security 3.9.74913.496 RC1 Bug Reports - LOCKED

Please post all bug reports & BSOD’s here and make sure to include:

  1. Your Operating System (32 or 64 bit) and Service Pack revision (Instructions for XP and Vista)
  2. Other Security and Utility Software Installed
  3. Step by step description to reproduce the issue
  4. How you tried to resolve the problem
  5. Upload Memory Dumps on crash if you encounter any
  6. Attach screenshots to your posts to clarify the issue further
  7. Any other information you think that might be useful

It’s vital to provide all this information, so the developers can quickly identify and fix bugs faster.

  1. OS: Windows 7 x64 Build 7068 (I know, not officially supported yet but it should be similar to Vista x64 SP1 or higher)
  2. No other security software installed
  3. As safe assumed applications aren’t fully trusted:

    Also “Protected files/folders” and “Protected Registry Keys” should be set to allowed. And applications that are assumed as safe should be able to run any other program. That’s how it looks:

    And that’s how it should look:

Another issue: There is no keylogger- and dll injection detection on x64: Comodo fails all tests of AKLT:

Comodo x64 & SSS ( ):
Firewall doesn’t block the outbound connection test the first time it is started (SSS says ICMP packet could be sent). The second time I run it Comodo blocks it correctly. It really happens only the first time you run the ICMP test, after one try Comodo will catch it!
If I remember right the problem only appears wit the x64 bit version, the 32 bit catches it also at the first time.

The x64 version also doesn’t detect windows messages and taking screenshots.

I hope not detecting windows messages, dll injections, screenshot taking and keyloggers is just temporary until hooking at ring 0 for those on x64 is added :slight_smile:

Thats the way it is designed right now. Protected Files/Keys will be granted the access one by one while automatically learning.

Ok, as long as the user doesn’t get unnessesary pop ups everything is fine :slight_smile:

GUI glitch:

Summary window: Virus Defence should be Virus Defense (for the English - US translation).

I also forgot to add to the known issues list that X64 Defense+ does not have all the hooks active in this version.

So basically I am using a crippled version at this time (Vista Ultimate x64).

Are you referring to Vista John ? :slight_smile:

Concerning the x64 Defense hooks not active yet. Will this make any of my testing around the program less reliable in results than the x32 version?

Yes. The results will be unreliable and it will fail to detect some tests. We will try to update the x64 version tomorrow. You can test with it.

Thank you, again, Egemen.

Also, where is The realtime virus scannig Stateful should be The realtime virus scannig is set to Stateful, as Network and Proactive Defense.

I have installed the 3.9 beta on Vista 32bit. I don’t know if this is on purpose or not, but I noticed that the help menu doesn’t open.

This bug remains.

I didn’t receive any ThreatCast ratings until now. Does CIS intallation requires internet connection to TC proper function?

Yes, TC gets rating from on-line database so you need to be connected to the Internet to receive TC ratings.

Windows x32 XP Pro SP3. I unistalled the previous version, cleaned my system and then I installed this beta. All rights as far, except that the firewall doesn’t alert me when I run for the first time Opera browser: I have only the alert by Defense +. When I run for the first time IE 7 I have the alerts byr the firewall and by Defense+. Firewall setted in Custom Policy Mode and Defense + in Paranoid.

  1. Your Operating System (32 or 64 bit) and Service Pack revision (Instructions for XP and Vista)
    Windows 32bit XP SP3

  2. Other Security and Utility Software Installed

  3. Step by step description to reproduce the issue
    ( 1 ). Run a Scan
    ( 2 ). Loopiing Scanning on the first *.lnk file

  4. How you tried to resolve the problem
    ( 3 ). Try to stop the scan.
    ( 4 ). Can not stop this looping scan.
    ( 5 ). Open Task Manager
    ( 6 ). Can not stop cmdagent.exe
    ( 7 ). Start->Rebooting PC
    ( 8 ) . Can not reboot
    ( 9 ). Force NoteBook PC down by presseing the power key for about 5 minutes.

  5. Attach screenshots to your posts to clarify the issue further
    Please see the attached 2 screen.
    Attached 1: looping scan.
    Attached 2: cmdagent keep runing after press stop scan.

[attachment deleted by admin]

windows vista HP 32bit
Just CIS 3.9
Started a scan the about 10mins later a "Microsoft C+ " or some program/component of that sort displayed an error message and the system locks up so I can’t get a print screen, it might be a one off so I’m scanning again to see what happens.

EDIT: Scanned again, here’s a screen shot I managed to get before it locked up, I would like to point out that in the scanner it keeps scanning the same file over and over again just before it crashes (See Screen Shot)

[attachment deleted by admin]