Windows 7 Action Center alerts that Comodo Firewall is disabled

This happens SOMETIMES (not very often).
USUALLY about minute after I log into account when computer is started.
Icon is visible in tray.
SOMETIMES changing firewall mode between “Safe Mode” and “Block All” fixes it.
But SOMETIMES problem persists even after computer is restarted couple of times in row.


I confirm this, it happens sometimes on my Windows 7 with CIS too.

I think Comodo is already aware of it.

Hi PiotrM,

We are aware of this, and we are checking on it

W10 Famille - 21H1 - 19043.1110 / CFW :


It’s been 2 times in 3 days that Windows indicates that CFW is deactivated while it is operational (widget and systray are animated).

I ran the “Repair” function: no error and CFW was still not recognized by Windows.

I reinstalled CFW.
During the installation, my AV quarantined the file \AppData\LocalTemp\fusion.dll.tmp

Edit : the analysis of cfw_installer by the AV is negative.

It seems that you have some other AV software installed, there could be compatible issue with CFW.
You can uninstall that AV software and reinstall CFW.


You can report this as a bug by following the instruction here.

Hi domo78,

Sorry for the inconvenience, could you please share us the screenshot?

Hello C.O.M.O.D.O RT,

After the problem, I reinstalled CFW, so I can’t take a screenshot.

Is there a solution to reactivate CFW in this situation?
As it seems that I am not the only one, is it possible that when CIS/CFW is launched, CIS/CFW will impose itself as AV/FW as it does when it is installed?

I don’t understand why sometimes (rarely) it happens that the Windows protection system does not recognize Comodo immediately or does not recognize it at all. In fact, after a few minutes, the Windows notification appears telling me to check the protection of Comodo and / or Windows Defender. I know that Comodo is still active but this is very annoying. Then just restart the PC that the Windows security system (after 2-3 minutes) recognizes it and no notification appears. This thing rarely happens but I don’t know what it could depend on.
On this PC, before Comodo, I had Avast Free and the Windows security system immediately recognized it when turning on or starting Windows (maximum within 1 minute). In my opinion, this aspect should be improved in the next version.
I state that I have a 32 BIT Windows 10 PC with 4GB of RAM and a Centrino Core due Duo, but this happens now very rarely and with the old versions more often, only with CIS.

It’s a known issue.
The AV (not being AV CIS) on my Windows 7 is always recognized by Security Center after Windows start while CIS sometimes is not recognized by Security Center (but I know it is up and running correctly).

When will it be fixed?
Is it so difficult to solve it?
Surely it is not an indispensable bug to solve, but it is very annoying and for a user who is not an expert sees that warning and panics … ;D

If I knew I would tell you. ;D

No reason to panic with CIS installed. ;D

Yes, I know…
But if I install it on PCs of friends and inexperienced acquaintances they might panic, but beyond this it is also annoying for the experts in my opinion. :smiley: :wink:

You can calm them down when they do panic. ;D ;D
Experts get used to annoyances (well sometimes then). :slight_smile:

Great [at]CISFan. ;D ;D ;D
I hope to get an answer from the developers as well. :slight_smile:

Have never seen them answering anything for a veeerrryyyy long time…

I hope to get an answer from the developers as well.
I'm sure the developers and/or members here will tell us if they knew the solution


We were able to reproduce this on one of our machine after updating from CIS 7098 to CIS 8012. It is normal in some cases a restart is required during update because sometimes during update the task of replacing files may not be done when they are being used.

If you ever experienced this issue when there is no update, then please let us know. We had this windows recognition problem with old CIS but I think we don’t have this problem with CIS 8012.

Hello, this has happened to me twice already. I didn’t do an update but a clean install of the latest version of CIS 8012. It happened after installing it and using it for a few days.

The issue, as I’ve already reported earlier, happens also sometimes on my Windows 7 with a clean install of CIS 8012 (no update).
After Windows 7 start Security Center fails to recognize sometimes that CIS FW is up and running.

EDIT: Just after starting my Windows 7 it happened again, see screenshot.

Updated my comodo firewall on 7 10 2021
Binary update
booted my computer and got this message

“Failed to connect to a Windows service. Windows could not connect to the System Event Notification Service service.”

After several attempts for a solution & reboots
I used system restore & restored to before the latest “Binary Update” 7 10 21

Problem Solved
Computer back to normal

Windows 7 Pro - 64 bit
Comodo Firewall version