Trusted Software Vendors was lost

I had install CIS and today I found CIS was broken all my application, so I check my setting, and I found the Trusted Software Vendors was lost, I swear I had not change that, the just lost.

JoWa and Rhiana experience the same problem.


happned to me, comodo sucks

no software is perfect… and improvements needs to be made. for that reason a software does not suck. For those who view and are having the same problem try reinstall, in case you can’t wait until the bug gets fixed.

  1. install CSC and do the following steps before you run do the following things

CSC —> Settings —> General. Here you mark all besides the last option.

CSC —> registry cleaner —> settings. Here you mark the second and the last option.

CSC —> privacy cleaer —> settings. Mark the second and the last option

CSC —> disk cleaner ----> settings. Mark the second and the last option.

  1. uninstall CIS

No internet connection is recommended
3) run CSC and clean.

  1. install CIS


[attachment deleted by admin]

JoWa had the same problem. I gave him my vendor.n. file and it seems to be okey so please accept this file here and replace it with your broken/damaged vendor.n.

Thanks JoWa for beeing my experiment candidate ;D

when you repalce it you go to desktop —> My computer —> program —> comodo —> comodo internet security —> database. delete ONLY vendor.n. file.


[attachment deleted by admin]

Mine was gone today as well after a reboot. Had to reinstall. So was this a bad update…?

Update: I think I need to give the complete database floder and you need to replace all files in safe mode (that you do through pressing F8 during booting)

I will come back with more details.

Update: It seems to work. So you need to download the attached file and replace the files that are in database_CIS to datebase in safe mode.


[attachment deleted by admin]

this how you solve you “Trusted Software Vendors was lost” problem.

  1. Download the attached and extract it on your desk (so that you have it visible).

  2. restart the computer and press F8 and select safe mode.

  3. Now do these steps: desktop —> My computer —> program —> comodo —> comodo internet security —> database. Keep database window open, now you delete all files besides the files that are called pending, now copy what’s in database_CIS in database.


[attachment deleted by admin]

I have also been hit with this Trusted Software Vendor list issue and am searching for a solution.

I think the files Valentin forwarded are specific to his system.
The whitelist file “white.n” lists many executables in “/users/valentin” directory tree.
I wonder if installing it over the copy on another system might have unintended consequences?

I noticed that the “vendor.sha” he sent is identical to mine, and both have a modified date of 8/28/2010 which matches the date of the End User License Agreement file “eula.rtf” sent with the release. I expect the “vendor.sha” is the original from Comodo. When I compared “vendor.sha” to his still working “vendor.n” I found they were nearly identical. Only 32 vendor names were missing from his vendor.n, and 8 new ones were added at the bottom, possibly by him.

So I tried copying the original “vendor.sha” to vendor.n, and checked the Trusted Software Vendor list in Comodo interface. I now have what appears to be the full original list as of 8/28. I then removed the 32 entries assuming they were removed for a reason and now have a “reasonable” looking list. Unfortunately my vendor.h file is only16 bytes long versus Valentin’s file which is 4.37KB, which concerns me.

Can anyone from Comodo verify if copying vendor.sha to vendor.n is a reasonable thing to do, or am I left having to remove my vendor.n completely and rebuilding it from scratch by adding vendors for all of my applications?


PS: Am I the only one left feeling uncomfortable about how easily this Trusted Software Vendor list can be changed from outside Comodo?


I forgot to mention that when you do replace the damage/broken with the my attached database_CIS then you will have my vendor list but this was a solution that I found. In case people aren’t happy with this I will install my CIS complete on a Virtual machine extract and attached the orginal database.

eHuman, this was a spontaneous and an alternative solution, which seem to work. Pm me


but if you delete the local database CIS download the new database with the original server COMODO?
Sorry for my english
Yours sincerely

I will extract from CIS complete where is bug is not visible (as far as I know) and see but I give no guaranties .

You shouldn’t not delete database folder.

if it doesn’t work please follow my tip how to solve it (you will get my vendor list but what else can do? I works) delete files that you find unnecessary.

I will come back with results.

UPDATE: I have tried to extract my CIS complete this is all I get (look at the attached file)

I will check with only CIS and come back with the results


[attachment deleted by admin]

Nice work eHuman. I was a little uncomfortable with taking someone else’s files myself, and the odd 7z zip format didn’t help (thanks for posting a ZIP Valentin).

Had the same problem as everyone else yesterday. Oddly enough, overnight my file has changed again to include more appropriate vendors (ex. Microsoft, Adobe, Windows) instead of yesterday’s list of mostly Chinese companies, but it was still very short. Replacing with the .sha file does seem to work, but it would be nice to hear from Comodo just what the heck happened here and how to properly address it. The easy changeability of this file also concerns me. I’m shocked you can take someone else’s file and copy it to your machine and have it work, and that it is not encrypted in any way. I’d like to know how this is maintained on the local machine by Comodo.

As a recent convert (from ZoneAlarm), I must say I am not completely sold on Comodo yet and this doesn’t help.

I have decided to install CIS on a clean Win7 with no update or anything, just CIS. I will copy the database and I will attach it.

I have no viruses or trusted file that are malicious. That I can quarantine


My concern was less about threat vectors (I can see the files are safe) than using this as a method to solve a problem with CIS. Just doesn’t seem right. How can a Trusted Vendors List be trusted when it is stored openly and transferable between users so easily?

I don’t have the answer to that. Normally no one would go and mess around with such things.

This looks like a bug in an update process, not a bug in CIS, so tramsferring to AV (vendors are downloaded with AV updates) help for the moment. If identified as a CIS bug please ask a mod to return it here.

Best wishes


I don’t think this is an AV bug, I have the problem and I don’t even have AV installed, just the Firewall/D+.

FYR, I am also using this configuration.

Hello Everyone,
We investigated the problem and here is explanation as what happened. For few hrs on Wednesday, cloud started returning Absent for all vendor look up and as CIS does scheduled cloud lookup for existing vendors to ensure if any is removed from cloud it is removed from local list; it ended up removing vendors from local list.

So in case any existing user who had been affected due to this bug, sees a new signed application, which is not safe by signature but only through trusted vendor lookup and if live cloud lookup fails, he may see alert.

While we are contemplating in providing update to local vendor list via program updates, any one willing to have list updated, can download master list via following URLs:

Steps for replacing:

  1. Go to CIS installation folder
    %PROGRAMFILES%/COMODO\COMODO Internet Security\database\

  2. Rename ‘vednor.n’ and ‘vendor.sha’ and replace with following respectively:

  3. Re-start system and you should see complete list in Defense±->Computer Security Policy–>Trusted Software Vendors

Sorry for inconvenience caused.