[Solved] Vendor list empty

I don’t know how it happened but the vendor list of one of my computers is suddenly empty. When i launch a program already installed, it is now flagged as unrecognized and run in the container. Of course I’ve the same problem when I try to install a new program.
Any idea how i can reinstall (import?) the vendor list?
Windows 10 22H2 32_bit. CIS
Tank you in advance for your help

Try a CIS repair

Hi Boris_3,

Thank you for reporting.
The vendor list shouldn’t be empty, kindly run diagnostics and share us the report.
@Zorkas Thank you for supporting.


Afraid it is not a problem to be resolved with Diagnostics.
The problem happened in the past after a cloud lookup for the rating of vendors. I remember now that indeed I ran a lookup few weeks ago.
In this old post (2010) Trusted Software Vendors was lost Umesh gave the following steps to replace the vendor list:

But of course it was for an older version of CIS and doesn’t work with CIS
Is it possible to have the steps to be followed to restore the vendor list in the actual version of CIS?
Thank you

OK. I decided that the easiest way to bring back the vendor list was to restore a previous system image. Which I did. Now I’ve again the entire vendor list but I had to spend quite a lot of time to update windows and my softwares. I will never again make a cloud lookup of an unrecognized vendor.

Thanks for your feedback
Indeed, restoring by disk image is the best way to deal with problems like yours.
Personally I make a monthly backup
In the event of a major operating system update, immediately after