Stopped working after update

Hi

I can not install this version on my computer because Windows tells me that the COMODO drivers are not signed

I use Win7 Pro 6’Bits

Are there others on Win 7 x64 facing the same problem?

Magneto. Are you using the online or offline installer?

The security agent said it couldn’t start after i rebooted. during the update there was a problem with windows mentioning invalid certificates.
-windows 7 64 bit ultimate

Magneto. Are you using the online or offline installer?
I use ONLINE version.

How did you update? Did you use the program updater?

Yes, I’ve had this problem with CIS offline installer for a while now with Win7 Home 64. (I reported it in a previous build thread about CIS. But those go away when a new build of CIS come out.)

Yes, I installed an autoupdate

Are there others on Win 7 x64 facing the same problem?

Magneto. Are you using the online or offline installer?

Same problem with OFFLINE version.

Windows 7 without SP1 is not supported and it won’t work without it.

I have split posts and merged it to existing topic of the same issue, as stated by Comodo all future versions of CIS is only supported on Windows 7 with SP1 or later OS versions. If you are using XP, vista, or 7 without SP1 then CIS will not install or work correctly.

I had trouble finding the subject … :wink:
The problem is that my version of Windows 7 is with SP1

Then you need to have kb4474419 installed which is also required to receive future Windows updates.

Thank you :-TU
actually it was necessary that the update kb4474419 is installed, which was not my case. The SP1 of Windows 7 is not enough. It may be indicated in the minimum configuration for CIS with Windows 7.

:slight_smile:

Hello everyone

I’ve reinstalled my windows-7 and trying to install the Comodo Internet Security Premium. However for the past 2 hours am unable to do so. I’ve tried everything. Uninstalled it using windows un-installation and Comodo’s own uninstallation, changed the driver signing setting in Windows - and tried reinstalling it several times after the said processes. However continuously getting the same bloody error after installation regarding driver signing issue.

Is there a way out please as this is seriously driving me crazy now :frowning:

You need to have the necessary latest Windows updates installed as all Comodo files are signed with a sha2 digital certificate, which Windows 7 doesn’t know how to read without those updates . . . . . KB4474419

Hello jamalpk,

Thank you for reporting.
We are systematically checking the DB updates and there is no problem in signature DB updates.So could you please confirm the CIS version and kindly check your host entries.If you felt any difficulties in the sense Kindly contact us.
Have a nice day!

Kind Regards,
PD

CIS does NOT start after installing it and restarting windows. This message appear on my desktop : “Comodo Security Agent could not be started…” . I run the Diagnostics tool to fix the errors but the tool did not resolve anything.
When installing I got some errors on my Win7 64bit SP1. There were 3 unsigned drivers that Windows did not accept : CMDGUARD.SYS , CMDERD.SYS , CMDHLP.SYS . Windows messages were : The driver is unavailable and the program might not work correctly. Windows requires a digitally signed driver.
I will attach some pictures with this.

I was using an old version of CIS from nov.2017 (version 10.2) and I tried to install the latest version from official website :

It installed Comodo Secure Shopping corectly but CIS and ISE did NOT.
I had to reinstall the old version 10. Hope you will fix this soon.

You must have Windows updates installed to support sha256 code signing certificates.

In case you don’t find it, the Update mentioned by Futuretech is KB4474419.

I use Windows 7 64-bit SP1 too (with all MS Windows updates installed) and CIS V12.2.2.7036 installs and runs fine on it.

You need to have at least the aforementioned Windows update (KB4474419) installed to be able to install CIS V12.2.2.7036.
Maybe you need to (or must) install another Windows update too (KB3033929), please see this post of Liosant:

https://forums.comodo.com/news-announcements-feedback-cis/comodo-internet-security-2020-v12227036-released-t125668.0.html;msg901229#msg901229