Stopped working after update

THANK YOU so much. This worked. :BNC :-TU

THANK YOU both. This info was so helpful. :love: :■■■■

Glad that you managed to install CIS on Windows 7 64-bit SP1. :slight_smile: :-TU

Dear Sirs,

OS - Win7 64

I just tried to update my CIS.

During installation it asked any unsigned drivers.

After installation and rebooting it says that CIS can’t be running.

So, what should I do now?

Best regards,

Hello all,

Got some issues on Win7 64bit.

First tried to install via update. Everything looked fine during installation. No error messages. Just requesting a normal restart. Afterwards Agent could not be started. Firefox didn’t even open anymore. InternetExplorer opened but the network speed was like 1bit per second. Unistall over Add/Remove Programs was not possible. Disabling the Firewall driver in adapter settings didnt help. Finally got the uninstaller tool and was able to clean CIS completely. Afterwards everything worked fine.

Second I gave the offline installer a try. During installation I got 3 Windows signed driver warnings telling me that Comodo is trying to install an unsigend driver. (Internet Security Helper, Internet Security Sandbox, Internet Security Eradication Driver). Upon restart Agent is not able to start as well. Firefox and Internet now still working but CIS not running. I’m stuck here. :‘( :’(

System: Win 7 64bit (pretty sure not up to date as updates are turned of)

I read somewhere that KB4474419 and KB449062 are requiered. Is that all? Or is there missing more reagarding the unsigned driver error? I attached the report.

Any help?
Many thanks in advance!

I use Windows 7 64-bit SP1 too (with all MS Windows updates installed) and CIS V12.2.2.7062 installs and runs fine on it.

You need to have at least the Windows updates KB4474419 and KB3033929 installed to be able to install CIS V12.2.2.7062 on Windows 7.
Please see this thread for more info and how to get those updates:

Hi TheGsus,

Win 7 doesn’t support some certificates without these updates. Thus, unsgined driver error is expected when updates are not installed. Could you please install KB4474419 and KB4490628 then try it again? Thank you for your feedback and please let us know the result :slight_smile:

Kind regards,

Hi ab52003 & TheGsus,

This specific issue that you have mentioned could be solved by installing KB4474419 and KB4490628.

Could you please confirm that you have installed this on your machine. Do you still have problem after installing these updates.


Yes, the problem was solved after installation KB4474419, KB3033929 and KB4490628 updates.

Thank you!

V12.2.2.7062 (Firewall only) Windows 7 Ultimate 64-bit (clean install with all MS-updates)

The windows update KB3033929 isn’t really needed to install CIS on Windows 7.
KB3033929 is not listed in the “View installed updates” on my system as shown above.
KB4474419 and KB4490628 are both listed.

Many thanks for fast help! CISfan, mertavunduk, C.O.M.O.D.O RT, ab52003, oldrotary :-TU :-TU :-TU :-TU

Installing KB4474419 and KB4490628 and a clean CIS installation afterwards solved the problem.
I didnt try to install KB3033929 as the last system was set up about 3 years ago and the KB is from 2015 (replaced by plenty of new ones according to MS).

My suggestion would be to add a check to the installer / updater to avoid such issues (if it’s possible). I guess some people don’t have a second system to download uninstallers and do some research if the system is fu**ed after an update without any warnings/errors. Maybe a roleback option is also an option.

Thanks to Comodo for providing a free and good piece of software. As a SW developer I can understand that not every case can be checked before.

Thanks to Forum for easy, fast und quick help! Keep it going! :-TU :-TU :-TU :-TU

if windows 7 sp1 you must install updates


if windows 7 not is sp1, you must install updates in your system




V12.2.2.7062 (Firewall only) Windows 7 SP1 Ultimate 64-bit (clean install with all MS-updates)

Hi Liosant,

CIS installs and runs fine on my system (as shown above) without KB3033929.

I got all my updates from MS thru automatic Windows update (I didn’t install any updates manually) but MS didn’t install KB3033929 on my system.
Both KB4474419 and KB4490628 got installed by MS.

Can you tell why KB3033929 is needed?

in my tests CIS only auto start with 1ª update kb3033929 and 2ª update kb4474419… :-TU

‘Microsoft has published the security advisory KB3033929 for applications running on Windows 7 and Windows Server 2008 Operating Systems, which provides support for SHA2 hashing algorithm’

You can’t find it because:

  1. They released a later rollup update that includes this fix

  2. The rollup update does not follow any previous rules that outline how a KB is identified on your system

Edit: added the KB number for clarity

Thank you Ploget for the info.

CIS installed without errors and it runs fine and smoothly on my system with the automatic updates I got from MS (so without KB3033929).

If I understand it correctly then KB4474419 and KB4490628 are sufficient to install CIS on Windows 7.
Or are there other KBs involved which are needed to install CIS on Windows 7?

I’m just trying to get the full picture of which most recent KBs are needed (and which not) for CIS installation on Windows 7.


What MS has done or is saying is that you and others who have it installed on Win7 already have the KB3033929 which covers the signature issue. You just can’t find it and don’t know it’s there because they later changed the way that KB were installed in their cumulative releases

So Yes, it’s needed and Yes, you have it . . . you just don’t know it and can’t find it!

If anyone is running an up to date Win7 and they’ve installed all the cumulative updates to date then it’s there

Ah, a ‘hidden’ KB3033929 buried below another cumulative KB.

That explains it. Thanks.

I can’t tell you the exact version, but it’s the one I DL’d today. Win 7 Home Prem 64.

A couple of days ago CIS could not start at reboot. I ran the diagnostics as suggested and came up with the same message except that now I was invited to create a bug report. I did that and saved it to my desktop. I have no idea how to actually send the report. ME this is usually automatic.

So I tried several times to reinstall:

QUESTION: Is there a way to reinstall from files on my computer? Every time I have to reinstall the install downloads all the files again. My data allowance and download speed make this onerous.

Anyway I went through the DL/Install process and at last, instead of just saying “Could not be downloaded” or can’t install, I had the message that Win 7 was not happy that there was no digital signature. I walked through and appeared to install Secure Shopping, Dragon and CIS.

Only to come back to “CIS cannot start”…run diagnostics…fail…create report…new report on desktop.

So how do I submit this/these reports?

Any ideas about why CIS ca’t start. Secure shoping is OK. Dragon Browser is OK.

I have Win Firewall and stuff OFF wile installing… I have tried other security software and have it off the system.

I tried to install ZoneAlarm and had a similar problem with digital signatures.

Hi Nick . . . See the details on the first page of this thread: CIS 7098

Use the Offline Installer, so it stays with you and in particular see the Win7 instructions which are necessary for a correct install on your system and to have the Signature recognized

You may need to do a Clean Install if this doesn’t work, but give it a try first to save constant downloading