On Windows 8.1 Compatibility and Upgrade

Hello Everyone,

We have been receiving many requests/questions from our users about the products (In this post, the products refer to COMODO Antivirus, COMODO Internet Security, COMODO Firewall, COMODO Endpoint Security) and their compatibility with Windows 8 and Windows 8.1.

Also many of you have faced problems with the products when you upgraded from Windows 8.0 to Windows 8.1.

Hopefully, this thread will be able to answer many of your questions and offer workarounds to get you up and running:

1 - Windows 8.0 Compatibility: All the products with version 6.0 and later are fully compatible with Windows 8 and have passed all the requirements for compatible for Windows 8 logo program.

2 - Windows 8.1 Compatibility: All the products with version 6.3 and later are fully compatible with Windows 8.1 and have passed all COMPATIBLE for Windows 8.1 logo requirements(You should be seeing them in the Windows Store shortly). The products with version 6.2 and before are not compatible with Windows 8.1.

3 - Windows 8.0 to Windows 8.1 Upgrade

3.1. Users who use the products with version 5.x:
If you are using one of the 5.x family of the products, Windows 8.1 will block these products. Before you upgrade to windows 8.1, [i]please upgrade to the latest version of the products for FREE from the following URL: http://downloads.comodo.com/cis/download/installs/www/cis5upgrade/index.html[/i]
3.2 Users who use the products with version 6.0, 6.1, 6.2:
If you are using one of the versions listed above, Windows 8.1 will block these products. Before you upgrade, please use automatic updater in the products to update them to the latest version i.e. 6.3.

3.3. Users who use the products with version 6.3:
If you are using 6.3, your products are fully compatible and certified for Windows 8.1 already. However, Windows 8.1 upgrade has a bug that causes data loss by deleting a critical registry key used by the products(HKEY_LOCAL_MACHINE\SYSTEM\software\Comodo). Windows 8.1 upgrade is coming from a trusted source hence the self-defense in the products do NOT block the damage causing them to dysfunction. We are in touch with Microsoft for further resolution of this issue however we have also issued a path this weekend to ameliorate the damage caused by the upgrade process.

The Symptoms

Symptom: If you are using the products 6.3.294583.2937, your products will not start and you may not be able to uinstall neither.

Fix: Please run diagnostics tool by executing the command, “C:\Program Files\COMODO\COMODO Internet Security\cis.exe --diagnoseUI”, when done, restart your computer. The products should be functional however your configuration settings will not be able to be recovered automatically.

In order to PREVENT the configuration loss, please make sure to upgrade the products to the latest edition i.e. version 6.3.297838.2953

Symptom: If you are using the products 6.3.297838.2953, you will see diagnostics reporting an error and requesting a repair.

Fix: Please follow the instructions. When diagnostics is done, please restart your PC and everything should be back up and running. Note than a restart after diagnostics is required.

4 - Windows 8.1 Compatibility
The products with versions 6.3 and later are fully compatible with Windows 8.1 and have passed all required logo tests.

Still some issues seems to be there as although I got my browser and outlook open the firewall still reports no incoming and outgoing traffic or any connection being active while a simple netstat -na shows me about 3 dozen open connections. perhaps some more research is required (if necessary i will be more than willing to help).

Kind regards
Wilfred Klein

Can you post a screeshot? What AV are you using? If you are using one like Avast that uses a local proxy in its web shield the problem is there.

Is there any way just to download a new version of Comodo (after already upgraded Windows to 8.1)?

I dont even know what version of Comodo Internet Security I have. CIS has collapsed completely.

And: it’s too much of a risk to run a registry cleaner by hand.

Can you confirm there will be a software by Comodo fix which will restore a bugged CIS on Windows 8.1?


Im running the most recent version 6.3.297838.2953 and the firewall is not working and it asks me to fix which I do but only fixes up to 65% then it creates a report.

How can I manage to Work it out? I use WIN 8.1.

Thanks in advance


After Windows 8.1 Update via Windows Store, Your 3rd party Root Certificate has cleaned.
Please re-install KB931125 or Automatic Root Certificate Updates on Windows.


You Firewall Global Rules is ok, only Application Rules not working

Application Rules need BFE
but CIS6.3 installer maybe not compatible Windows 8.1.

Sometime don’t write data to

Install KB931125 and Re-install CIS6.3(again&again) maybe fix it.

HI Again,

I have still not found a solution to fix my firewall. Is it a bug in Windows 8.1 or is it a bug i Comodo firewall?

I have tried this:

After Windows 8.1 Update via Windows Store, Your 3rd party Root Certificate has cleaned.
Please re-install KB931125 or Automatic Root Certificate Updates on Windows

The KB931125 is for XP.

Thanks in advance!

Kind regards

i run the latest version of CIS (6.3.297838.2953) and did yesterday upgrade from win 8 to 8.1 by the windows store. first CIS reported that defence+ doesn’t work and the virus database needed to be downloaded again. after using the diagnostics tool and a restart it worked fine.
today i learn to know that one should desinstall any antivirus-scanners before upgrading windows 8, which i didn’t. do i have to desinstall and reinstall CIS now in order to have it properly installed or isn’t that necessary?

How does another free program editor, from 2006, not supported/updated anymore, work fine with 8.1 but
a supposedly state-of-the-art IS tool is broken, and for so long ? Makes my wonder if I am really safe anymore.

None of my other installed programs had an issue, just comodo.

A program editor does usually not run at kernel level; it has no drivers making it less likely to break.

Did you update from Win 8 to Win 8.1? What version of CIS were you running when you updated?

Two fixes have been made after the first release of CIS 6.3. Is one of these happening or is there another problem:

Early this week I upgraded to 8.1 on an old AMD quadcore machine. Process said that Comodo firewall was not compatible so I uninstalled it after reading stuff on the web. Upgraded to 8.1 with no glitches and then reinstalled Comodo firewall without any problems.

Last night, I did the same to a newer i7 machine (Comodo Firewall was the only non-compatible app). Anyway, I uninstalled Comodo Firewall and upgraded to 8.1 without hitches. Then I reinstalled Comodo Firewall and did a reboot. Now windows won’t start. It just keeps trying to re-start and after two or three tries it kicks me into the page that says that Windows did not install properly, etc. etc. The most I could get is to boot in Safe Mode. From there I can’t even uninstall Comodo Firewall.

Any tips on how to fix this? 8.1 was running well up till then and things made a turn for the worse after reinstalling CIS downloaded fron CNet.

Thanks in advance.

Thanks for reminding about the kernel level…that makes sense.

CIS is on constant update mode.

I tried the diagnostics in the OP: C:\Program Files\COMODO\COMODO Internet Security\cis.exe --diagnoseUI

Is this a typo or should it have been cfp.exe instead of cis.exe ? Do I have the right stuff for CIS ? It is in the same path name.

So I changed it to cfp and ran - same compat issue.

Yes, I did upgrade to Win 8.1. Ever after it kept complaining about compat issues with Comodo. Even with the latest CIS (from CNET) I get the same issue. Comodo just does not run.

Please follow Most Effective Way to Reinstall CIS to Avoid/Fix Problems by my colleague Chiron. It will provide a reliable and clean starting point. Key is to run the cleanup tool in Safe Mode.

I checked CNET and they are not providing the latest version. Get the latest version from COMODO Internet Security 6.3.301250.2972 Released! and hopefully that gets you going.

CNET: Welcome Comodo Internet Security users - CNET Download

has: 6.3.301250.2972
seems to be the same version - are they reporting the wrong version ?

released: sep 2013

BUT: file size from cnet is 204MB while from comodo site it is 198MB

Would be helpful if you could suffix the versions into the installer name

I am downloading right now - comodo site is very slow :slight_smile: will also do the clean up

Done - it works now, thanks for the link ! Didnt have to clean up.

Apparently CNET is now serving the latest version.

I fully agree Comodo, and many others, should suffix the version number in the installer.

[rant mode]Why on earth is that so hard to provide version numbers? Why on earth are there companies who serve installers with name install_fill_in_the_blank.exe? I am on high speed fiber optic connection and I am wasting time on adding version numbers or otherwise editing the installer’s name. It gets in the way of my workflow. All I want is to start the download and return to where I was… :-X >:-D[/rant mode]

So I upgraded to 8.1. After the upgrade CIS didn’t work but after diagnostics it wants a restart, so I did that.

Now I’m stuck with a BSOD everytime Windows tries to start. The BSOD is caused by cmdhlp.sys.

How can I solve this problem?

Try to get into safe mode (Apparently this is different in Windows 8 and later versions than before) then try to follow this guide as close as you can (pay attention to use the right .bat file) if successful you should be able to start Windows normally and then re-install it cleanly.

With today’s tools, that shouldn’t be a big deal right, so many automation/build/CI tools like Maven and Jenkins make this a breeze. No manual intervention or time wasted in suffixing version to build name.

The problem is that I’m not able to get in to safe mode. I get to this screen, http://www.7tutorials.com/files/img/win8_safe_mode/w8sm9.png, and there my computer doesn’t react on anything I press. I also tried http://www.techsupportalert.com/content/two-new-ways-boot-safe-mode-windows-8.htm without luck.

That’s interestingly odd. When it is indeed CIS causing it then this is what I would do in that case if hook up the hd to another computer and rename the following CIS files:
In %Program Files%
In system32:
guard64.dll (when on 64 bits) or guard32.dll (when on 32 bits)
In system32\drivers:

That should disable CIS. Then please follow Most Effective Way to Reinstall CIS to Avoid/Fix Problems by my colleague Chiron. It will provide a reliable and clean starting point.

Now you can do a clean install with the latest version of CIS if you like.