Is cCloud in Beta? It is really unreliable and so slow recently.

I’ve been testing out for a few weeks and it has been … well, horrible. I have quite a few people waiting for my recommendation for an online backup service and I was hoping this was going to be it, but…

The first account I made I had to just abandon. It wasn’t letting me delete items (told me they weren’t there) and couldn’t upload more than a few files at a time (was using the folder synch feature) usually and I never had any idea if it was trying to upload anything or if it had given up. So I gave up after a couple days of that.

The second account, I skipped the folder synch installer and just went with straight file upload from the website. It was working beautifully until three or four days ago when it became so slow as to be completely unusable. I just timed how long it took to move from one folder to a subfolder (not move a file, just change what I’m viewing) and it was 39 seconds. I have a 50Mb/s connection, nothing else on the net is slow. I have not been able to upload files effectively. I’m trying to upload a folder of photos, total size is about 1GB, but it keeps stalling out and quitting and I don’t know what’s been uploaded (lots of subfolders) so I have to delete and try again, then try again, then quit. This is crazy.

Is this a beta service? If so, awesome start, but let me know when it’s ready.

If not beta, are you doing work on the system lately? Is there any way we can find out when this is happening, outage/issue reports, etc? That would really help out.


I have been trying out both cDrive and cCloud on my Windows 8.1 system. Neither of them seems to work. CCloud installs OK, but makes no effort to synchronise the test file I put in the synchronisation folder. CDrive is still more problematic; when I first installed it I got the drive OK, but I couldn’t transfer any files to it. Windows Explorer just seemed to give up and hang at that point. So I uninstalled CDrive fully, with Revo Uninstaller Pro, and then reinstalled it. This time I couldn’t even get it to log in. It kept giving either error 100 (timeout) or error 62 (?).

I also haven’t been able to get Comodo Backup to work (see CB thread), or even to upload via the web interface. So I give up: I’ve got 10GB I can’t reach. Other cloud sync services that I use work fine. I’ll leave my account open and try again in a few months, when hopefully the bugs will have been sorted out.

Today I was trying the new for the first time - tried to upload one file. After about ten minutes of uploading after the progress reached 100% it said “Upload failed”. Not a great first impression.


Am really frustrated as I thought I’d found a reliable service with a good perk (10GB) to set everyone up with to begin trying out online backups.

I’m experiencing the same problems as both of you…files I couldn’t delete on one account after total failure of CDrive (like jmward) and super slow uploads that are unreliable (like AdamW).

I can’ t find any announcement from Comodo about current issues either.

Rethinking other Comodo products now.


And now I have another file I can’t delete on the new account.

Plus I cannot even login with IE, I cannot upload anything with Opera, and I cannot upload folders with Firefox (only individual files). This computer is a fresh install of everything, completely updated. This is nuts.

Does anyone else know of a good backup service that allows you to upload whole folders like cCloud does?

Most (like won’t let you. You have to select individual files to upload, which is utter nonsense.

I’ve been checking it off and on with no luck.

Today though the speed is drastically improved, upload performance is flying at a respectable rate.

I still have one file that cannot be deleted, giving the error that it is already in use. I was able to narrow it down to the one file from about a thousand in fifty different folders by selectively deleting what I could. I was able to cut the file from a subfolder and paste it into the root folder and also was able to change the name. Cannot delete it though.

I still cannot upload anything with Opera. (Button does nothing when clicked.)
I still cannot upload folders (only files) with Firefox. (Button goes straight to file upload when clicked.)
I am able to upload folders and files with Chrome. (Button gives File or Folder option when clicked.)

Latest installs of all.

I also haven’t found a decent alternative yet. Looking for a backup solution with 5+ GB of storage (and a 500GB - 1TB option at reasonable fee) that has a web interface that allows uploading whole folders (most make you select individual files). I’d rather not have to install a “sync folder”.


During 20th Dec-23rd Dec, the cCloud servers experienced some unexpected heavier load. This caused the upload/download operations to work slower and to occasionally fail. Now it should work ok.

Firefox supports upload only for files.
Regarding the Opera issue, we tested with latest version (18.0.1284.68), and the upload process went fine for both files and folders. Clicking the “Upload” button should expand the “Upload files” / “Upload folders” menu. Please check if you have the same version and also let us know what operating system you have (and if it’s 32/64 bit).

Regarding the files remaining locked issue: we are aware of the problem, it can happen in rare cases, it will be fixed with next server release.

Regarding upload to cDrive issue… if it happens again, please collect the debug information.


Still very slow it take long time to delete a files in cdrive ir dont give me no error

this still not fix


Deleting files on cDrive does take longer because the operations are performed directly on server. If you want faster access you can use cCloud instead. Please provide information regarding how many files are you trying to delete and how long does it take, so we can determine if the operation takes longer than expected.

The issue with files which can’t be deleted will be fixed in next server release.


This the error Messenger 306 Sharing Violation it like 7 files

The sharing violation issue will be fixed in a release next week.