COMODO Time Machine 2.2.121064.147 RC Released!

Hi Everyone,

We would like to announce the availability of COMODO Time Machine 2.2.121064.147 RC!

What’s New in 2.2.121064.147?
NEW! Updater function is available. You can keep all snapshots during update. Note: This function just works for RC and later version. BETA users can’t use this feature.
NEW! Help file is available. Note: Currently, Help file is not the final version. Please report bugs you met to bug report thread.
NEW! Command line tool is available. You can get more detail informations about command line tool from help file.
FIXED! More than 100 fixes of GUI. GUI will be more stable…
FIXED! Can’t work with removable devices.
FIXED! Can’t work with plugged-in card reader.
FIXED! Bug of dynamic disk support on Windows 7. Now CTM could be installed to dynamic disk on Windows 7.
FIXED! BSOD during snapshot defragmentation

Download Location:

Please post your bug reports here:

Excellent work guys! Welldone. A much needed product!


Good work Comodo, just finished DL will dis-install Beta & install RC on work comp at lunch :-TU Oops glitch during uninstall of Beta somehow, office comp went into continual boot loop, had to send it away since I couldn’t access F8 to enter safe mode to investigate the cause, now the comp is in IT hands since I also don’t have the required boot disk, should come back to me on Thursday 26th, bummer though :cry: :stuck_out_tongue: I’ll wait for the final release. I did manage to uninstall CTM from my home comp successfully though, sigh…
Regards 8)

Hi I got a BUG!?

I downloaded the .147RC software and on install after the text to choose your harddisk(s) Windows Installer Crashed. Time Machine did install but not right. Than A popup from TM showed and the error was;

Critical Error; A critical subsystem required for proper functioning of the product is not active. This usually happens with a incomplete install. PLS reinstall.

I had to kill the app. in my task-manager and had to set CIS into install mode to install for the second time. Now its running.

Question, I do not get the install window were to select a disk, and where can I tell TM to put the data on a other disk or partition. Where does the standard data for the time-line go to?

I have 14GB on C:\ and 40GB on F:\ I want the data on F so my C:\ drive does not get full.

nice work comodo!!! i will test and report

Hi Eljo.
Thanks for your report.
We will check this issus soon. I need to know which version of CIS are you using. It will help us to reproduce the issue.

About your question, don’t worry about your free space on you disk. All of them will be managed by CTM. Drive C must be protected so far. If you don’t want to protect other volumes. You can uncheck them during install.


I use CIs 3.13…573
virus 3022

Got it. Any questions/bugs, please feel free to ask me. I will help you as possible as I can.
Have fun.


Ok I used CTM and I must say WOW nice!

I installed your Dragon and after some testing I desided to stay with FF so I reversed with CTM and that looked proffesional. It worked like a charm.

Some questions on this. I checked CTM’s first snap and it has zerro “0” MB?
Is it normal that a snap has over 500MB

I unfortunatly clicked the wrong tab and do now have a snapshot taken, I can’t remove. All buttons stay gray

What do you mean about the first snapshot?
Baseline or the snapshot you created?

Actually, Snapshot size is up to how many data did you write to disk.
In normal case, you written 1MB, then take a snapshot. Size of new snapshot should be 1MB or 1.1MB. This is just a example. When you write some data to disk, Windows will write other informations to disk. So that size of snapshot is always not less than dada size you written except it has bugs. :slight_smile:


Sorry. I can’t see the image you sent. Could you please send it again?
We don’t angry any bugs. Fixs them. Make CTM more better. This is our goal.

Btw, I recommend that post bug to bug report thread. It will be more better. :slight_smile:


Wow great. I finally am able to install the version

The Baseline, as you can see it has 0MB
The second line I cant remove.

When I began to write there was no place to report a bug for the RC, is it now?

I had to do 2 hard shutdowns after install on XP SP3 as the boot stopped at desktop pic first then login. The next time there was an alert to run chkdsk as there was a damage in sys volume inforestore.

That seemed to work and now I think it is all OK

The previous version froze the comp after startup so had to uninstall.

I was too fast. Unfortunately it still is not working

Amazing works great! thanx Comodo!

Is it still not compatible with CDE???


I was about to ask the same thing similar. :slight_smile:

Will we see the known issues resolved before the final version? (Below).

But great work on this release! Working flawlessly on Windows 7 64bit. Well done!


Is this stable to use on my everyday pc?