COMODO Time Machine 2.0.112674.133 BETA Released!

Hi Everyone,

We are very excited to anounce that COMODO Time Machine 2.0.112674.133 is available for BETA testing. Thnak you very much for joining the BETA testing of our product.

This is a BETA software and must not be used any other purposes than testing.
It can contain serious bugs that could cause permanent data loss.
!! Please do not install this on your production system !!

What is COMODO Time Machine?

COMODO Time Machine is a high performance and powerful system snapshoting software which allows you to take the snapshots of your machine and switch between them.

Have you ever used Virtual Machines? What if we can bring their convenince to you with your real machine?

with CTM 2, you can take snapshots of your real system and switch between them, mount the snapshots as drives and recover your files easily, schedule automated tasks etc.

COMODO Disk Shield has been superseded with this product and is discontinued. Please make sure you uninstall it if you have it installed already.

System Requirements:

OS: Windows XP and later 32bit and 64bit ( Including Windows XP, Windows
2003, Vista, Windows 7)
RAM: 128MB
HDD: IDE/SATA/SCSI (4GB - 64TB) x Maximum 4 Disks

Known Issues:

  • CTM is NOT compatible with BitLocker Driver Encryption
  • CTM is NOT compatible with any disk utilities including disk encryption utilities such as COMODO Disk Encryption
  • Installation can fail on some Windows configurations
  • Updater is not active yet
  • Please note that this is not a complete list.

Download Location:

Bug Reports:;msg329051#msg329051

Playtime ;D

Indeed :slight_smile:

Now, just have to find some malware links 88)


Anyone mind posting SS… for those of us that cant get CTM to install!!

(even thought pre-beta did install) :cry:

I’ll test it on Win 7 :slight_smile:

Installed with no problem on my Eee PC netbook. Going to get to my house and try it out with my laptop. So far so good!

Installed fine for me and seems to be working okay. I have a question since I never used it before. I made a snapshot and it said it only took 72MB. I then tested it by deleting a file from my documents and trying to recover it. The recovery worked. My question is; can you recover any file that was deleted since the last snapshot and if so, how is this possible from a file that only takes up 72mb?

I have not been following this project, so excuse the newb question, but how is this different than Windows built in system restore function. thanks!

Just for fun , I copied the theme file from CTM over to CIS and look ;D

[attachment deleted by admin]


The installation states that CTM can be installed on a single system or multi-boot system (for each system). In my case, I am running XP and Kubuntu (Linux). Can CTM be installed under this setup? (for Windows only). I also use a seperate boot loader (XOSL) for each of these OS’s. Will this be affected by the installation of CTM?


Thanks. Once this is released, I’ll suggest this to everyone I know.

Comodo Time machine is a must have.

First of all welldone to the Comodo Time Machine team! They have done an excellent job!

Beta or not, this is now on my work machine!! :slight_smile:

Comodo Time Machine is the answer, period!


Please do not install CTM in such a configuration.Unless it is installed in ALL of the operating systems, it will not work proerly and mess the system when you boot with ubuntu.

You could always mount the snapshot as a virtual drive to recover the required file.

Alternatively, you can “protect” selected folders from changing back when you restore a earlier snapshot.

:wink: Familiarity is a wonderful thing. :wink:

Ewen :slight_smile:

i have a c:/ and a d:/ partition,how do i unprotect d:/?i just want to protect c:/ only.

AFAIK it only protects the boot volume. At least in the pre-release version I tested.

when i look in ctm it says c & d are protected?i dont see an option to unprotect it?i use rollback rx on my other pc and theres an option to select the partitions you want protected upon install,didnt see anything like that in ctm.

I was able to recover the file just from the snapshot without mounting it. Mounting drives is something I have never done and am totally unfamiliar with. Seeing as how I never have even had to use System restore, this whole Time Machine thing is new to me.

I uninstalled CTM from add/remove programs to see how that would go and it did uninstall but when it said I had to reboot, I also got a popup that the uninstaller was a dangerous app and had been shut down by Windows data execution prevention. Then Dr. Watson kicked in with the usual window that the uninstaller encountered a problem and needed to be shut down and the option to report the problem. I just clicked out of it and rebooted. I got a screen saying CTM was being uninstalled and then Windows booted up normally.

Everything was fine but I ran Auslogics registry cleaner and it found 35 invalid entries in what it called Firewall. The entries were all in the rules section for CIS and referred to the components of CTM. I let it remove the entries and all is well.

The DEP popup worries me though. I have never gotten one before.