Comodo Internet Security 2019 v12.2.1.6950 Beta 2 is now available for download

Did you block outgoing connections in the firewall or have a look in ‘Unblock applications’ as well as in your ‘file list’ - set as unknown there?

Today only events that I wanted to block were blocked in my firewall.

Is this when you first start up your system?



At system startup and when i open a new file.

You are intentionally blocking cmdagent, what do you expect to happen? I don’t understand how people who block CIS functions and then complain about issues that they made for themselves. And by the way, the firewall block logging will log 3 times the actual blocked amount of connection attempts, an issue that has started since the beginning of v12. There is a reason cmdagent needs to make those connection requests…

You tell me

I am not using CIS , I am using the firewall. Does blocking cmdagent break the functionality of the the firewall? Probably not !

Blocking or unblocking cmdagent doesn’t make too much difference. you will always see a delay ( between 1 and 10 secondes ) when launching files. I am just reporting that this beta version is making more connections than the previous versions.

No you wont see a delay when cmdagent is not blocked from making the connection attempts, those connections are the result of performing certificate revocation checks of digitally signed applications. If you launch an application that is not digitally signed, then cmdagent does not perform any connection attempts, other than file lookup if file lookup is enabled in file rating settings. But because you are blocking it, cmdagent is going to keep trying until it can successfully connect to get the revocation status. There is no setting to control this and even Windows itself will perform these checks with either explorer or svchost. But Comodo performs these checks on its own instead of using Windows to do it.

And it is not making more connections than before, like I said before there is an issue where blocked connections are logged 3 times more than the actual connection attempts. So 1 blocked connection will show up in the log as 3 connection attempts being blocked.

My PC runs and runs and runs, no matter what I’m doing! Not a tiny problem.

Okay, Been using beta 2 for the past couple of days or so. Switched to CIS through the installed programs menu in the real control panel instead of the metro one.

Upon switching back to CFW the tray icon disappeared again. Desktop widget still works just fine.

I also got a red X both times when I changed components “cannot change comodo firewall.” when I seemed to successfully switch to CIS.

and then when I switched back to CFW it was “cannot change comodo internet security.” even though I successfully switched to CFW.

I didn’t see anything bad happen besides the tray icon disappearing.

Comodo Staff, if I need to make an error report with that “reporter tool” please PM me about it and I’ll get right to it.

Hi futuretech,

Thank you for reporting.We are checking in it.

Kind Regards,

Hi StefanG,

Thank you for reporting.We are checking in it.

Kind Regards,

Filterweb not block or ask in websites or links (SSL) completely

Looking forward too soon !? No, not a big problem for me. Got blue screen after resetting the virt. Desktops.
I provide dump files, not a mini dump.


Did you get my message? I can’t see any confirmation that it has arrived.

Yesterday a website froze in secure shopping. Fortunately, no online banking, but nevertheless an important site.

So I played back a backup with 6882, again, unfortunately I forgot to save the dump file first

What applications did you run within virtual desktop before you used reset containment to get the BSoD? I did not get your message make sure it says message sent successfully.

I thought it was enough to click on your name. Now I have entered it in the box, the feedback came about the successful ‘sending’ now.

Most recently I used a page in ‘secure shopping’ for sensitive private data processing. The site froze and all I had left was the task manager, which was still working and so I was able to eliminate the entire process, including ‘secure shopping’. But, as I wrote, I did forget to save the dump file for this process.

Hello futuretech,

We are working in it.when resolved let me ping you.


A problem with Brave Portable web browser when running Virtualized. (Brave portable at Releases · portapps/brave-portable · GitHub )

Settings > scroll down to “Additional Settings” > Autofill > Payment Methods
When I enter the page, Brave hangs after about 5 seconds.
I get a Win10 Blue rotation circle for about a minute.
If, after the hang clears, I slide the “Save and fill payment methods” to OFF, everything works as it should.

But, If, before the 5 second hang, I move the “Save and fill payment methods” to OFF, then Brave locks up. (Win10 white screen, app not responding.)

Brave Portable works fine when not virtualized. My layman’s guess is that Brave has to grab something from Windows that is outside the sandbox in order to do Payments.

Perhaps related, but Brave Portable forgets my customizations to it, even though I have it installed in a Shared Space.

Clipboard copy/paste outside of virtualized browser still not working. (The last time this worked for me was CIS Beta.) I have clicked the box “Allow contained application to access the clipboard” and done a reboot of Windows.

Win10 Home 64 1903.

This a known bug and should be fixed in the next release

Hello pmikep,

Thank you for reporting.
It is an known issue in v12.1.0.6914. Our developers are working in it,once resolved let me notify you.

Best Regards,

Had to reinstall, Comodo related downloads are still running super slowly for me. Can I get a link to the offline installer of the beta? I can’t get the online installer to run properly.