Comodo Dragon is now available for download.

From where did you get this version? My Dragon is still on and it says it’s up to date.

Many websites have published this version (example:, and others).
My Dragon on and it says it’s up to date
P.s. Sorry, I see You also do not know how and I :slight_smile:

Comodo Dragon Final

Hi Raven656 and Eric,
I also do not know what the unknown minor update fixed.
As with Eric, my installed version is and it says it’s up to date.
Running the installer from the opening post now gives version (Screenshot)

Kind regards.

[attachment deleted by admin]

Thanks to the two of you. Installing it as I type… :slight_smile:

But… wasn’t that not too distant future supposed to be now? With v41?

Although I’m personally not really interested in Comodo Dragon anymore, as soon as Vivaldi is in a usable state (by that I mean with extension support so I can use LastPass and Referer control etc) I’ll be switching to that, still hope Comodo picks up the ball and doesn’t drop it again.

That’s the crunch :slight_smile:

One more time, or else :-TD

well… at least with this “new” 36 version… the flash problem is gone! ( finally) :stuck_out_tongue:

it is a shame comodo is getting behind…

Can we please stay on topic.


It looks like 1.22 Version has been out for 4 days. I can’t get mine to update to 1.22 and still have 121.

Hi Dragon1952,
Mine wouldn’t automatically update either.
I just downloaded and run the installer from the opening post with no issues.
Note: Have Dragon closed when running the installer.

Kind regards.

[attachment deleted by admin]


Tried downloading the setup file from the link as you did in the first post.

I am afraid that other XP users are going to start seeing problems because of programming software changes. This is the same error I recieved when trying to update Avira. It downloaded but would not install. I will need to manually update until I am able to purchase a new PC.
I think the culprit in Avira’s case was that new or additional programing was used SSE2 which was not supported by my XP.

Not sure if that is the same reason I am getting the Illegal Instruction with the Dragon Setup file ?

Attached is the error report.


[attachment deleted by admin]

Rather not supported by your CPU. Chromium 35+ requires SSE2.

Can you check with CPU-Z if your CPU supports SSE2?

EricJH and JoWa

I knew this old PC would start slowing me down. Didn’t realize programming software could have the affect it is having.

Downloaded the latest CPU-EZ it installed without any problems but when I clicked on it to run it, at 4 blocks it “locked” my computer up (twice) that I had to hard reboot. Downloaded the Oct version the first run had no problems but the 2nd locked up again.

Did find out this oLD PC has an AMD Palomino Athlon 2000+

I mentioned the Illegal Instruction with Avira not installing the updates. Not sure what the programmers did but it now is working .

I will download Dragon and try again.


Speccy from Piriform also shows CPU support.
There is portable version too.

That is also what I use. :slight_smile:

Athlon XP “Palomino” supports SSE, but not SSE2 or higher: Wikipedia.

Avira may have begun compiling the software differently for compatibility reasons, e.g. with /arch:SSE.

Chromium for Windows is compiled with Visual Studio 2013, where SSE2 is default. Here are the /arch-arguments in VS2013.

I’m new user . What differs between Comodo Dragon and Chromodo? . So in brief please :slight_smile:

Hi pierdoletz,
There is not a lot of difference between the two, Chromodo has a more traditional Chromium appearance.
Comodo Dragon or Comodo Chromium? [Merged]

Kind regards.