CIS doesn't start on CPU without SSE2 support

Can you reproduce the problem & if so how reliably?:
Yes, if I execute the installation program file, the installation doesn’t start
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:I uninstalled previous CIS version removing all registry entries
2:I downloaded latest CIS from
3:When I start the installation program, the installation closes itself
One or two sentences explaining what actually happened:
After the latest update, CIS has stopped working definitively
One or two sentences explaining what you expected to happen:
Should have appeared window language dialog
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how you tried to fix it etc:
I think that the new version of comodo ( is not compatible with old processors that not support anymore SSE instructions. With an Intel Atom (Netbook) installation starts without problems.

Exact CIS version & configuration:
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Have you made any other changes to the default config? (egs here.):
Have you updated (without uninstall) from CIS 5, 6 or 7?:
Have you imported a config from a previous version of CIS:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows XP, SP3, 32 bit, Athlon XP 2800+
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=None b=None

This one looks quite serious. [at]richardd0_1, if possible could you please follow the instructions from this post :;msg805123#msg805123
We might be able to catch some exceptions.

Thank you.

Hi, same here for me… but on Windows 7 32 bit and AMD Sempron 3300+.

How I say in this topic, do you think it is possible that the version 8.2 does not work on processors without SSE2 instructions?

Updating from 8.1 has blocked cmdagent and the whole CFW… :o
A clean installation is not possible, because nothing happens after extracting files from the installer… ???

By the time I’m back to the 8.1 and I had to block any automatic update!

I have tried to use procdump but it crashes when cmdinstall.exe starts (I have attached the log from Dr. Watson), I have obtained a partial dump with procdump. I have attached the log of the first crash of CIS after update to version 8.2

[attachment deleted by admin]

Ciao, vedo che sei italiano anche tu per cui ti scrivo in lingua madre.
Ho la sensazione di aver ragione… in uno dei tuoi dump si parla di “Numero exception: c000001d (istruzione non legale)”.
Va a finire che hanno davvero progettato il nuovo installer per processori che dispongono di istruzioni SSE2 (i socket A tipo i nostri supportano soltanto le SSE)…
Ebbi lo stesso problema tempo addietro con Avira Free (lo uso da tempo in accoppiata vincente con CFW), ma Avira ha subito corretto il tiro mettendo a disposizione un installer adeguato anche ai nostri processori (ce ne sono ancora tanti in giro).
Spero proprio che Comodo faccia lo stesso…

Translation for non-italian:

In one of your dump I see “Number exception: c000001d (istruzione non legale).”
Probably Comodo has really designed the new installer for processors able to manage SSE2 instructions (Sockets A processors support SSE only) …
I had the same problem some time ago with Avira Free (I use it for a long time with CFW), but Avira solved immediately by providing a functional installer even for our processors (there are still many of these in the world).
I hope Comodo does the same …

First of all, please try the following :
0. Run cmd with administrator rights.

  1. Type :
    sfc /scannow
    DISM.exe /Online /Cleanup-image /Restorehealth
  2. Restart.

Also, you have to take a full dump of ‘cmdinstall.exe’, for example. The posted ones are not really useful-- not enough information. Could you kindly create a video in order to better investigate this issue (when you’re trying to utilize given procedure)?

Thank you.

Hi qmarius, I have tried to do the operations that you have suggested, but seems that “main.exe” has the same problem of cmdinstall.exe, i don’t see any window when I run it. The only log that I captured is with process monitor (from sysinternals), I attach if it is useful.
There is another method that I can do?

Ciao watcher, si anche io sono del tuo stesso parere. Quell’eccezione (c000001d) mi ha portato a ipotizzare che fosse un problema legato alle istruzione SSE2. Purtroppo quasi tutti i programmi li stanno compilando con le istruzioni SSE2, facendo rimanere fuori dal giro tutti coloro che hanno un vecchio processore (servirebbe un pentium 4 per superare questo problema) :-\

Translation for non Italian:
Watcher, I’m agree with you about the exception c000001d, I think that is connected with the SSE2 instructions that are missing in my cpu.

[attachment deleted by admin]

I have the same problem.

I use Windows 7 Ultimate SP1 32 bits in Atlhon XP 2200+ with 1 GB memory PC133 and 80GB HD IDE

“Yes, if I execute the installation program file, the installation doesn’t start”

It for release 4508

“After the latest update, CIS has stopped working definitively”

It for old version 8.0

Here’s a thought. Just a long shot. I am wondering if the 8.3 error being experienced might be somehow related to this one?

8.3 ?

How it was compiled, is what I’m referring to…

Is there any chance that the problem is solved?
After so many years, I would be very disappointed if I had to leave this firewall, but at the moment I have no intention to change motherboard and processor…


I have the same problem on Athlon XP. After update the CIS completely stopped working. When restarting my Windows XP the internet connection is blocked, and the CIS tray icon does not appear. After about 3 minuted the dialog saying that CIS tray agent could not be run appears and asks if I would like to start the repairing process. The process finishes and says that no problems was found.
I than uninstalled CIS and tried to install it again. And I encountered the above described problem. Installer extracts itself into TEMP directory, and after that the new process is started and immediately disappears. No windows appear, only the new process in process explorer that disappears after a second.

Can we expect that this problem will be fixed? Or that processors without SSE2 will be abandoned?

Exactly what happened to me.

From what I can find, SSE2 has not been abandoned by processor mfgs. So there must be something else at work here.

@ everyone that’s experiencing this issue, please attach a system summary. (run > msinfo32 > save)

Thank you.

My system summary attached ( had to switch info.nfo by info.txt for attach ).

I have Comodo firewall 8.0 with update disable because of the problems.

[attachment deleted by admin]

… and here’s mine.

Last working version:
Many thanks.

[attachment deleted by admin]

Hi John, IMHO the problem is related to processors that NOT working with SSE2 instructions.
Socket A procs like AMD Athlon and Sempron, working only with SSE instruction.