CFP BETA 32-Bit Bug Reports [CLOSED]

Vista ultimate on two machines, 3 updates from the other day would not install, would go through the installation reboot pc and the updates would come up again, again, tried to allow all to fix, in the end removing comodo and then the updates went in okay. Happened on two machines.

I run Shattered Galaxy ( and inform me that there’s a new update available. The first problem i saw that i cant click on the button to get the update.

After this i used Alt+tab to switch between tasks. At this point i saw there’s a cfp window asking for permissions to let the application out, which is not shown anyway (only saw it’s picture, tried to switch to it but no results).

When i realized that i can’t allow or deny the connection - cause you are defending cfp from hooks? - i launched task manager and tried to kill the game process as well as exit cfp. dumprep was launched, causing 100% cpu usage.

when running cfw 3.x, firefox uses almost 200 mb of resources. when turning off cfw it works “normally”. but my isp speed test shows speeds it always did. it seems to only drag down local processes.
however, when using ie7 there doesn’t seem to be a problem.
also get more bsod’s when using firefox even after shutting down firefox

i may have found a “workaround” for this. don’t know how it happened or why but i went into computer security and found most settings for firefox were blocked, while ie7 settings were all allowed. still uses about 100mb of resources but doesn’t bog down the system. will keep playing and see.

as soon as the firewall asks something and I allow the action, my wireless connection drops.

//edit: kinda annoyed a lot at the moment. As long as the cmdagent service is running, my wireless connection keeps getting lost, even when I disable both the firewall and the defense+ system.
I’m using Vista Home Premium.

Hmmm yes. CFP will not allow any hooks to be installed to CFP.exe process. Exactly what sort of hook does the game needs?


Please report all bugs for CFP v3.0.9.220 Beta 32-Bit in this thread.

Please be sure to include:

Computer information
Operating System information
Actively-running security and utility applications
Specific symptoms of the bug, and steps you can take to reproduce it.
Specific steps you have taken to try to resolve it.

Thanks for helping to make CFP v3 a better firewall ~


During installation it gives the message that the firewall is not compatible with Spyware Doctor Pro. Will this be worked on in a later stage.

Continued the installation anyway and so far things run smoothly.

Harry (:NRD)

[s]Configuration Import says it completes successfully, but imports nothing.

Prior to uninstalling 3.0.8, I Exported the configuration. Even with the default settings of “Train with safe mode” I was getting alerts for applications like Outlook (because of a mobile-phone plugin) and BOC (not sure why…) so I decided to Import the config file. Went through the process, and it completed successfully. Checked my rules; nothing had been imported.[/s]

Uninstallation of 3.0.8, and install of 3.0.9 were accomplished in SafeMode, with registry cleaning in between. (BTW, the “activation” window appears directly behind the installation window, and cannot be seen. It also said that activation was completed, even tho there was no internet connection available.)

Pentium M, 1.6GHz, 512MB RAM
XP Pro SP2, 05.01.2600
IE 7.0.5730.11
BOC 4.25
CMG 1.1
MaxCrypt 2.0.4


Edit: Dev’s, pretty much ignore this post; I didn’t read the release notes well enough. Perhaps you can note the comment about “activation window.” :-[

updater still causes bsod. at least for me. stealth ports wizard still doesn’t save.


Seems pretty good to me so far

When I log out of an Admin account and log back in to a user, two(2) Icons for CFP show up in systray. I am not using “fast user switching”. I use a User Account for normal use and do all system maint as an Admin.

I can reproduce this on my laptop with 3.0.8(now downgradeed to CFP2) and have seen this on my desktop with 3.0.8 & 3.0.9

I think I saw this reported in the last version, I have never reported this in the past

If I do a complete reboot such as after an install, and log back in as auser this does not happen


In these instances, is the firewall still operating normally? No error messages or other problems? (I know w/2.4, this is an issue)


Not sure in 3.0.9 however in 3.0.8 omn my laptop I noticed that only one ICON showed trrafic and I could right click and Exit the inactive one and all seemed normal. I can´t remember what process manager showed I will reproduce the problem and post my analyisis


when doing a windows update in vista business 32bit and when trying to update the windows update engine to 7.0.6000.381 I’m alway getting the error 80070643 back. This must be caused by CFP because when I uninstall it I can update again but only once. Afterwards system crashes because the Windows Licence is not recoginzed anymore. The next reboot there only brings up a black screen and a boot up is only possible in the mode where you ignore uncertified drivers (don’t know how it is exactly named). This is caused by a faulty network setting I assume - here is teh error:

  • Provider

[ Name] Microsoft-Windows-Security-Licensing-SLC
[ Guid] {1FD7C1D2-D037-4620-8D29-B2C7E5FCC13A}
[ EventSourceName] Software Licensing Service

  • EventID 1001

[ Qualifiers] 49152

Version 0

Level 2

Task 0

Opcode 0

Keywords 0x80000000000000

  • TimeCreated

[ SystemTime] 2007-09-28T13:12:15.000Z

EventRecordID 1972


  • Execution

[ ProcessID] 0
[ ThreadID] 0

Channel Application

Computer xxxxx


  • EventData

hr=0xD0000034, [2, 4] "

Hope this helps to improve CPF

Unfortunetly, i’m just a lesser scriptkiddie = i dont know :(.

In the Release thread it says: Previous configurations exported are not compatible with this one because of the major arhitectural changes. So please try clean install only.
So my gues is you won’t be able to import a previous config., hope I’m not wrong…

Guess I should’ve read the directions, huh? I grabbed first and asked questions later (since there’d been issues before, I didn’t want to be left out).

Thanks for pointing that out,


It seems as if CFP is operating fine only showing 2 Icons in systray

[attachment deleted by admin]

You’re wellcome.

I have sth to report: High CPU usage running P2P applications, eMule in this case. Big difference between Beta 2 and Beta 3, I couldn’t even notice Beta 2 working, now with this version is a whole other story, It is the most CPU time consuming process on my machine -same settings on both betas- and same workload…

-the box is XP SP2 32bit Spanish, Nod32 full, CFP Beta3. eMule is running in Secure Mode with low privileges… any Ideas??

2 icons will you please check in task manger to see if it is the same as mine
1st is from the user I have logged off this one works ok
2nd is from the user I have logged on this one is not ok it says the defence is not working