"You must restart your PC to complete the installation..."

First of all, I can not speak english THAT perfect, so I’m really sorry for grammar mistakes.

This is what happened:
I use to have CTM on my Windows 7 Home Basic 32 bits running very well. After less than one year, i had to reinstall Windows and start from the scratch. The first thing I did was install CTM, everything gone fine until I decided to test the software before using it.
Every time that I restored the system to a snapshot it did not started like always. It showed that black/white screen that appears when the PC is turned off inappropriately. I just choose “Start Windows normally”(I don’t know how it appears in english systems) and everything was fine.
So I decided to reinstall CTM to make sure it could work well. The unistallation was a complete failure. A lot of files were missing and i had to use system recovery(of Windows) and back to the day when I installed CTM.
It was still there, so I unistalled it AGAIN using the setup file. It went well.

But now that I’m trying to install it again it shows an Error Message:
“You must restart your pc to complete installation/unistallation firstly. Then try again.”

Is there any way to solve it?

My notebook is a HP Pavilion dv4-2012br, if it is some help.

Thank you in advance and sorry about the grammar mistakes.

Hi Jnsrecreio:
Please tell me your email, and i will send a fix tool to you.

Best Regards.

Hey and Welcome!

in case nothing helps i would recommend you to uninstall CIS, clean the the register that CIS left with CSC (comodo system cleaner) or anything else and then install it again.


I am also experiencing the same issue. Could u plz sen me the same utility? Natedizzle7015@gmail.com

I am running Windows 7 64 bit OS. I tried installing Comodo Time Machine, rebooted and got:
Critical Error: A critical subsystem required for the proper function of the product is not active. This usually happens with an incomplete installation. Please re-install the product and try again.
So I try to uninstall, and get the message You must restart your PC to complete the installl.

Soulcat, check and see if there’s a SSD on your computer setup !

Good Morning,

Similiar to other users, I installed CTM on a PC and received a message that it hadn’t been installed correctly and that I should uninstall and reinstall. Uninstalled the product and was requested to reboot the PC. After the reboot, I tried to reinstall and I get the error message “You must restart your PC to complete the installation/uninstallation firstly. Then try again.” Endless cycle. I think I would benefit from this removal tool I see in the forums. rleo[at]bigfishtechnology.com thanks.

  1. Version of our Products - Comodo Time Machine v2.8
  2. Complete system details such as OS with service pack - Windows 7 SP1 64-bit
  3. Other Security software’s installed in the system is in use; - Trend Micro WFBS

i am having same problem.

can you send me the fix tool?

adress is

tohmizo at hotmail dot com.

thank you and best regards.

Hi … I am having the same issue on win xp. Comodo does not offer to uninstall and a manual cleaning of the registry does not seem to solve the problem. I believe I need the cleaning utility. Please send to penrest@nbnet.nb.ca

Many thanks

Hello, i have the same problem “you must restart etc…” could you send me the utility at sagtiv@gmail.com

I have the problem because the install aborted before it finish ???.



seems i have the same problem, i get the message: “you must restart your pc to complete the installation…”

Could i get also the fix-tool?
Email is laitrus@yahoo.es

Greetings and thanks in advance

I have the same problem can you send me a tool?

my email is mguarro@libero.it

I have the same problem can you send me a tool?
I ran a tool to clean the registry, but that did not help. my email is felix412 at gmail dor com. please reply

I also encountered the same issue. Can you please send me the fix file as well? My email is petercallan[at]alumni.nd.edu. Thank you!

I have the same issue my email is ommon@gmx.com

The same issue here as well. Stuck in an endless cycle of rebooting, sometimes the install goes up one percent before asking te reboot again, but currently i’m stuck at 96% and not going up.
Could you send me the tool as well?

Many, many thanks


I have a PC under Windows Seven 32bits and I have the same message when I try to install CTM : “you must restart your pc to finish installation…”

Could you send me the Fix Tool please ? My mail is p.byll[at]groupe-esa.com

Thanks a lot !


P. B.

Can I get a copy of that tool as well. daudette at fortstjohn dot ca


Why this tool can’t be downloaded normally,with a posted link and has to be send via email??I need this tool too for someone in trouble.