Windows 7 Freezing

Windows 7 has been freezing these past few days, I doubt Malware is involved in this as I have scanned with MAB, and CIS and everything came out clean. I’d like to think that maybe the cables inside my case are a little loose, but I would like to know before I actually open it up and take a looksy. These freezes are very recent, maybe 2-3 days is when I started receiving them. It just “freezes” my colored mouse stops changing colors, my numlock does not respond, neither does CTRL ALT DELETE. My PC is only 3 years. There is also the issue of my CPU overheating, but this is not the case because I’ve been monitoring their temperatures

Specs: Windows 7 Home Premium 8 GB RAM. Intel core i5. ATI Radeon HD 5570 and 1TB Hard Drive


Is there anything which you are doing, or which happens, most times just before you experience this freezing? For example, does it often happen when you open a webpage, open an email, start a scan, etc…?

Also, do these freezes happen if you disable all modules of CIS (and reboot)?


Nope, I can open an email, watch videos, start a scan and everything, but most of the time I’m just watching videos, and then when I leave and come back, I see it freeze up. It’s quit frustrating :S

Okay, please try entirely disabling CIS and see if the problem continues.

I’ve disabled the Anti virus, Firewall, HIPS, and sandbox. Am I supposed to wait for the freeze to happen? ._.

Nevermind, the cause of this is I might need to update my Graphics Driver. I’m Sorry about this :s

While you’re still here, I’ve clicked the update button, and this error came up.

No problem. These sort of issues can be difficult to narrow down.

Does running the diagnostics find any errors? Also, did you install this version fresh, or did you update this from an older version of CIS?

This is a fresh install. And where is the Diag?

Open the main CIS GUI. Then, in the upper right-hand corner, click on the question mark. Then, select Support and then Diagnostics.

Also, have you been experiencing these update problems every since you installed CIS, or did it update correctly for a while and all of a sudden developed these problems?


They would update when I first installed Comodo, then the problems developed. Anyways, I ran the diagnostics, and said it can’t fix them, should I post the report?

So it said that it found problems, but could not fix them?

If that is the case then the simplest solution would be to re-install. There may be other solutions, but unless you have a lot of specific rules you manually created this should be the simplest solution. To re-install please follow the advice I give in this topic.

Please let me know if you have any questions.


Hey, So I did as instructed, ran safe mode with networking, downloaded the removal tool, uninstalled CIS, it worked, so i restarted my computer normally and installed the latest version of CIS, prompted me to restart my computer, which I did, and here I am now, it’s giving me another error when I press the update button, CIS is now saying it’s at risk because it’s virus data signiture base is out of date, I ran the diag again, only to get the same result

Can you please check the version of CIS you have installed? Just copy and paste exactly what it gives you.

I want to make sure that you do in fact have the most up-to date version.


Okay, that is not the newest version. Thus, this may be a bug with the older version.

Please download the newest version from this topic. Then uninstall the old version, and install the new version, by again following the advice I give in this topic. Let me know if that works.


Sorry about the long wait, but after uninstalling the old and installing the new version, and after it’s finished installation, it prompted me to restart my computer, after that a message came up saying the Comodo CIS agent could not be started, which asked me if I wanted to run a Diag, it got up to 60% before telling me it had errors it could not fix.

Did you boot into safe mode in-between (and run both uninstallers)?

Yes, the uninstaller told me to restart my computer and run the removal tool again, so I did, everything came out okay, but for some reason I still see Comodo firewall on my control panel

Good news ( i think ) I downloaded the upgrade from ver5 to v6 from that link you sent me, after that, prompted me to restart my computer, and went to see if I’d be able to uninstall Comodo, and it worked! Comodo is off my PC now, do I proceed to reinstall Comodo?