Windows 11 Freezing after completing boot (Work around included)

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
No, This issue seems specific to certain devices. Imaging the physical machine and running COMODO in VirtualBox does not recreate the issue. I believe it to be a hardware/driver incompatibility.

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Install COMODO, finish update and quick scan.
2: Reboot computer (when instructed by COMODO).
3: Sign out of Microsoft account, and immediately sign back in. This is the point where the system usually becomes unresponsive.

One or two sentences explaining what actually happened:
COMODO freezes/locks up Windows 11 after the boot cycle completes or if you sign out and immediately sign back in after rebooting.

One or two sentences explaining what you expected to happen:
The system should boot up normally without freezing.

If a software compatibility problem have you tried the advice to make programs work with CIS?:
After about 4 hours of troubleshooting, I don’t believe this is necessarily another programs fault, but that COMODO is trying to block said program causing the system to lock up.

Any software except CIS/OS involved? If so - name, & exact version:
Yes, however unknown at this point. All software running will be included in the kill switch process list.

Any other information, eg your guess at the cause, how you tried to fix it etc:
I would presume it is a driver or critical system process being blocked by COMODO’s Auto-Containment. I have experienced this on a few other computers as well. The other 3 computers all have Windows 11 running on hardware no older than 3 years. Other older devices running Windows 11 oddly don’t seem to have this issue.

I have found that disabling the “Pseudo File Downloaders” rule in Auto-Containment fixed the issue.


Exact CIS version & configuration:
Default Internet Security configuration

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:

Have you made any other changes to the default config? (egs here.):

Have you updated (without uninstall) from CIS 5, 6 or 7?:
No, It was a new build so was the only version ever installed.
if so, have you tried a a a clean reinstall - if not please do?:
Yes, uninstalled, ran cleanup tool, reinstalled.

Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 11 Pro v10.0.22621
Memory Integrity = off

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=No b=No

Hi CIS-1,

Thank you for reporting.
Could you please check your inbox for pm and respond ?


I am running into the same problem. It has been happening since the end of December. I had to completely uninstall Comodo as I couldn’t figure out what was causing it to freeze anywhere from 5 minutes to 24 hours. It would become horribly responsive.

I completely formatted and rebuilt my machine, and the ONLY thing I did was install Comodo, and the problem immediately appeared, so I knew that there was an issue somewhere with Comodo. I found that the moment I ran the uninstaller (Comodo complete uninstaller) and let it remove it, the problem stopped - and it hasn’t locked up since.

I now have a second machine that was not having issues, and it is now starting to have the same issues. I will try disabling the “Psuedo file Downloaders” and see if that helps. I will also try putting Comodo back on the other machine and see if that helps with the lock ups as well. Hopefully it does.

ON A SIDE NOTE: At my place of employment, we use Comodo Enterprise without issue.

Setup #1:

Windows 11 22H2 - 22621.693
AMD Ryzen 5 3600
32 GB Memory
1 TB Samsung NVMe (Boot) and a 1 TB Samsung SSD (Storage)

Comodo (had to remove)

Setup #2:

Windows 11 22H2 - 22623.1037
Intel i7-1165G7 11th Gen
16 GB Memory
1 TB Samsung NVMe (Boot)


Hi rhirne12,

Thank you for reporting.
Could you please check your inbox for pm and respond ?