Windows 10 Anniversary pre-RTM signature issue


just a heads up, the latest Windows 10 Anniversary pre-release builds, which are almost final, are not allowing installation of Comodo drivers. Screenshot here.

Now the important bit. Upgrading from previous Windows works fine, but you need to get an ISO and install fresh to see this issue.
If you don’t care as it could be a last-minute Windows issue, then at least have this on your radar and try clean install (of builds 14390+) to see if this is the new normal.
So far I confirmed it on 14390 and 14393, Comodo 10 beta same issue.


Hmm… odd. Doesn’t happen here with the Insider builds. There is an issue with CIS not allowing incoming traffic (when using p2p programs) that makes me do a clean installation after each Insider upgrade. A couple of builds ago I did a clean install of an Insider where this problem didn’t occur either.

I checked the signature of inspect.sys of CIS 10 beta 5144 and it is valid.

In the screenshot I see the computer is not connected to the web. I am wondering if that plays a role somehow. Could you check and see if the problems persists or not when installing CIS with a connection to the web?

Hi Eric,

thanks for the reply, it was a good idea but unfortunately it is Comodo (this time tried that disables the internet.

Here is the new screenshot, showing all 3 drivers that fail installing, with internet previously working (Edge in the background was loaded before installation), and main issue how I discovered this, is that TCP/IPv4 gateway is not remembered, no matter how many times entered.
All started with DHCP/Automatic IP, totally default Windows installation.

Same after reboot.

I see Microsoft Hyper-V Network… Are you running Win 10 in a virtual machine of some sort?

Yes, but only for testing purposes to confirm it happening on the untouched Windows, saw the issue on the real machine first but my OS was heavily modified.
I am a long time Comodo user over the years, this was the first time to see something like this. It could be Windows issue, I can ping you from time to time until new Win10 is released in August.

It looks like it is system specific. When installing Windows 10 in vm is CIS the first thing you install? What network adapters do you use? I’m using Realtek.

Mine is Intel 82579V (Asus onboard).
But it also happens on Hyper-V, so you can easily test it yourself, I don’t think it’s system specific as Comodo always worked for me, now I’m back on Win10 1511 just for that reason (same config, same NIC or VM, all works fine).
As said try the clean install of Win10 RS1 pre-RTM or in a week or two RTM, not the upgrade version.
Other than getting the ISO image, it’s a simple check in the virtual machine.

I don’t have experience with Hyper-V. I am on an AMD system. I did a clean install recently and installed 8.4 and the problem didn’t happen with me.

Did the problem occur on 32 or 64 bits systems?

You can use VMWare or VirtualBox, to name a few, doesn’t matter which machine, what matters is that it is a clean install of latest Windows 10 previews, build 14390 or later (current one 14393).
Tried only 64-bit.

If you tried these builds clean install and it worked fine, then you have nothing to worry about.

edit: just to clarify, you don’t have to test on a virtual machine, I do that for simplicity, makes no difference.

I think this is fixed with version 10 BETA.

Btw Win10 RTM is signed off, build 14393.
When using Windows 14393, both Comodo 8 and 10 install fine, clean or upgrade (I had issue repeatable with 14390).
If I ever see the issue again and figure out what causes it, will report - hopefully it’s gone for good.


Having this issue again, don’t have a clue why it didn’t that time.

Static TCP/IP gateway issues are consistent, even when Comodo installs ok, one can’t set static address, the gateway part is not remembered.

Anyway, I understand if you ignore this, I would do the same due to lack of clarity, just please react when you hear it from other people too to get it fixed as fast as possible.


OK, I think I have the exact cause this time.
The Windows Defender definitions need to be updated.
So if you want to see what’s going on here, and maybe be independent of this step, try without Defender definition update with the fresh Windows build 14393 install.

Hi, sorry I’m late to THIS party. I have not been able to use CIS for several builds now. I was getting a not compatible with windows message but now it’s the signed driver messages. I installed 10 on an old desktop a few weeks ago and CIS continued to work normal as did a laptop I updated last week. It’s This laptop that won’t allow it. ASUS G750JM.
I just wanted to add my observation to the discussion…

P.S. I’ve disabled Defender, tried running as administrator and ran in “8” mode. A you tube video suggested extracting the installer, but I don’t have that option when I right-click.

Yeah for me again it doesn’t work, don’t know why sometimes it did work, just confusing and it made me sound like a noob.
Maybe signature checking server is sometimes offline/busy, or it has something to do with UEFI Safeboot, beats me, gave up, will wait until more people report it and it gets fixed, or MS fixes/changes it with hotfixes.

I did see this, which may be related.

Try installing 7zip that will provide the option.

That’s also noticed by ts:

I will quote the linked ghacks article Windows 10 Version 1607 driver signing changes by nuhi:

Microsoft announced recently that the upcoming version 1607 of Windows 10, known as the Anniversary Update, will only load kernel mode drivers that are digitally signed by Microsoft.

The change won’t affect all systems however the company notes, as only new installations are affected in the beginning.

Starting with new installations of Windows 10, version 1607, the previously defined driver signing rules will be enforced by the Operating System, and Windows 10, version 1607 will not load any new kernel mode drivers which are not signed by the Dev Portal.

The list of exceptions to the new policy is long. Below is the most important information in regards to the new kernel mode drivers policy:

  • PCs upgraded to Windows 10 Build 1607 from a previous version of Windows (for instance Windows 10 version 1511) are not affected by the change.
  • PCs without Secure Boot functionality, or Secure Boot off, are not affected either.
  • All drivers signed with cross-signing certificates that were issued prior to July 29, 2015 will continue to work.
  • Boot drivers won’t be blocked to prevent systems from failing to boot. They will be removed by the Program Compatibility Assistant however.
  • The change affects only Windows 10 Version 1607. All previous versions of Windows are not affected.

In short people doing an upgrade installation are not affected but people doing a clean install will be.

OK, so I’m guessing that’s a confirmation that this is a real issue/task.
Please keep us updated on the progress, maybe move the topic back to the active bugs section to gain more visibility.

That worked! The video used winRar which is what I had.
I extracted the 64 installer, AND IT DIDN’T WORK EITHER. Really? Thanks MS. I appreciate the ‘free’ 10, but lighten up.