Virus scanning trouble

Here’s something to ponder over…I set up two new scans earlier. The first being sys32 folder and second the windows folder, I tried the sys32 folder first where I’ve been having all the trouble and the scan completed, I then tried expanding the scan to the complete windows folder and that completed, but when I tried to scan the C:drive the scan stalled again in the sys32 folder??? fathom that one if you can :slight_smile:

I think it fails after a scanning some amount, not on a particular file. Some times it scans a lot less files on my disk (another bug) and it then completes.

Were you standing on the power cord while it was running?

Seriously, this is obviously affecting a lot of users, & with no sign of solution in the pipeline, or at least an acknowledgement from Comodo, I for one will have to look elsewhere for my antivurs scanning…

??? lol no, nothing trapped/squashed. This problem has only started on my other com since 3.8 version came out.
Version 3.5 had no problems at all.
I do hope there is a solution for this soon :slight_smile:

CIS is a great suite and runs fine on my com BUT It looks like I will have to take it off my mothers com until this bug is sorted :frowning:

Please could we have some confirmation/reassurance from the devs that this is being looked into.

Same problem here with CIS 3.8.65951.477

Virus scan always stops at either two files in the C:\WINDOWS\system32\drivers folder: n4_mini.sys or ftdisk.sys in that same folder. As others described, the computer totally hangs; no way of stopping or killing the process. Only way out is hitting the reset button… :cry:

My system should be powerful enoug; the quadcore CPU load is never more than 25%

System information:

Naam van besturingssysteem Microsoft Windows XP Professional
Versie 5.1.2600 Service Pack 3 Build 2600
Fabrikant Microsoft Corporation
Systeemnaam RR
Systeemfabrikant INTEL_
Systeemmodel DG33FB__
Systeemtype Op x86 gebaseerde pc
Processor x86 Family 6 Model 15 Stepping 11 GenuineIntel ~2400 Mhz
BIOS-versie/datum Intel Corp. DPP3510J.86A.0293.2007.1002.1519, 2-10-2007
SMBIOS-versie 2.4
Map van Windows C:\WINDOWS
Systeemmap C:\WINDOWS\system32
Opstartapparaat \Device\HarddiskVolume1
Landinstelling Nederland
Hardware Abstraction Layer Versie = “5.1.2600.5512 (xpsp.080413-2111)”
Gebruikersnaam RR\R Hond
Tijdzone West-Europa (standaardtijd)
Totaal fysiek geheugen 2.048,00 MB
Beschikbaar fysiek geheugen 1,48 GB
Totaal virtueel geheugen 2,00 GB
Beschikbaar virtueel geheugen 1,96 GB
Ruimte voor wisselbestand 3,83 GB
Wisselbestand C:\pagefile.sys

Hope this will be fixed soon; untill then I shall have to disable scanning altogether, I’m afraid…

This problem hasn’t gone away!!!

Having same problem but with different file. On my system, it hangs on /system32/igxpmp32.sys. This is display driver from Intel. I found a workaround on my system, though. Created 2 scans, one for the Windows folder only, then one for the rest of the drive. Kinda inconvenient, but it works for me until devs fix prob.

Hi yes I think I’ll have to do the same until this gets resolved, funny thing though my scanner doesn’t always stick on the same file, it varies?? don’t know why.
Anyway lets hope it does get sorted soon :slight_smile:

Guys, let’s hope they fixed it in the new CIS version which was AFAIK sheduled at the end of the month. I assume that this has nothing to do with signatures, but with the coding of CIS so they can’t fix that with sig updates. If I remember right they will change the way the exclusion works at least :slight_smile:

So please remain calm until the new version is there.



Have you tried removing DEP from cmdAgent.exe? (note this cannot be done with Vista x64).
This has worked for other users.

How do you do this in XP Pro? The option that I have enabled is “Turn on DEP for essential Windows programs and services only” so it sounds that it should not affect cmdagent, but I’m still having major lockup issues. Do you have to mess with the BIOS settings and turn it off at the hardware level?

It was a suggestion to try. If you change DEP settings in BIOS it is at the hardware level (if your computer supports it).
You are correct in that your DEP setting should not effect cmdAgent.exe in any way.

Tried removing cmdagent from DEP, no luck…
Still got the same lockup during a 10 minutes scan of system files, from which the only escape is the power-off button…

This problem seems to be over several different threads now. Maybe other lockup instances are slightly different, or maybe the DEP solution works for Vista?

Win XP, sp2. CIS 3.8.65951.477, Virus sig DB 1062

I have not read all posts before, with the risk of asking stuff already asked.
Did anybody disabled the “scan archives” before scanning the \drivers folder ?

Tried that today & it didn’t work.

I did make some progress however…
By disabling the Real Time scanning during or before starting a manual scan I was able to get much further through a complete system scan than before, & was able to stop the scanner without having a system lockup requiring a reboot. I think it might even have completed the scan & hung up on the last file.

As usual the scan came to a stop although it still seemed to be running.
When I tried “Stop Scan” nothing happened first time, but the second time I got a Windows error & cmdagent crashed, freeing up my computer again.

So I’m wondering now if there may be a conflict between the Real Time scanner & a normal virus scan?

Can you please check the Windows eventlog (application/system) (start, run, cmd, eventvwr [ENTER]) and see if you can find the crash details logged there ?

For Real-Time conflicting with Manual it could well be they seem so share the same scan threats.

It could also be that the scanner is running out of resources, that was a crash cause on a few previous bugs.


I am also experiencing the same scanning trouble, as I type CIS is currently stuck on system32/drivers/fspad.sys. The computer is running on XP Home 32bit.

Scan will not stop once ‘Stop Scan’ is pressed.

@Ronny: No crash in the event viewer.

If I’m correct and you press Stop and it doesn’t react cmdagent.exe has already crashed and is no longer able to report “stop” back to the GUI.

If it happens again, can you check your running processes to see if cmdagent.exe is still running ? using taskmanager or CIS view active process list.

If I'm correct and you press Stop and it doesn't react cmdagent.exe has already crashed and is no longer able to report "stop" back to the GUI.

Can also replicate this by pressing ‘Stop Scan’ during a scan.

cmdagent.exe is still running.