Virus scanning trouble

Lately my daily/weekly virus scans have been taking much longer than usual to complete (a good hour or even longer). I have canceled the last three for this reason, and tonight received an error code with a message saying there were “insufficient resources” to complete my request to start a new scan. I’ve since restarted my computer and manually started a new scan after setting my heuristics to “medium”, and the scan successfully completed and showed one error: C:\ProgramFiles\MozillaFirefox\plugins\np_gp.dll. I’ve quarantined it, but am reluctant to delete without knowing whether its’ a true threat.

I’ve been reading posts about similar problems (people have mentioned their scans stalling at “system32” and Firefox in general, which rang some bells), and also read about “false positives” sometimes being at play. I haven’t been using Comodo for long, and freely admit that I have only a very basic understanding of what’s going on behind the scenes with issues like this – can some of you more savvy users give me some tips and/or reassurance?

Cheers, and thanks!

I am having similar problem, the virus scan stalls at 146435 going on almost 3 hours now and it won’t move. I have uninstalled it twice thinking something got corrupted but no luck so far, on the part where it says status it gets stuck at:


Any ideas as to what the heck is going on? I use to run a virus scan couple times a week without any problems but now I can’t run a scan since it stalls like it is now.


I tried that suggestion twice but no luck, plus I tried to post a reply but I keep getting a error.

Hi I’m also suffering with the scanner sticking problem. My scanner just sticks on C:WINDOWS\system32\drivers\pci.sys

I did post this problem about a week ago in the anti virus bugs section but I didn’t get any response.

Some advice would be appreciated

Hey there everyone,

It’s perhaps just a temporary fix but have you guys tried to exclude those files ?


Just tried another scan and this time the scan has stopped on the same file as above. Something strange going on here.
Maybe as suggested by eXPerience excluding these files will temp’ fix the problem, but the problem does need addressing on a permanent basis of course.

Same problem here, AV scan hangs at c:\windows\system32\drivers\ftdisk.sys

I started it as a “Critical Areas” scan.

I can’t even stop it, it’s completely hung and it took down the entire computer with it, completely frozen now.

I hope Comodo will address this soon. The AV part of CIS leaves a lot to be desired.

I’m going to move this to the bug reports guys :slight_smile:


I’m sorry but the AV is unusable in 3.8 for me:

  • false positives galore with reports that go unanswered and no upadtes to the signatures
  • AV scan hangs that take my entire computer down, I have to hard reset it
  • slow disk defrag that hasn’t been solved since 3.5, even though reported by many users

3.5 was stable, too bad the AV database updates stopped.

I think I’ll have to reinstall 3.8 without the AV part and use either Avira or Avast until CIS gets its AV act together – any recommendation between the 2, known to be more compatible with the non-AV parts of CIS?

Well, instead of reinstalling I would sujest you to just disable the AV. In the meantime use Avira :slight_smile:


I run a daily AV scan and have had no problems until today.
After 40 minutes the scan stuck and completely froze my computer.

I hope that this can be sorted out.

(Windows XP Pro SP3)

Well, can you guys please upload the files it gets stuck on ? To mediafire, or just add them in an attachement. I’m not sure, but I guess it could help the devs :slight_smile:


I don’t think submitting these files helps. I doubt there’s anything special about the files themselves, my feeling is it has something to do with their location (c:\windows\system32\drivers) and the fact that they may be locked while the AV is trying to scan them.

I personally removed CIS and installed it without AV and I am using Avira for now with a 30-day trial. Hopefully 30 days will be enough time for Comodo to address the AV issues. I can live with the exceptions for false positives and even with the slow defrag, but an unstable system is not acceptable.

I am also having this trouble, but I believe it may go much farther than what anyone else has mentioned here. I did the CIS update on 02/28 to the 3.8… or whatever the most recent complete update is. I have a scheduled weekly scan on Sundays at 11am. I was not at the computer during the scan that would have taken place on Sunday, but when I did return there were no errors present and the scanner was not showing, so I would have to assume it did its thing, at least that one time???
I use OpenOffice and went to open a document today and couldn’t. It asked me for an ASCII File Type to open every document I tried to open and no matter which file type I tried to use when a document opened all I get is “#” signs. I have 35 sub directories under my Documents and there are a ton of documents in each of those. Everyone one I have tried to open is this way. So I started doing some investigating. I found that every file associated with OpenOffice, and even some not associated with it had a file modified date and time of 03/01/2009 12:55 pm. Wow, every file same date, same time. And that is about the time the scan would have been finishing up from the Comodo Virus scan. Is this just a coincidence? I doubt it very seriously.
Anyway, I started looking around for things such as virus and other malware that might have gotten on my computer. I did a scan with Threatfire, Spyware Warrior, aSquared, Spybot, and then tried to do a manual scan with Comodo. I have tried that 3 times now and it has “hung up” all 3 times between file #449 and #460??? I didn’t catch where that was in the scan. When I say hung up I MEAN HUNG UP. If you hit pause, the scanner window goes gray and your can’t do anything else. If you hit stop, the scanner window goes gray and you can’t do anything else. It will pop up asking you if you want to quit, but that doesn’t make any difference - hitting yes does nothing either. Hit the “close” icon - same thing. You can’t even open Task Manager with “ctrl-alt-del” to close down the process/program. After clicking several times around the scanner window you get the popup about the program isn’t responded do you want to end it. Well, that shuts down Comodo, all of the Windows desktop, the task bar, the tray - but the Comodo Scanner window is STILL THERE!!! DOING NOTHING!!! And I had figured that Comodo had been up and going long enough with the antivirus that it should be a done deal, as I just started using the suite about a month. And everything was going good until this. I don’t know what the heck this last update did but it sure has screwed things up royally for me!!! LUCKILY, I made a backup of all my documents on 02/28, so hopefully OO will be able to open them correctly, once I get them transferred back on the hard drive.
Looks like the only option now is to disable the virus scanner - maybe even go back to just the firewall, and use someone else’s antivirus. This is terrible!!!

I am also having a total computer lockup every time I run a virus scan.

I’ve been using the virus scanner for 3 days: went OK 1st day, yesterday it ran OK but didn’t display when it finished.
Today it ran for 40 mins & then hung. I finally had to power off to reboot the system.
I’ve tried 2 other, shorter scans, since & it’s done the same each time. It’s not file related as it has stopped at a different file & folder each time. The files it stopped at last time passed individual file virus scans.

I’m running the latest CIS version on Windows XP SP2.

Hope this contributes…


Excluding the files does not help. It scans them anyway.


I too have the same problem I repoted this over a week ago. Hopefully now something will get done about it :slight_smile:

Here is my original posting:-

Win xp home sp2 32 bit
CIS latest version .477 with lates Virus db 998
no other security apps

Hi I thought I would try a virus scan of my other com again now this latest version has come out. Unfortunately for me I still have the same problem as before with the other version.
My scanner just sticks on C:WINDOWS\system32\drivers\pci.sys…I left it scanning for about 30 mins and it didn’t move off this file. The duration counter is still counting and the magnifying glass is still spinning around as if the scanner is still active but I’m sure it doesn’t take that long to scan one particular file. Also if I pause the scan from there and then click stop, both the pause and scan buttons grey out and I am unable to get rid of the scanning screen. If I click on the X to try to get rid of the screen I just keep getting the other pop up window saying are you sure you want to stop the scanning. If I click yes or no it makes no difference, all it does is close that window. The only way to get rid of the scanning window is to power off the system.
Any suggestions?? and is anybody else still having this problem??

This is a known bug and we are waiting for a fix. I have found no workaround.

Yes, this is still a behavior of CIS that has me scratching my head. After all, what does exclude mean…

It scan the files but does not report what it finds. I would rather it did not scan at all.

That’s what I was trying to get at. Exclude would imply it was left out of a scan. That is after all what exclude means.

I made a post about this just after I started using CIS. I still haven’t heard anything from the devs as to whether or not the list is broken or if it is functioning as they had intended. If it is as they intended, they need to change the help file regarding the exclusions list.

I suspect it’s broken because they are striving to make a very resource friendly application, and scanning files the user doesn’t want scanned is definitely not saving any system resources…