Virus Database Updates are VERY slow...

Hi there,

I use Comodo on all of my Windows machines, and have noticed that the daily antivirus database updates can sometimes take as long as an hour. All of my machines, both PC’s and laptops, are always connected to a FIOS or T1 network either at home or in my office respectively, and yet today it took 52 minutes to download the latest updates.

I ran a speed test on the network through and it clocked at over 5.2mbps which is extremely fast, so obviously the bottleneck is software-based or on your end.

That said, is there any way I can expedite the signature updates?

Thanks in advance.

good day and welcome to the comodo forum,

that is a very long time to do an update… maybe there is something wrong with your installation? did you try to run the built in diagnostic tool? maybe try to do a reinstall on 1 of your machines and see if the updates are faster…

Hi there,

As I stated above, I’m running Comodo on multiple machines, running XP and Vista, in multiple environments and all on high-speed broadband, and they all update very_slowly. All of the machines are pristine, spyware/malware free and are used only by me - a software engineer with over a decade of experience in the field.

That said… I’m fairly certain that when I said the bottleneck is either in the software or in the pipe on your end of the net, that’s probably what it is.

I guess the question I should be asking is whether or not Comodo updates from a single location on the internet or if it has the ability to download the updates from several mirrored locations (and not just the primary data center). I know this problem isn’t limited to as one of my coworkers commented that his PC at home runs Comodo and he’s had virus database updates that took over 15-20 minutes (he runs Comcast Cable).

It almost seems like the virus database is downloading in a passive way, as if the bandwidth is limited to less than 3-5kbps. Is that correct and if so is it possible to knock out that bandwidth cap via a setting I haven’t found or a manual registry change?


Yes, I agree you. the problem occures in different environments, on different platforms, on several different locations… the problem could indeed be software related, but I think the problems are with Comodo servers at the moment (could be the central data center).

The suggestion to download from different locations is a good one, I support that idea! maybe you can add it to the wishlist?

I am really not sure if it is possible to edit through the registry a setting of the firewall to remove a possible bandwidth cap, my knowledge is limited about that I am afraid so…

It is possible that Comodo has some problems with the net and servers that causes these huge delays in delivering the updates, it is also possible that others have same problems…

Maybe it is good to wait a day or two and see if this problem is a minor incident or a more comprehensive structural problem…

Thank you!

When updating, it is not the downloading that takes a long time, it’s the installation of the new signatures. You can view this in the “Active Connections” windows. cmdagent.exe will only be active for less than a minute while DLing. Then, the update percentage completion will stay at 90% for a while while it installs the updates. This slow installation of updates should be fixed with the new signature format currently in beta. :slight_smile:

I just downloaded the latest version with the AV and tried to run a virus scan. I too am a knowledgeable guy, with clean systems etc. In fact I was previously running the Comodo without the AV, as well as Threatfire. I just uninstalled the old firewall and installed the version with the AV.

In my system (only one so far) the Virus database update simply hangs. Zero progress! And it is in the download phase. Furthermore I cannot run a virus scan because it simply pops up the “downloading” dialog and hangs.

This with a Dell M90 (pretty powerful system) running Vista with 4 gigs ram and a 10 mbit connection to the internet.

IOW, at this point I have no AV as I uninstalled my old AV before installing this new Comodo version. Not good!

I just rebooted my computer this morning to see if that helped. Before the reboot the scan refused to run saying it was updating the database, a manual update would just hang.

After the reboot the manual database update just went right through, took about 30 seconds to one minute, and a scan would start promptly (though it is pretty slow, you can watch each file go by).

So it APPEARS that for now my problem is “fixed”.

I run Comodo AV on two systems and have experienced the exact same -extremely- slow update of the database, well over one hour (download time). I think this must be either a flaw in the software itself or with the servers (most likely?) and not the individual systems trying to get the updates. My systems are: 1) A very old IBM T20 and 2). a DELL XPS M1730, very fast. 10MB broadband and Windows XP Pro on both. Other software online updates of various sorts takes merely seconds to download, installation however differs considerably between my two systems, naturally, as the IBM is very slow in itself.

This is evidently not an issue with the individual systems at all…

I am glad your problems are solved for now… the problems were probably more server related than the personal system setup of each individual… Though it is possible that there is some kind of software related issue, if you experience some problems you think is software related, the best is to describe your issues in the bug report section of CIS.

For now I wish you all a very nice day!

02-03-2009 I too run three machines with XP-home and pro Athlon, P4 and p3… connection is by cable broadband.
all machines take well over an hour…

You’ve got it easy Im running a Q9450 and thus far the update has taken almost 3 hours under Vista Ultimate 64 bit, happened the other night under XP 32 bit as well on the same machine, I have 3 desktops and two laptops in my home and they are all suffering the same speed issues.

Me thinks this is either a bug in commodo Internet security or a huge software incompatability is going on between CIS and some basic part of the OS which is :frowning: because I really like the product but this is making me seriously think twice.

I have the same problem! Update stucks to 30% and nothing happens…11 minutes passed

This is a bug as far as I can tell. It could be some hardware/software incompatibility on certain system setups. The best is to describe the problem in the bugreport section of CIS, only then there is a chance it will be fixed in next program updates.

I have had this problem since the beginning. The database upates get to 30 percent and then the system just hangs. I have just downloaded the latest version 8.65951.477 in the hope that this would improve things. I had to manually download and install as the update would not work. The result is the same 30 percent and then hang. It would be a really good idea to provide the virus database definitions as a seperate downloadable pack like many other systems so that a download manager could be used. At least then we would know when to quit from the internet. I have been trying to update the database now for FOUR HOURS.

Argh… Ok, it’s been more than a month that I’ve been waiting for the updating problem to be resolved. I’m jumping ship now, as I’m more than a bit aggravated by the situation. To my knowledge the definitions were only updated once successfully.

For the record, this was a new Windows xp professional installation, with service pack 3. Comodo version 3.8.65951.477 was fresh installed just after the Windows installation. The virus definitions stand at 1062 and the annoying “updating your virus definitions” popup perpetually comes and goes. Manually launching the update program gets the usual 30% download hangup with a warning about it failing and the subsequent finger pointing at my internet connection.

Not sure what’s wrong, or why your programming team can’t fix it but enough is enough. Thanks anyway.


I dont have any problems downloading new sigs. Believe I only had that error once in the months CIS has been installed, and when I tried it again right afterward and everything worked fine.

My problems is CIS takes several minutes just to compare the version I have to the current version. IDK why that takes so long.

Same problem here… stuck at 30%.

Plus it repeatedly gave the error message, “Failed to update the virus signature database. Please check your internet connection and try again later.”

I just kept on attempting to update, and FINALLY after 30 minutes it jumped to 51%. From there on the counter was more reasonable, and reported the status change every 1 or 2%.

The answer seems to be PATIENCE, and lots of it.

After installing CIS there is a big datebase to download. About 34 MB. That takes time. During the process the progress indicator will stay at 30% for a long time before it will go up. That is confusing and annoying.

I have this problem too, it’s so bad I have had to turn off automatic updates and run update when doing nothing else as it seems to take over my older PC

Automatic AV updates can’t be disabled.