Updated Comodo Firewall on x64

I updated CFP today. I completed it’s task and asked me to restart. Since I had been done with what I was doing I proceeded to restart. When I restarted things didn’t behave properly, Comodo Firewall didn’t load or initialize. I restared in safe mode and hit upgrade, (there was something else to upgrade) it finished upgrading but broke some system things (after final upgrade). I use a lenovo thinkpad (Vista x64) and it’s productivity center won’t load (and everything assosicated with it, power management, wireless…etc) that part is completely broken. I decided to restart in safe mode this time and the security center for windows didn’t start up and I couldn’t start it (broken). Also I can’t start any application not x64. I’m currently using IE 64.

If that didn’t make sense, here’s a summary:

  • Upgrading Comodo Firewall for me broke my “windows security center”
  • When I started up in safe mode to complete the upgrade process that broke applications. I can’t load Firefox, Matlab, Acrobat, etc (everything and anything). IE64 and Thunderbird 64 does.
  • I uninstalled Comodo Firewall and cleaned with ccleaner, and restarted in safe mode. Installed newly downloaded Comodo Firewall and restarted.
  • Yay Comodo Firewall installed properly…applications still broken though (can’t load anything…)
  • backing up work on notebook now
  • upcoming weekend to reinstall OS (:SAD)

Just an FYI, something in the upgrade broke the “windows security center” and now no applications load. I try to start an app and task manager doesn’t recognize anything being done. Wish I could restart “gnome” ala linux…sigh


When I run in safe mode I am able to load applications fine, except it’s in safe mode…

Anyone know why CFP would maybe stop my services and not allow them to startup? I think that is what has happened, but I’m not sure how to restart the services which I need to run applications…


Same problem here. Windows Vista 64bit.

After updating the firewall to version 3.8 Windows stopped loading most of the services/programs. Starting programs isn’t possible. Only thing I could do was uninstalling Comodo Firewall to make Windows usable again…

I tried to set the defence level to allow all/disable or training. All without effect. Also I disabled my virusscanner and other processes, and I even disabled loading them at startup. Also without effect. It looks like Comodo is blocking something while starting Windows…

The very same thing happened to me today. Vista x64.

Auto-downloaded and installed the newest update, restarted.
No program would work anymore, not even Internet Explorer would start up (lol), no services could be started other than the very core windows services.

Uninstall Comodo solved the problem, after i spent hours and hours of virus / spyware scanning in save mode (since no application would start in normal mode) (thought it could be a virus since I’ve downloaded porn in the same session (:KWL)).

Now I’m gonna install another firewall. I’ve spent many years with Comodo and was almost always satisfied with the firewall, but this is just ridiculous (and i’m not someone who writes angry posts normally, I’m usually very understanding with software bug things since I’m a programmer myself (:SHY)).

It’s funny imagining all the ‘normal’ users who have no idea whats wrong with their computers (:SAD)

Info for you Comodo guys:
Vista Home Premium x64
Avira AntiVir
Lots of Anti-Spyware Software


Maybe we can list things our computer have in common. I noticed that you are using Avira Antivir too. Also I have a lot of other anti-spyware software installed. BO-Clean, SuperAntiSpyware, MBAM, Spybot S&D, AdAware 2009. But only BO-Clean and Antivir running at startup and using resident protection.

Further there are a lot of other services/programs, like Daemon Tools, MSN, LogMeIn, Poppeeper, ProcessXP, SabNZBd, RMClock, UltraVNC, Belkin USB Network Hub controlcenter.
All running on Vista x64 SP1.

Hardware: Q6600, Intel P35 chipset, onboard Realtek NIC, 8800GT.

Doing a complete uninstall fixes the problem? Ok i’ll try that…but i love me comodo sigh.

Anyone have a link to download a previous version until they fix this issue I don’t mind going back.


This may help you understand what happened:

Quote from:

First post:

Important Note for Windows Vista Users Upgrading From Older Versions

The Windows Vista users, who have CIS version 3.5.57173.439 or older installed(32 and 64 bit), are going to have 2 updates because of the nature of this release.

  • The first update is going to update some critical files that are necessary in order to continue with the second update.
  • Then the second update is going to finalize the upgrading process to version 3.8.64739.471

End Quote.

The best way to ensure it is installed and functioning properly is to uninstall any version already on your computers, reboot, then install the downloaded new version (x32 or x64) directly onto your system. Reboot again and all should be OK.
If updating from 3.5, do NOT use any saved configurations with the new version, as this will cause problems with the new version 3.8

I hope this will help you gentlemen.

Thank you for your help.

A complete uninstall doesn’t fix this problem. First I tried it with autoupgrade, and the second upgrade. Windows was unusable.
Then I did a complete uninstall of the firewall. After that I downloaded and installed the firewall ( v3.8 ) again. Windows went unusable again. After that I did an uninstall + removing old files/regclean. Still no succes.

after downloading the first update i didn’t see any option or indication of the firewall to install a second one. and since connecting to the internet was impossible after the update, there was no way to get this information.

i have no idea which version i had installed previously. i always had auto-update on.

even if there are two updates to install, if the firewall doesn’t tell you that there is a second update and you can also not go to the internet to find out, it seems like the situation could have been handled better by the programmers.

@Kevin: yes, i do use some of these programs, but it seems the problem is elsewhere. what surely solves the problem though is to not install comodo again (:NRD)

ps: yeah, i’m still angry (:AGY). not because of the trouble the program causes here, but because of the lack of communication that causes the normal user a lot of trouble since there is no way to find out whats wrong when you cant visit this forum. the program should tell the user whats going on.

I happen to have the same problem… after i updated comodo… my system stopped functioning properly…avast wouldn’t load,ad-aware,firefox wont load,etc the only solution was to uninstall comodo :’( i feel naked without comodo :-[

my system
Windows Vista™ Home Basic 64
ad-aware anniversary edition

Hi, see my post “BSOD after update” under Install/Setup/Configure, this board.



I have a similar problem, I just updated Comodo Firewall and it has stopped Ad-aware (anniversary free version) from working. The Ad-Watch Live from the tray does not show up anymore and when I try to run the Ad-Aware program, it freezes in the loading screen. This problem does not occur during the previous version.

Apart from Ad-Aware and losing all my safe-file list and blocked file list, everything else seems to be fine.

I am using Windows XP Professional x64.

Any assistance will be greatly appreciated, thank you.

Honest opinion.
Lose the Ad Aware. Not a hater, I used it back a while and I can see great potential for conflicts.
Especially between Adwatch and D+.
If you are running the full CIS suite and maybe BOClean separately until it’s built
in to CIS. All the other stuff you could install is more trouble than it’s worth.

Honest opinion.

Same Issue’s here… Using Windows Vista64
I have been using comodo firewall for quite awhile, however the latest update didn’t install correctly, and it updated the firewall to full blown internet security suite (yes I did the 2 updates). I encountered a few problems. 1. It deactivated my previous anti-virus(avast home edition), and I could not get it to re-activate, even through windows security center. 2. I couldn’t start ANY programs other than windows default services. NO INTERNET ACCESS through various web browsers (IE, Firefox, or Safari wouldn’t even start). I did have the icon saying my computer was connected to my network (and Internet). 3. I decided to do a system restore. Comodo somehow prevented a system restore completing successfully (windows stated as such, and I had the same issue’s as before). I have used windows system restore to correct or revert other issue’s with comodo in the past, however this time I did a complete un-install and reverted to a restore point from 2 days ago with no issue. I have everything working, and I won’t be re-installing this product anytime soon (I really don’t like doing a fresh install of vista64) I liked the firewall as a stand alone product, and as since that is no longer the case, I will discontinue use of the product :’( after several years of use…

I did some further research and I think I found the part that is making problems. The firewall (and virusscanner) work when you disable the Defense+ program permanently. So when you start your system and everything is blocked and messed up, you open the Comodo tray icon and turn Defence+ off. Do this by going to the Defence+ tab in the program > advanced > Defence+ settings > mark Deactivate Defence+ permanently (requires a system restart).

After rebooting Windows works fine again, with the Firewall (and virusscanner) enabled. Hope they can fix Defence+ soon!

thank you.

there are obviously many people here who have a much better understanding of this firewall than i do, but could this problem (if it really is defence+, havn’t tried it) be a conflict issue with ad aware? it seems everybody who has this problem also uses ad aware. although i have no idea if ad aware actually goes that deep into the system to be able to conflict with defence+.

kevin, have you tried not using ad aware and putting defence+ on?

i don’t know yet if i’m gonna give comodo another shot. looking for other options atm.

You’re welcome.

I allready disabled Ad Aware (no autorun or resident protection). But that didn’t help. Now I uninstalled Ad Aware completely and CIS is working perfectly now!

I enabled Defence+ again, but I set the status on disabled. Then I rebooted the PC and put the defence status to safe mode. And it is still working :slight_smile:

That doesn’t sound right…why would removing Ad-Aware fix the problem? How many other programs will I have to remove before I can get my machine operable again…zzz

I’ll try same method and post results because using my computer is more necessary than to use Ad-Aware.

If a Mod wants the error report that was generated when I updated CFP post an email. Otherwise I guess we’ll continue to talk about it and see what works.


same thing is happening to me. I updated and programs wouldnt open up. as someone said, i dont get a notification for a 2nd update since there is supposedly two. can a moderator or support staff member please comment in this thread about whats going on and if its being fixed?

EDIT: can anyone recommend another firewall for 64 bit until comodo fixes this issue?

The second update doesn’t fix things either dude. It just fully installs CFP but leaves your windows unusable. If it makes any difference I was able to get the second update running in safe mode of windows. But that just installed CFP completely and didn’t fix the problem of making windows unusable.

You need to follow the steps that Kevin D. states. I just did same and that does fix problem.

— HERE IS FIX ----

  1. Disable and Deactivate Defense+ on Comodo Firewall.
    Defence+ tab in the program > advanced > Defence+ settings > mark Deactivate Defence+ permanently
  • Restart computer
  1. Uninstall Ad-Aware - Restart computer
  2. Activate Defense+ on Comodo Firewall - Restart computer
  3. Enable Defense+ on Comodo Firewall

There is a few restarts so the whole thing can take a while. Also just as an FYI I don’t use any of the Ad-Aware Adwatch services (I don’t have them starting on boot or loading in background. I don’t use autorun/resident shield/etc…). I just use Ad-Aware as a manual spyware check every so often (unscheduled). I’ll check back later if another CFP update was issued or if the bug was found as to why this was happening, but for now following those steps fixes the problem.