Update Testing to Comodo Internet Security v12.2.2.7036 RC

Hi All,

Before we release Comodo Internet Security 2020 v12.2.2.7036 RC as a general availability release, we would like some beta testing feedback for the update system.

For volunteers, we’ve listed below the previous versions to install to test the update to v12.2.2.7036.

Please install the previous versions and test the update system as detailed below. You can download 6818, 6870, 6882 and 6914 from the links mentioned.

Here are the steps you should follow:

  1. Download the previous version from the related link.
  2. Before installation, make sure there is no IP in your host corresponding to download.comodo.com
  3. After installation please ensure you have restarted your system and change your host to include download.comodo.com
  4. After that, you can click the update button. But please close all your apps before starting the update procedure.

There will be a 2-step update and when you restart the computer after the first update, the second update will be done automatically, and your computer will be restarted when the process is finished.

Comodo Internet Security Online Installer:
Size: 5,625,088
MD5: 4aa1126b9d385637b375a13df6bb17a2
SHA1: d1e05feaa6f1f7cf97c8bc81f44c6a63e94a929f

Comodo Internet Security Offline Installer:
Size: 77,004,280
MD5: 5531a4675bd4d6fcbc0e17e4797e9b80
SHA1: a1d7928941bdc77fd6af61eb00d393f85f04741a

Comodo Antivirus Installer:
Size: 5,625,088
MD5: 9c99f75580244bddc65ded1254aefa07
SHA1: 6f5d5df11cf91413fcf517aeaeb9324a207a729f

Comodo Firewall Installer:
Size: 5,625,088
MD5: d87d2b4979ff8ee6649e3982b7f9bbf0
SHA1: c839d3f06ae59d2afff4ebc7277ce834f1042f45

Comodo Internet Security Online Installer:
Size: 5,649,344
MD5: e767263f1388d51069b3c960aa296c23
SHA1: 7d97b958f05b9545035b5c53bf75b297585be2a4

Comodo Internet Security Offline Installer:
Size: 77,727,688
MD5: 775ba7618ab53af9d6f9bc0893364d47
SHA1: ce29fdfca90f3ea2ec8e65944f7633abb9f84565

Comodo Antivirus Installer:
Size: 5,649,336
MD5: c055aee0c22c9796aba8c80ea25bfb63
SHA1: 6b1a4677026a3e80711c82e4a561ce21d4598690

Comodo Firewall Installer:
Size: 5,649,336
MD5: a364e798600286075ff41995a32993d5
SHA1: ffa4d56277f238d8066ad6f63d00e3a864bed771

Comodo Internet Security Online Installer:
Size: 5,637,360
MD5: 36ea4d3e5331812f6d045e2bfc893f05
SHA1: 7be07df8fb95419670b85efd1b65ffde79b8daaf

Comodo Internet Security Offline Installer:
Size: 68,186,664
MD5: e0b576a13816e77ff4ac344ab4387b01
SHA1: 77ae547f1625903acd6281172714244f7b03636f

Comodo Antivirus Installer:
Size: 5,637,352
MD5: 7d0da57c318e9a60d70d740bfa56dc0e
SHA1: ab1ed9eda6ee55fb65abd3c16a9385fa66241846

Comodo Firewall Installer:
Size: 5,637,352
MD5: 57fbd3c15b02de94aecf6d74cc040569
SHA1: e9c772f76bdf031b49f41f91077e90e1e8ef4af1

Comodo Internet Security Online Installer:
Size: 5,613,920
MD5: 7431196569471ab1292ade1ae5238697
SHA1: 7f258cc63f7124b493c701d3b57bbfcf354c714f

Comodo Internet Security Offline Installer:
Size: 75,454,976
MD5: 3a9f81ad02b24e010428f5751825e606
SHA1: 7bc3041c86a649f9768392d50d019760aaca4fdc

Comodo Antivirus Installer:
Size: 5,613,920
MD5: cffa765f8a78f72eabea77a154db0074
SHA1: a2a23e8c06786cfa8f81fb81254fe5368c2c88ed

Comodo Firewall Installer:
Size: 5,613,920
MD5: ab150ff09b2782a54eb6d853112b598f
SHA1: cb72cc531a48f2384697b3ca9467f1d69ba5a4ba

Please give your valuable feedback! :-TU


I was able to successfully update from 6914 to 7036 using the program updater, and seeing that 6914 was the buggy version with folder protection, updating from all other versions should work as well without issues.

For me update from 6914 to 7036 worked as described.

Windows 10 Pro 64bit 1909 (18363.720)

6882 → 7036 RC Update Failed

It downloads the update file, goes to 100% then says:

Error: 0x80070002 - The system cannot find the file specified.

I performed the update but it continued to be out of alignment with the Windows 10 security control system. The Windows Defender antivirus also continued to be active. I restarted the PC but nothing has changed. Furthermore, if you deactivate and reactivate a component of CIS, the X remains on the status icon and you must restart the PC. I went back to 6882, waiting for the new official version hoping it won’t have these problems.

It worked for me from 6882, can you show the tasks log? Did you install 6882 with modified host file, or was it set to normal?

This topic is about if you can update to the latest RC from an older build, not talking about issues that are already known and one such issue that is a Windows bug.

Ah OK. The update has worked well since version 6882.

Windows hosts file was set to normal when installing 6882 using the Offline installer (SHA1: 77ae547f1625903acd6281172714244f7b03636f).

After install (and restart after install) the hosts file was set to the test ips then I restarted the computer again, then I clicked update in CIS.

The recogniser did update however.

I have not made any changes to the hosts file on the PC.
In the CIS proxy and host settings I have disabled https://download.comodo.com/ and added
I clicked update and the update started, running it twice as indicated. All right.

Interesting and weird, I guess you will have to do a clean install when it goes final.

Possibly would have anyway.

Win10 x64 latest - 6914 to 7036 updated w/o any problem


Could you please try to remove the TempFiles in ProgramData/Comodo/Cis/Quarantine/Temp/ and try to update it again? Some old binaries may have remained, and this may be caused by the effect.


download is slowdown (brazil south america) ;
see image… cdn.download.comodo.com download is 500kb/s;
download.comodo.com download is 100, 80, 60kb/s

Just had a look. That folder is empty.

Tried again, and it fails.

Win 1909 pro (18363.720)

Updated from 6882 to 7037 with no problems.
Now it shows 7036 again, but it first showed 7037

Hi prodex,

7037 is a middle version, it is an incremental update method that we employed so that binary update works with all versions of previous CIS installations.


Hi ReeceN,

I downloaded and installed 6882, after a restart, changed the host to download.comodo.com

After that, I clicked the update button. It works very well.

Could you please uninstall CIS and do these steps again? We can arrange a remote session if that’s OK for you.


Thanks, so I wasn’t drunken! :smiley:

update normal, except the database(antivirus)