Update Problems

I have Comodo installed on two systems; the only differences between to two is one has Win XP Pro SP3, and the other has XP Home SP3. The one with Pro has a faster CPU and more RAM. The update installed on the XP Pro system without a problem, but after the update and reboot on the XP Home system, CFP would not load, clicking on the Start Menu did nothing, clicking Uninstall did nothing. Before I do a System Restore, does anyone have other recommendations? Thank you.

Depending on your previous version it could be needing a second update.
For some updates there is a two stage update needed, are you able to run the “check for updates” on the CIS gui ?

Can you also please post what your previous version was ?

No, Comodo does not respond - period. As I recall now when the d/l was installing on the XP Pro system it was taking a very long time and it was passed my bed time, so I aborted the process. When I rebooted I made sure the first thing I did was complete the d/l and installation of the update. There could have very well been two updates and I would not necessarily have known; but as I said in my original post the XP Pro update installation was fine.
I’m concerned about using the XP Home system on the internet without a working Firewall.
Thank you for your response.
P.S. As far as what the previous version was, I have no idea, except to the best of my knowledge, it was up to date prior to this problem update. It was just installed on this system earlier this year or December '08.

If you go to C:\program files\COMODO\COMODO Internet Security and click cfpupdat, that should open the Comodo updater.


Hi kedstar99,
Thanks for your reply.
Did that, but comes back no updates available. Did Belarc of system and it shows CIS version 3,8, 64263, 468 installed, but it still will not load.
Thank you.

Hi Rjmat1 and welcome aboard, my suggestion if you had a previous version and exported your configuration somewhere that’s easy to get it back from, download Revouninstaller and uninstall CIS full out run the registry cleaner included in Revouninstaller, reboot then install latest CIS.
Should be fine from there on… :-TU
Xman 8)

Hi Xman,
Yes i had a previous version, no I did not export my configuration. Is it that complicated?
I was fine before this last update!
Is that the only solution. Are you declaring System Restore not an option?
Thank you.

Hi there,

Can you please run this script and send me the logging ?

PM me please for more details.

Hi Ronny,
Thanks for your continued concern.
Followed your instructions, but when attempting to send file to you as PM (cut and paste), I got an error message, ‘file exceeds 40,000 maximum allowed characters.’
Looking at that printout, it certainly has just about everything on my system. I’m concerned about privacy and confidentiality issues. I’m not savvy enough to know how to proceed. Are there alternatives?
Thank you,

My problem has not been resolved. I did a system restore to prior to this update and turned auto updates off. I will continue with the older version of CFP until the bug can be identified and repaired.
Thanks to all for your every consideration.

Do a clean install of 3.8.xxxx.477 version update problem is solved in it :BNC

Hi devenroy, et al,
Well, you don’t know how much I wish I could say “that worked” … but it didn’t.
Once again I used RevoUninstaller to remove CIS, rebooted, and tried to install CIS 3.8.65951.477, but I continuously got a pop up window titled “Comodo Internet Security” You have an older version of Comodo Firewall Installed. In order to upgrade to Comodo Internet Security you need uninstall it and then install this version. Do you want to uninstall it now? –
Regardless if I click yes or no nothing happens the window goes away, but nothing happens. I tried multiple times; same result. I even made several tries in Safe Mode. Then out of frustration I tried to re-install the old version – same result as above.
So I’m actually worse off than I when I started, because I can’t even install the old version.
I’m sure everyone is trying to help me, but my frustration is growing. Any ideas?
Thank you,

rjmat you can try this option and see if it works, first download comodo system cleaner 1.1.64939.61 version and install it, after that unistall your 3.5 normally with windows add/remove programes, i know revounistaller is better in cleaning the left out files but still use windows add/remove, unistall the CIS 3.5 version then reboot pc, after rebooting clean the registry with comodo system cleaner take back up of registry (this option included in comodo system cleaner) so you just have to say “yes” to it, then it will clean registry and asks for u to restart your pc do it,
after restart you begin the installation of CIS 3.8 then see if it works, it will probably work. :ilovecomodo:

Yep this definitely smells like a bad uninstall, there is still some “uninstall” information left in the registry.
Also check c:\program files\comodo\ to see if there is some “firewall” of “internet security” left.

Hi devenroy and Ronny,
I have not yet tried devenroy’s latest recommendations, but so you both know, after the uninstall I did a system search for anything comodo and two additional files showed up, which I deleted, did a reboot, and tried both 3.8 and 3.5 with the same result. I will try devenroy’s instruction later today, and post back.
Thank you all for your continued help and support.

Hey nurse, it’s getting worse. I used Comodo System Cleaner, which found 650 items; considerably more than half were cookies, another large number of temp files, prefetch cache, and about 54 registry items, which I perused and determined appeared to be harmless; i.e. file extensions, program shortcuts that I know were removed or deleted, etc. After I rebooted and accepted the deletions, all appeared well. I clicked to install CIS 3.8 and the system locked up. Two more tries, same result. I did a system restore to yesterday and the system seemed stable.
Before I tried anything else I figured I would update this thread for any feedback.
Thank you,

So now your back to a crippled 3.5 install that is no longer visible on the Add/Remove Programs ?

Hi Ronny,
No, I think it is visible in Win Add/Remove, but I’m not 100% sure, but you’re right it is crippled - it will not load. I’m taking a break from that system having just spent a couple hours of frustration. When it locked up I had to hit the kill switch, and rebooting is time consuming. During those installation attempts, I unplugged from the internet, and closed as many processes as possible. Let me tell you it’s impossible to stop AVG8, but I guess that’s a defense mechanism against the bad guys.

Sorry to hear that rjmat, i appologize for that, but i myself tried it when i got problem like u, i used comdo system cleaner done back of registry then cleaned the registry by it, then reinstalled 3.8 now its working absolutely fine for me, updating is fine too i m on virus database 1017 which is latest so no worries,
I really want to say sorry from bottom of my heart to you my friend, as this method didnt worked for you and i know it becomes fraustation when things mess up in pc etc.

I guess everyone is getting sick of me but - I’m baack!
I figured I had nothing to lose, so I went thru Explorer/Program Files, etc. and clicked cfpupdat.exe, and it actually went thru an update sequence with the dash track, percents etc. to 100% and Finish, but when I clicked the Icon to open CFP - nothing happened so I tried cfpupdat.exe again and it said updates were available but then popped “Error 118 Update could not be completed. Not able to communicate with Comodo Internet Security Helper Service.” What now?
Your every consideration is greatly appreciated.
Thank you, Bob