Unscheduled quick scan on startup [M1442]

Unscheduled quick scan on startup
Can you reproduce the problem & if so how reliably?:
Yes, very reliably.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:Install CIS
2:Do not update Comodo or run any scans
2:Disable network adapter or connection to WAN
3:Disable Full scan and Quick scan by pulling that icon from right to left in Comodo settings
4:Restart OS
One or two sentences explaining what actually happened:
On startup CIS automatically open CIS main window and starts quick scan and aborts it right after starting it.
One or two sentences explaining what you expected to happen:
I expected it would not run any scan or open any program window automatically and it would run in the background.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how you tried to fix it etc:

Exact CIS version & configuration:
Comodo Internet Security, disabled Full scan and Quick scan (pulled that button from righ to left).
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
I left everything as it is for easy reproduction.
Have you made any other changes to the default config? (egs here.):
Have you updated (without uninstall) from CIS 5, 6 or 7?:
if so, have you tried a a a clean reinstall - if not please do?:
Yes, I have. Clean install in new virtual machine.
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 8.1 64 bit, UAC settings disabled, administrator, VM in Wmware Workstation 11.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=? b=Windows Defender (disabled)


Diagnostics file and KillSwitch Process List in .zip file which was created when I created diagnostic file:


[attachment deleted by admin]

Can you please create your bug report in Required Format
Here : Comodo Forum
Thanks for pointing this issue :-TU

Not replicated on my virtual machine. Please provide exact/additional replication steps.
Initially, the scanning process should involve (first-time) update phase where the latest database is downloaded.

Thank you.

Well, on my VM worked for at least the last one year and a half when I tested at least 4 different versions on Windows 7 and Windows 8.
Before restarting check if you have network adapter disabled because if you do not it will start downloading updates regardless of your automatic update settings and settings for quick scan (updating before scanning).

I added this step for succesful reproduction.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

We were informed that this behavior is by design. In the meantime, I will move this report to “Resolved” section.