Unable to unistall Comodo Internet Sercurity Premium CIS Free

Hi Guys
For the past two days, I’ve been trying to uninstall CIS but with no luck.
I have tried the uninstall tool but I get this error message:

11:7:20 C:\Jenkins\workspace\CisCleanupTool2_vs19\CisCleanupTool2\CisCleanupTool2\RegTools.cpp:46 >> Can’t open key (SOFTWARE\COMODO\CIS\Esm), error 2
*11:7:20 C:\Jenkins\workspace\CisCleanupTool2_vs19\CisCleanupTool2\CisCleanupTool2\CleanupOnline\CisCleanupTool2.cpp:76 >> ITSM Administrator password for Removal tool is not set, skip password verification, exiting…

** I have tried to do an update but it get to about 17% and then fails.
** I’ve tried to delete the directory folder, but keeps coming back.
** I’ve tried to upgrade but it won’t allow me
Deleting registry keys hasn’t helped
Any suggesting on how to unistall this program would be great.

Try the older CIS Removal Tool as mentioned in this post:


Hi VinceZA,

Thank you for reporting.
Kindly use the below ciscleanuptool. (Note: Do not skip the no of the restarts asked while using this tool.)