Unable to export configuration [Merged Threads]

Each time I try to export my firewall configuration, I get the message “Unable to export the configuration. Please make sure you have enough rights for the path”

I tried all sorts of different paths (Documents, Desktop, etc.) but still get the same message. I’m using 32-bit Vista, btw.

Had the same problem (Vista Ultimate), and was told to go to the properties dialog (shortcut) and then compatibility/check run as administrator. Didn’t work for me, but you might try it. For me it caused Comodo not to load when I closed and reopened it, but unchecking cured that at least. Good luck; Ed,

It appears to be a Vista issue (I’m guessing UAC) as I was able to save in XP. It doesn’t matter anyway, coz importing configuration doesn’t seem to work either!.. none of my settings were restored, so I’m sorta wondering what’s the point of having that option in the first place.

On XP when you import your saved configuration do a “Import As” and then give it a different name and it will work then. I couldn’t get the configuration to work either when I used just the “Import” choice.



When I try to export the configuration, I get an error popup “Unable to export the configuration. Please make sure that you have enough rights for the path”. Sure I’ve enough rights, as everything else can write to location a provide (with and without CPF installed).

What is interesting, the file is created - but it is empty.

This problem exists since early beta, and it still exists in most recent release (,
which is installed on fresh Vista system.

I tried to search reports about this problem, but (unfortunately) could not find anything.

Any clues concerning how to fix this? Or is this known problem already?


I have had the same problem since, using Vista Ultimate, Avast! Had a suggestion to run as Administrator-didn’t work, and caused Comodo not to load. Have had no further feedback from Comodo. Took screen snapshots of the firewall rules I came up with instead. :wink:

I have encountered a strange problem on my Vista machine. When I try to export my setting, after I choose a place to be saved where I have enough right to write like in my documents folder, comodo get a busy for a while, then prompt a message you do not have the right to write. Even more strange when I start the firewall with administrative right, the window for choosing place to save do not pop up. There is no any response at all

I had to disable UAC to export my settings-running as administrator was not enough. Export/import hsve worked perfectly since. I have left it disabled, since that also fixed problems with several other programs.

I think that should not be the solution. Though UAC can cause problem, it still have value as a very basic kernel level hips. And the problem might be with the right of the file. I look at the file and see that it is set that user do not have right to modify it.

This bug exists since ages in all 3.x betas, up to latest Nobody at Comodo testing FW on Vista?? When will this finally be adressed?? This is becoming more and more ridiculous…

I have installed v3 of the firewall and have managed to get remote desktop working but want to export my settings so I can just import them if there is ever a problem.

When I try to export the settings I am told I dont have rights to save in the path. It creates a 0kb file with the specified name though.

I am the administrator and should be able to save in my document folder.

I am using Vista Ultimate and CPF v

Any help greatly appreciated.

I am unable to export or import settings without turning UAC off. After that, has consistently worked perfectly. And turning UAC off fixed problems with several other programs, so I am leaving it off.

running as administrator worked for me.
To run as an administrator, I simply right-clicked on comodo icon in the start menu and selected “run as administrator”.

Yes, please pay attention to this. (:AGY)

CPU: iP4 2.4 x32
OS: WinXPpro - SP2 + updates (all services are in their default states)
Other security: Avira AntiVir personal ed., limited user account.

I get “Unable to export the configuration. Please make sure you have enough rights for the path” message when trying to export config. Of cause I try to save in directory where my user-acc have full access.
There is no such problem when I login as administrator. Everything works fine.

Waiting for confirmation and Thanks for excellent program. (V)

Sounds like the way it is intended to work. Limited users have no rights over administrative software databases. Not to change, not to import or export, not to save, … Vista works this way too.

Limited user ALLOWED create new rules, change existing rules, change every option but NOT ALLOWED export settings? Where is the logic?

PS: Thinking that U R mistaken to move this topic from bugs.

I moved this post from bugs to help because generally you can get more traffic and comments here. Might be a bug, might be a feature. :wink: I am not an XP user, but there are many programs in Vista that require you to run a program as an admin to save the database. Reason being that the admin controls a default database, which is provided to each new user. Certain things must be able to be changed by each user in order to operate-the users are running different programs and activities and thus need different rules. (Different virtual machines). But a user should not be able to turn off passwording, for example, if it set by the admin. If he can, that is definitely a bug. And certainly not store a bunch of independent options that a new user can pick up instead of the admin version. The idea of a user having limited rights is often only supported if he can’t change the default database, but only change limited parameters necessary to run his version of a particular program. Haven’t explored CFP3 as a user, so there may be some problems in the privileges provided user accounts that can get some comments. Vista strongly enforces user vs admin privileges, with a program called UAC that constantly nags users (and even admins) with popups saying you can’t do this as a user or even without reverifying you are an admin. I have to turn off UAC to export the database and think that is probably a bug, but enough others have the same problem that I am not sure.

The only logic that I can see is if the exported settings would not only affect the limited account, but also the administrative account.
If this were the case, then clearly a limited user should not be able to export settings.
I suspect this is the way it works but do not know.


Strange things U R talking about. Lets see to this point from the other side. How can I (as user) backup my own settings which I have tuned before?
IMHO if you worry about the security of the WHOLE database you’ll have to prohibit import, but not export.
I’ll test later if limited user allowed to import all settings. Think that this feature gives us an unswer.