TrustConnect Feedback [old]

Hello everyone,

Please post your feedback on TrustConnect in this thread.


As I am traveling every week and using wireless connections on all trips this service is very useful for me.

Upon connection the program always assigns the same IP to me (I suppose everyone using TrustConnect is assigned this IP??)

Program seems to be running well without noticeable upload/download delays.


I’ll continue to use this program!!


Thanks! for the opportunity to test your new service. It works well on
my Gentoo linux box.

Here is a rough draft of a possible “linux quick start guide”. If you
find it potentially useful, let me know and I’ll improve it; or take
it and run :slight_smile: .

Roger Parks

                                      Linux quick start guide:
  1. Assure that you have Tap/Tun driver support. This can be done by
    looking for “tun” with the following command:

ls /dev/net

the result should be:


If tun is not present, you need to recompile your kernel with:

Device Drivers —>
Network device support —>
[*]Network device support
Universal TUN/TAP device driver support (can be loadable or permanent)

  1. Install the openvpn client via your distribution, or the openvpn web site.

  2. Create a subdirectory named trustconnect within the openvpn
    configuration - almost always this would be /etc/openvpn/trustconnect.

  3. Copy the cert and the conf file into /etc/openvpn/trustconnect

  4. Optionally: edit /etc/openvpn/trustconnect/conf and add two lines:

user comodo
group comodo

where comodo is an unprivileged user that you will need to create. Openvpn will then drop the admin privileges required to start, and will become user comodo - this is a safety
feature, should someone try to attack your openvpn client.

  1. Determine the default routing for your box by running the following command:


note the info in the “default” line; more about this later.

  1. run the following command, and sign in with your account name/pwd
    when asked:

openvpn --config /etc/openvpn/trustconnect/conf

  1. You will see a console window loaded with diagnostics. killing the
    window, or entering ctrl-c will terminate the vpn. At this point, all
    external connections are being routed via TrustConnect in Atlanta.

  2. When shutting down the openvpn connection, your configuration will
    return to the original settings, with the exception of the default
    route. This can be restored with a command such as this:

route add default gw dev eth0

Obviously, your initial routing default may be something else, which
is why you listed it in step 6.

  1. Free, personal use of TrustConnect is intended for occasional
    HotSpot use - such as accessing an unencrypted (non-ssl) mail account,
    or especially when conducting important business (e.g. banking).

So please disconnect from the TrustConnect VPN when not used for this
specific purpose. Please don’t misuse this Comodo offering.

p.s. I should add, GREAT choice, using 443/ssl.

This will both get out of hotspots that restrict users to http/s, AND it’ll get by DPI/QOS that might stop it otherwise.

I swear it wasn’t me! ;D
The traffic graph must be an aggregate.

[attachment deleted by admin]

password incompatibilities?

I successfully changed my account password via the trustconnect https page to something longer and more complex.

However, while the server was happy with the new PW, the vpn server didn’t accept that new pw. I had configured the client for automatic retrieval of the pw, so this was not a typo error.

Changed it back to something a little smaller, and the server again functioned.

Suggest you indicate somewhere the limits of the vpn password, and/or make the account password constraints and the vpn password constraints the same - so that if the account accepts a password, the vpn server will also accept it.

  1. From the preceding post, the following quote:

“However, while the server was happy with the new PW, the vpn server didn’t accept that new pw. I had configured the client for automatic retrieval of the pw, so this was not a typo error.”

might be clearer this way:

“However, while the HTTPS account-server was happy with the new PW, the vpn server didn’t accept that new pw. I had configured the client for automatic retrieval of the pw, so this was not a typo error.”

  1. DATES. How about putting dates and/or versions on conf files, certs, and other downloads? That way, if you need to change something, we know which updated items need to be donwloaded and installed.

I cant use CTC… T_T

FYI, im testing CTC under 2 networks: uni and home(thru router). FW disabled.

yesterday I tried tens of times to sign-up CTC but da page didnt load. I got message st like: “service 443 is unavailable”. was it becoz of comodo servers?

today, i went 2 uni and used internet thru school network. can load da page but only can sign-up after >5 times trying.
then cant connecting. CTC kept saying connecting for ages.

just now i came bak home and tried again. this time CTC told me straightforward dat connection to CTC is failed.

theres st to notice: does CTC instal any device? coz this morning i found there was a new device but seems weird, did kno where it came fr, so i uninstaled it.

Another qn fr me :slight_smile:
Do I need FW if Im online w CTC given my comp is clean?

-dun haf FW in public place: u open ur ports so da hackers r free to catch ur traffic. However, CTC encrypt all alr.
-clean comp: no dangerous outbound connection.

Yes, one encrypted/tunneled port doesn’t protect the other 65534.

ok, thanx cat, i kno dat. However, w/o FW, da hacker can watch over my shoulder but dun understand anything, wat can he do?

and 1 mor qn fr me, hav anyone tried hotspot shield?

HS also aims to provide secure public wi-fi. It creates VPN between ur comp and public router. its a free software.

while CTC encrypt and transfer my online activity between comp to Comodo server thru public router. CTC is a service and chargable if ur heavy user.

I can see dat CTC is mor robust but then can further slow down dan HS. However, i havnt tried any of 'em.

Is level of protection fr HS enuf, since if ur at ur own network, ur connection wen it comes out of router is also no longer under ur control?

P.S: pls xplain to me (my 2 previous posts also) as Im new in dis. Currently i hav no need to use but need to giv my fren some advice, he only has an AV (norton @_@ since he 1st used an AV) and like to hang out at wi-fi cafe. and ya’ll kno im a comodo fan, but unbiased.

Without a firewall the inherent and unknown weak points of your OS (ports, protocols and applications) are open to exploitation.

I have never heard of AnchorFree or their products.
I would be hesitant to trust them or their 2nd party partners with control over my connectivity and private information without more research.

Its not da 1st time I heard abt hotspot shield.
I do search on HS and find dat its actually recommended by quite a lot of ppl. Its also got 4 star rating fr PCMag w its old version in 2006.

Mor interestin’, Anchorfree website also locates lots of wi-fi hotspots ard da world. I accidently came across some cyber cafes which haf websites, they advise customers usin’ HS too.

The TrustConnect server’s DNS resolution on seems to be failing tonight.
Any idea if it’s running it’s own DNS lookups or relying on the ISP’s?

Installed the client package on my 64-bit Windows Vista Ultimate laptop. However, when I ran the client and tried to connect, I received a failure error message which read:

There are no TAP-Win32 Adapters on this system. You should be able to create a TAP-Win32 Adapter by going to Start>All Programs>OpenVPN>Add a new TAP-Win32 Virtual Ethernet Adapter.

When I looked in Start/Programs, there was no OpenVPN menu. I looked into the Programs directory, there was no OpenVPN installed when the client was installed. I went out to, downloaded and installed their OpenVPN 2.0.9 package. However, I got a failure to install the adapter.

When I manually attempt to run the TAP-Win32 Adapter installer as administrator, I get a tapinstall.exe failure message.

Apparently this will not work under 64-bit VISTA.

I have both Hotspot Shield and TrustConnect installed on a new Vista laptop.

As this came with Norton for 3 months I am still using that, hoping for newer versions of CPF3 and maybe CAVS3 before it runs out.

I ran Shields up tests with both connected seperately.

With TrustConnect connected the Shieldsup tests showed my normal IP address and all ports stealthed and no ping reply, so the same as without it.

With Hotspot Shield their assigned IP was shown, just the HTTPS port was open and the pings replied.

Maybe someone can explain in simple terms what this all means please?

I’m not sure what you’re seeing as GRC’s scan, scans Comodo’s IP here.

[attachment deleted by admin]

I just get this :

[attachment deleted by admin]

i got dat too!


With TrustConnect connected the Shieldsup tests showed my normal IP address
sounds weird coz i believe CTC must handle IP add. James, did u test da 2 apps under 2 different contexts? as for my limited knowledge in dis field,if u connect thru router, ports and ping test should b da same(?!)

Hi Cat, yes the reverse dns part is what I get with Hotspot Shield.

Comodo says it is connected but I get the usual IP info so I thought it must not be working. What you say seems to confirm that.

Gordon I was getting the same as you until I checked my log in. I found that it needed all small letters for the user name whereas I had some Caps. When I changed that it appeared to connect correctly and turned green.

Aladinonl I did both with an ADSL modem.

My ISP software (wanadoo france) would not install on vista but I found a download for the modem and managed to get it to connect via the control panel.