This software sucks (cfp 2.4)

I only have a couple things to say:

This software uses way too many resources, it slows down my connection, and it just more or less sucks.

I do not think “sucks” is the right word to choose… Comodo has actually set standards for all firewalls… As you can tell by CFP ver 2.4 still in the top 3 of new leaktests. And i’m positive when ver. 3 comes out it will once again be #1

Thanks for your comments Josh.

If you have a particular problem, perhaps we can help, but the detail you have provided is a little less than we will need to help…


As for the resources, the upcoming version 3 will use much less. As for the connection’s getting slowed, do you have dial-up or broadband? Are you sure the installation went okay? Because really I haven’t heard many reports about CFP slowing nobody’s connection, certaintly not mine.


I don’t think it takes more resources than the other firewalls avaliable. From what I’ve heard it’s supposted to take less resources than ZA.
If you’re interested, you could try CFP3, it uses less resources than CFP 2.4.
You can download CFP3 here.

Note that it’s not in final yet, and might have some bugs

Comodo Firewall Slows Internet Connection?,1178.0.html,7101.0.html


Actually, Josh’s issue was already reported in August and we already answered here:

Apparently, there was no response from him…

Thanks for the replies.

I have a cable connection, I’ve tried this software before on a dialup connection and blocked all connections no matter what I did. When I have more than 1 program open that accesses the internet cmdagent.exe runs about 50-100% CPU and my browser loads pages at about dialup speed, and when I turn off comodo everything runs fine.

I checked those links from my last topic and none of them worked, I tried to disable logs but it didn’t work.

For the most part, I believe this is machine specific, as only some users have the problem. Cmdagent.exe on my machine takes up virtually no CPU time and only consumes 8Mb memory and I log everything.

Josh D, perhaps you could provide use with some more detailed information regarding your envionment, maybe with this to hand we can find a solution. Please see this post for details on what and how to post:

Important - Please read before posting


The logging has nothing to do with cmdagent.exe; that’s for the cpf.exe cpu issue.

The main cause for cmdagent is Application Behavioural Analysis (ABA) - mostly the Monitor DLL Injections option.

Good thing is that CFP 3 has not receive such complaints from any user as far as I’ve seen. Josh, the final version will be out soon, so you can retry CFP 3 until then.

The logging has nothing to do with cmdagent.exe; that's for the cpf.exe cpu issue.

Completely right Soya, me being a twit again :slight_smile:

Huh? Where? What’s going on? I don’t see you referencing logging in here yet ???

Letting comodo run the update to v3 was a huge waste of time, I don’t have nor plan to install SP2 and I ended up having to reinstall v2 and now all the settings are gone and it has to learn everything all over again.

This software doesn’t seem to like Opera, comodo runs at about 50-100% when opera is running and the resources comodo isn’t using opera uses, so my computer hangs most of the time. Also I’ve been having to restart alot because comodo keeps blocking opera after my computer has been running for a few days. I think I’m going to have to find another firewall if this keeps up.

Strange, lot’s of others use Opera quite happily, I guess it could be a problem with your set-up/PC. Maybe a clean install…

I have the same problem on my laptop, and that was with a fresh install of windows xp home sp2/comodo/opera, so it can’t just be me.

Perhaps it’s something conflicting with your set-up. Are you using the same software on both platforms?

This is clearly a fault 40 …

Are we referring to version 2 or version 3 of the Comodo Firewall now?

CPF v3 is a disappointment for me. Not only it doesnt work with Win2003, it doesnt even WARN the user about it. So you remove previous version, to install the upgrade, and AFTER that you are rewarded with one sad message window - Sorry, your system is not supported.

Now this is something unprofessional…:frowning:

Well, let’s see what it states on the official download site

[attachment deleted by admin]