The disregard button does not disregard

Hello, I’ve noticed a bug with the Secure DNS. There is a disregard option, but when I select to disregard the warning for a set mount of time it tells me it will redirect to the site in 10 seconds.

However, when it redirects to the site it once again blocks the site and provides me with the same options to disregard. I know that this is not me as another user saw exactly the same behavior here. Note that I have also seen this on multiple sites.

I too experienced this, went to a blocked site, clicked disregard and set it to 5 minutes and waited for it to redirect me there automatically (wait 10 seconds) and after that I got back to the SecureDNS page and when I disregarded again, but this time clicked the link instead of waiting 10 seconds, it worked. That’s the only testing I’ve done.

Disregard button does not work for me. In another topic you asked me to post here, including OS, browser and plugins so here they are: Windows 7, Firefox 18 with plugins for MS Office 2010, quicktime, shockwave Flash, Silverlight, VLC Web, Windows Live Photo Gallery. Same problem on another computer with Windows XP and Firefox (not currently open so can’t give any more detail than that).

Have had this problem for at least a month, have tried clicking link and also just waiting, I have not ever gotten past the warning page, on either computer.

Okay, I found something out. I tried it with Comodo IceDragon and got the same results as with Comodo Dragon. This was both with or without any extensions.

However, I found an interesting bug, which may be the cause of this. I found out that each time I tried to disregard the warning of a site it would redirect back to the same DNS page. If I immediately selected to disregard again it would also redirect back to the same DNS page.

However, if I then select disregard, and then let it sit on the page where it allows me to select a time for about a minute without selecting to continue, it will work correctly and allow me to access the site. Thus, it appears that the disregard option is only saved if I let it sit on that particular page for a minute before selecting disregard.

Is this behavior reproducible on other people’s machines as well?


Doing exactly the same here, it is like it needs time to initialize.

I think this ‘delayed’ behaviour is by design:

DNSBrian wrote:

I would like everyone to know that disabling Comodo SecureDNS to bypass a site block is no longer required. There is now a "Disregard" button that will allow you to bypass the site block and continue on to the site. The time allowed to the site is variable, it could be a few minutes or a couple of hours. You choose when the disregard page comes up. If you want to be able to go to the site permanently you must create an account and a network profile.

Re: How do I OVERRIDE “Comodo Secure DNS” to get to a Website that it is BLOCKING?

Hi Radaghast,
I am not convinced the delay is by design.
The variable time mentioned is how long to allow access to the site before it is blocked again, not how long before you can access it.

That was my understanding as well.

Ok, I guess I just read it differently :slight_smile: can anyone PM a site that’s blocked so I can see what happens…

PM sent. Thanks.

Not sure what’s going on here yet. Anyone know the connection between secure DNS and Amazon EC2?

Looks like I’m seeing something similar, but it’s jumping around all over the place. Basically:

  1. Enter the site in the browser
  2. Get DNS answer
  3. Connect to Amazon EC2 ( - (main warning page) Looks like Amazon hosting.
dex             : 3
IP Address        :
Host Name         :
Original Name     :
MAC Address       : 
Company Name      : 
  1. Select Disregard
  2. Get a redirect to (This is, something I asked about - This seems to be the ‘Domain Permissive Interface’ Continue page.
  3. Select Continue, page changes to: (no IP change)
You may now continue onto
You will be redirected in 10 seconds
or you may continue by clicking on the following link
  1. Nothing happens and I get bounced back to the disregard page (there is a link to the requested site on this page, which works)
  2. Tried this several times, around turn 4 or 5 it automatically redirected to the required site.

This issue should be fixed, if you want users to actually use it. >:(

I have stopped using Comodo DNS because of it, and won’t be back until it is fixed. :-TD

You shouldn’t make something, that doesn’t work what it should.