Strange & unpleasant fonts

Hi all,

I have the Comodo Dragon browser v installed on my Win 10 x64 (1607). Since the very first use of the browser I have been encountering a strange font set being used by CD. It is very unpleasant to read and watch. I was wondering whether Google’s Chrome has the same issue but found out it has not. Chrome’s fonts are just as they should be.

Take a look at this comparison below. Is there any way how to make fonts in CD look the same as in Chrome?


[attachment deleted by admin]

I have the same problem :-\

Hi Guys,
You could try disabling ‘disable-direct-write’ to see if that helps.
Please remember these are experimental settings.

Kind regards.

Thanks Captainsticks,

That has solved it. I am so glad I can continue using CD as I was already thinking about changing the browser.

You are welcome Svecik , glad to hear that helped. :slight_smile:

That font blur was terrible, it’s been bothering me for ages. I found temporary partial respite by deselecting hardware acceleration for video in settings but this command restores normal fonts entirely. I really wish we were not treated as guinea pigs so often :wink:

Captainsticks, I need your help once again.

I have just been given another PC and it also has the same fonts issue I described above. Trouble is, there is no such option as “disable direct write” on the flags page. I only tried to disable hardware acceleration but that did not help. Is there any other way how to make the fonts look right?

Thank you.

Hi Svecik,
Try deleting the following file if it is present, ‘ChromeDWriteFontCache’ and relaunch Dragon.
C:\Users\Username\AppData\Local\Comodo\Dragon\User Data\Default

Hope that helps.

Thanks Captainsticks, but I cannot find that file. That is kinda weird. Would you have any other ideas?

Thank you.

Hi Svecik,
You could individually try the following 3 suggestions to see if any help.
If the flags suggestions don’t help, I would recommend setting them back to their default settings.

Change the following from ‘default’ to ‘disabled’.

Change the following from ‘default’ to ‘non-material’.

One of the following extension might help.

Sorry if none of the above help, I am running out of ideas.

Kind regards.

Hey there,

Thanks for your help and efforts. Unfortunately, none of the above solves the issue. I have just realised it is a bit different from what it was on my laptop. The Advanced Fonts Settings extension actually displays all fonts properly, but for some reason on some websites (such as FB and a few others), all texts are italic except for a few special symbols used in our language.

Hope you can come up with another idea :slight_smile:

Thank you.

Can you find the C:\Users\Username\AppData\Local\Comodo\Dragon\User Data\Default?

Sure, I can find the folder but the file Captainsticks mentioned is not there.