[Solved with 175 Beta] CTM ruin my day, my disk, my data...

I’m sorry to say that my enthusiast with Comodo ended terribly…
I’ve booted yesterday and just sleep the computer overnight. In the middle of the afternoon, I restart the computer…
Well… the logon time never finish… Well, hard boot… Open CTM console and try to restore to the last snapshot. BSOD :o :o
0x0000007B (0X80786B58, 0xC0000034, 0x00000000, 0x00000000)
Well… try another snapshot… same BSOD.
Tried all my 20 or 30 Snapshots… losing time and time… Tried the baseline… BSOD or logon never finish…
Well… try to uninstall CTM and worked (restoring the computer to the actual system, as the baseline and other snapshots failed).
Could never boot again… :cry:
Windows DVD gives me the following error: 0xC0000225 Boot selection failed because a required device is inaccessible.

Restored my full partition backup (without CTM installed) and have my system back.

I’m really disappointed and do not know what will I do next… 3 hours lost… and I’m lucky :stuck_out_tongue:

I’m a little more calm now that my system is working again.
I only will try CTM again when it has a recovery disk and the system file issues (chkdsk) were incorporated into the technology. I’m quite sure this problem arrives due to NTFS files error or anything bad uninstalled from the boot sector.

Will this remain in silent?
Will be I just another frustrated user?

There are several frustrated users. Just look around a bit in the CTM board.

My experience is that the comodo staff almost never replies in the weekends. I suppose they also love to go out with there family like other people do.

Yup! ;D

This is not what I’ve expected: the support level, the impossibility to troubleshoot…
I’ve beta tested products, tried problematic ones. But when the company is not side by side with you, if you’re let alone, sorry not an enthusiastic place to be.

Situations like power failure, uninstallation, etc., should be easy to reproduce in labs.
I have no trouble with Rollback during the short test period. Something in the code was messed.

I have to agree that the support level could be much better, though on the other hand do the developers also have the right to take a weekend off. But sometimes they do not reply to posts at all. And that is rather frustrating. They sometimes leave us in the dark with an unbootable pc. :frowning:

Hi Tech, I am the same Jahn as Avast forum.

Is this the same system that MBAM reported non-existing files?

There is a known issue with the sleep function not working properly anymore with CTM. There are several post about it on this forum, though I can’t remember seeing one in combination with a BSOD.


I really hope comodo will be able to solve all the critical bugs. And I do hope that a snapshot restore will always bring you back to a working system. I also did experience that a snapshot restore resulted in a boot error at windows level, even though that snapshot was created at a time when the system was 100% working. In my case it was a missing /Boot/bsd file. So it looks like CTM does not include all critical boot stuff in the snapshots. This makes the tool unreliable. In other words unusable, because we won’t know if a snapshot restore will give us back a working system. In your case it didn’t. In my case it did not either.
Fortunately for me, my problem was much easier to solve with a windows RE disk.

Yes. Now without CTM even installed (this is a partition cloned before I’ve installed CTM), the MBAM problem persists and worse, without support in their forum (MBAM detection of file that does not exist (not a rootkit) - File Detections - Malwarebytes Forums).

Support is the key for the success. At least to get users respect.

I don’t think it’s related. It happened after a normal boot.

This is a must have. The system file must be preserved whatever happens with it, as you cannot use external CDs, chkdsk, can’t have access to the disk or files.
We need an external CD that solves all troubles with CTM: the MBR, the file access, the partition table, the install/uninstall program…
CTM is not a toy. But we need to trust it. Instead of Comodo developing thousands of tools, concentrate the job and the efforts to make it reliable.

I think the problem is not not including some files but not being able to monitor issues and crashes that generate bad files (corrupted and so on).
Why can’t I restore to a previous snapshot or even the baseline? ???

Hi Tech.
This is a known bug of CTM. My developer already fixed it. Fixed version will be issued very soon. I’m very sorry for trouble you. Please contact with me. I will help you to recover your system.
MSN: doskey(at)live.com


Too late now. I need to have it back three days ago. I’ve installed Windows 7 again (to restore the partition table, I have other 4 partitions, the MBR and so on) and then delete the Windows 7 partition and put a clone of it (some days ago before installing CTM) in the place.
I don’t know how to backup/restore MBR and partition table. I’ve tried a lot but did not find the final solution (booting with an USB drive). I was affraid to lost all over 4 partitions.

If you know where the bug is, isn’t it safer to restore CTM to beta phase?

What I can’t understand yet:

  1. Why did I lose the ability to restore any of the snapshots, specially the baseline?
  2. Why does the restore partition (100Mb) created by Windows 7 (that was never protected by CTM) have all the files “erased”?

Hi Tech.

  1. If internal data of CTM was corrupted, then CTM might can’t restore to snapshots or baseline. Illegal operation, which means such as boot from CD or use the 3rd-party offline disk tool. There operations will cause corrupt internal data of CTM. The bug you reported, it is a known bug on sub-console. It should be fixed on the latest setup.

  2. This is incorrect. In fact, CTM will not affect on any files on non-protected partition in normal case. Could you please tell me detail about the problem? Files lose on non-protected partition?


I didn’t perform any of these operations.
I was using the computer, boot normally, and the BSOD appears.

By the way, CTM “allows” that chkdsk could be launched (scheduled). The console has already loaded but I think the necessary drivers for CTM to work don’t. Can’t it block the scheduling by Windows?
I did NOT run chkdsk when the error occurred, I’m just asking.

Isn’t it already in the beta?

Yeah… The partition was “empty”. No files. After the BSOD and the uninstall of CTM, I’ve tried to boot without success. Used avast BART CD to access the disks and see the partitions. Two partitions are TrueCrypted and BART CD could not “see”. It’s ok. Only one of the three NTFS ones was protected (the Windows one) and two were unprotected (the Windows 7 recovery or boot partition of 100Mb, that CTM even detected upon installation and the second partition is a document/data one).

Hi Tech.
CTM supports Windows’ chkdsk during startup. It was not offline operation. Yes. The bug was fixed in the BETA. For the 2nd question, in fact, CTM is incompatible with TrueCrypt. How did you install CTM on your machine?
You boot from BART CD, then you should see the baseline of CTM. If you operator protected partition when you boot from CD, you may corrupt internal data of CTM.


I have the full partition encrypted before.
I’ve uninstalled TrueCrypt. Boot. Install CTM. Boot. Install TrueCrypt and mount the partitions.

Yes, I know I can’t manage the protected partition.
Yes, the baseline is there.
The problem is why the files in the restore partition of Windows 7 just disappeared… Maybe something was change in the MFT of that partition? ???

Maybe… I can’t confirm this in your environment. Anyway, CTM should not affect on non-protected partition. In fact, we did not test CTM work with TrueCrypt together in such case. It might is a compatibility issue. I will ask my QA guys to test this case asap. Then I will answer your question.

Thanks for your report,