Solitaire does not start in containment

V12.2.2.7036 (Firewall only) Windows 7 Ultimate 64-bit

I can’t seem to start the windows game “C:\Program Files\Microsoft Games\Solitaire\Solitaire.exe” in containment.
When right clicking on the file and selecting “Run in COMODO container” there is only a little activity shown by the blueish turning circle busy mouse pointer but the game does not start after that.
No Alerts or Warnings are shown. The Containment event log shows “C:\Program Files\Microsoft Games\Solitaire\Solitaire.exe” Solitaire.exe Rating as “Trusted” and Action as “Run Virtually” but it did not start.

Solitaire runs when not contained.

What could be the issue here?

Did you look in “Unrecognized Files” on the main Comodo GUI? I ask this as the classic solitaire application (Win7) had a sol.exe filename and will work fine in containment, but the game that can be downloaded from the Windows store (Termed Clasic Solitaire with filename solitaire.exe) will be blocked and won’t render when contained.

If this is the case, just change the File Rating to Trusted.

Hope that helped!

Hello cruelsister,

There is no “Unrecognized Files” listed. Solitaire came installed with Windows 7 and was not downloaded.

As I wrote before, the Containment event log shows “C:\Program Files\Microsoft Games\Solitaire\Solitaire.exe” Solitaire.exe Rating as “Trusted” and Action as “Run Virtually”.

Furthermore, I can run “C:\Program Files\Microsoft Games\Solitaire\Solitaire.exe” uncontained.

I tried MineSweeper game also and that didn’t start in containment either.

So at the moment I don’t have a clue why those games don’t start in containment.

Tested another game “C:\Program Files\Microsoft Games\Chess\Chess.exe” however same result.

Contained : Chess does not start.
Uncontained : Chess starts normally.

And fwiw, all three tested games (Solitaire, Minesweeper and Chess) do run Sandboxed using Sandboxie.

Just as a test, would you add them to the File list as an executable and see what message you get?

All the three games are already listed in the File List, see attachment.

Is this issue reproducible on other Windows 7 platforms and maybe also on Windows 8 and 10 ?

Who volunteers to test this simple issue? :slight_smile:

Can’t reproduce it with any of those on Windows 10 and I have the same Classic Game pack on this system as you have

Contained game score so far:

Windows 10 : :-TU
Windows 8 : undecided yet
Windows 7 : :-TD

Don’t be shy to volunteer and play a contained game.
I know there are people here using Windows 7 who could easily participate in this match. :slight_smile:

Hello CISfan,

Thank you for reporting :-TU.Let me check this and notify you.
Have a nice day.

Kind Regards,

Hello Dharshu,

Thank you for taking care of this issue and looking into it.
Looking forward to your feedback.

Thank you and have a nice day too.

Hello CISfan,

Are you sure those applications are running in the normal execution…?
Have a nice day.

Hello Dharshu,

Yes, all the three games that I did test (and probably all other games too) do run when I double click on the corresponding files in windows explorer (so they do run uncontained).
However, when I right click on them in windows explorer and choosing “Run in COMODO container” then nothing happens. I just see little activity going on by watching the busy mouse pointer but when the mouse pointer retuns to normal then the game is not executing.

I ran Sysinternal’s ProcessExplorer in containment along with a game to see if the game would be still be running but probably not being visible on the screen. In ProcessExplorer I saw that the game got loaded and started but after a very short time the execution was aborted and the game got removed from the ProcessExplorer process list.

I made an additional observation regarding trying to run a game in containment, please see below thread. It may give you additional information why (perhaps) the games don’t run/start in contaiment.

Please check my thread here:

Hello CISfan, Thank you.We are working in it.
Have a nice day!

Hello Dharshu,

Thank you too.

Don’t hesitate to ping me when you need additional information.
(I could make a small video to show you but the forum does not allow me to upload mp4 files)

Have a nice day too!

Hello CISfan,
If I need any additional info,I will surely ping you :).

Alright! :wink:

I went back to CIS V12.0.0.6882 to check if the games would start in this version containment.
Unfortunately also in this version none of the tested games Solitaire, Minesweeper and Chess works in containment either.
Again, only a little busy mouse activity but the games refuse to start.

The Classic Game Pack seems to run on Windows 10 in containment so I decided to “modify” the original Solitaire game, that comes installed with Windows 7, in such a way that it also should run on Windows 8 and 10. I couldn’t test the modified game on those platforms but the modification is really simple and easy to do so chances are very good that it will work on Windows 8 and 10.

However, even after this modification Solitaire just won’t come to life in containment on Windows 7, it again doesn’t start.

It seems that this issue is related purely to running the original Windows 7 games on Windows 7 itself since the modified game Solitaire also doesn’t start in containment on Windows 7.

The modified executable of the original Windows 7 Solitaire game compares exactly to the Solitaire game executable that does run on Windows 10 in containment. So they are one and the same.
I think @Ploget can confirm. :slight_smile:

So indeed, this “Solitaire does not start in containment” bug only happens on Windows 7.

I hope the bug will be fixed (soon) before support for Windows 7 drops… :frowning: