Should the Tor browser be able to run in Container?

I’m using
Windows 10 Pro x64 21H2 build 19044.1415
Tor browser 11.5a1 (based on Firefox 91.4.0esr)

Should the Tor browser work when run in the CIS Container or when invoked from the CIS Virtual Desktop? Is there some container setting I should use when using the Tor browser?

The symptom is that the Tor browser is unable to connect to the Tor network when run in the container. It can display HTML files which are on the local disk but does not connect to the Tor network.

The Tor browser works fine when not run in the container.
Other browsers work fine when run in the container, including Firefox v 95.0.2 and Comodo Dragon Version 92.0.4515.159 (64-bit).

I used to be able to run previous versions of the Tor browser fine in the CIS container under previous versions of Win10 and CIS, but it’s been quite some time since I last did it and I’m not sure what software versions I was using at the time.

I run it in both - virtual desktop and sure shopping

Currently latest version downloaded from Tor Project | Download is “torbrowser-install-win64-11.0.2_en-US.exe”

So, what is version 11.5a1 ?

11.5a1 is the most recent release on Tor’s alpha test channel. I’ve been using those releases “since forever” with no problems (until now, maybe). Sometimes they fix really egregious bugs long before the stable release does.

Did you check the logs? If you don’t have HIPS enabled, then enable it and try running tor again so you can see if anything is being blocked in the HIPS logs. Also check the firewall logs for any blocks.

I just now downloaded the most recent stable release of Tor (v 11.0.2 (based on Mozilla Firefox 91.4.0esr) )

Unfortunately, the stable release fails for me in what seems to be the same way almost all of the time. It managed to build a circuit only once of the dozen or so attempts I’ve made. Once I saw a very brief flash of what looked like a “Failed to connect” message, but it was immediately replaced by its initial opening screen which just says “Connedt to Tor” in the window and “Not connected” in the address bar.

When I disable “Always connect automatically”, the buttons “Tor Network Settings” and “Connect” never appear.

It works fine when not run in the CIS container.

I’ll try the HIPS suggestion next. (I normally have HIPS disables because it interferes whenever I do any software development.)

With HIPS enabled and running Tor’s stable release, the (exported) HIPS log contains the entry

<td>2021-12-20 10:57:23 
<td>C:\Users\selden\Desktop\Browsers\Tor Browser\Browser\firefox.exe 
<td>Access Memory 

As a test, I disabled VirusScope. It made no difference.

ETA: Disabling “Website Filtering” also made no difference.

Also, the firewall log contains no entries.
Blocked Applications has entries for other applications but none since Dec. 1.

I installed 11.5a1 and tried to run it in Containment and Virtual Desktop several times.
Sometimes Tor works (the Connect button appears and Tor connects to the internet) but sometimes not (the Connect button does not appear in this case).
When I first run Tor normally then chances are that it also runs the next time in Containment or in Virtual Desktop (but not always).

It is an intermittent issue (tested on Windows 7).

TOR browser V9.5.1 does run in Containment and Virtual Desktop nicely however TOR browser V11.5a1 does not as it fails many times to make a circuit connection (it even doesn’t show the Connect button at startup).

11.0.2 also works well and consistently, virtually and not

unfortunately, 11.0.2 does NOT work reliably for me. So far it managed to connect only once among more than a dozen attempts.

I’ll try to test some older versions of Tor, but I’m concerned about all their known security and privacy vulnerabilities.

A problem found, but Tor browser v11 still doesn’t work:

I enabled Windows Defender Firewall logging and discovered that it was dropping both inbound and outbound traffic for the IP address (localhost)
The log file didn’t show any other traffic being dropped.

The Tor browser uses the localhost address. I suspect other network related programs do, too.
I created an inbound rule and an outbound rule to allow that traffic. Windows Defender Firewall’s log file then claimed that it was getting through.

I also added a rule to Comodo’s Firewall to explicitly allow traffic in and out on that port, although that probably wasn’t necessary. Its log also claimed traffic from Tor on that port was getting through.

I don’t know why this is a problem only when Tor is run in Comodo’s container, though.

But Tor v11 (both stable and alpha) still doesn’t work in the container.

(Note that CIS does not (and apparently cannot) disable Windows Defender Firewall.)

FWIW, I tested several more browsers in the Container and they worked OK: Brave, Chrome, IceDragon, Maxthon, SeaMonkey and Vivaldi.

I’ll try to find and test older versions of Tor next.

Perhaps this could be the reason (look attachm.)

Thanks for the suggestion!

Unfortunately, the Tor browser isn’t listed there.

TOR browser V11.0.2 doesn’t work in Containment nor in Virtual Desktop. Same issue as with V11.5a1, not showing Connect button on startup page.
TOR browser V11.0.2 and V11.5a1 do work when run normally.
TOR browser V9.5.1 does work in Containment and in Virtual Desktop every time.

So, I observe the same kind of issues on Windows 7 with TOR browser V11.0.2 and V11.5a1 as selden observes on Windows 10.

The problem seems to be fixed in the next release of the Tor browser.

Tor 11.0.3 (dated 2012-12-19) is available at

Hopefully it’ll be available soon through the in-browser update.


I also tested 10.0.18 and 11.0, both of which worked.

There’s a mention of the symptom (no “Connect” button) in the Tor user’s forum, although there’s no mention of the circumstance where it was encountered. The response was that it’s a known bug and they’re working on it. See

It’s been out a few days and is already available through the browser update, I had no issues with the latest or the previous version then again, I had it to set to connect automatically on launch. If you have issues running it in containment, make sure to reset the container using the reset containment task.

Unfortunately, the Tor browser stopped working for me after I enabled “connect automatically”: then it didn’t connect.

I’ve cleared the container and turned off the automatic connection, but it still doesn’t work: no “Connect” no button appears while in the container.


Nope, also V11.0.3 does not work, again no Connect button showing.
Reset the Container does not help either (I have tried it many times already).