Scheduled Full Scan Does Not Run [M1006]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - CIS AV scheduled av scans aren’t occuring.

  • Can U reproduce the problem & if so how reliably?:
    Every time.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1:I set full scan to happen at midnight saturday (sunday actually) but no full scan is run.
    2:I set full scan to happen at various times and still no full scan.
  • If not obvious, what U expected to happen:
    The Full Scan should be run at the scheduled time.
  • If a software compatibility problem have U tried the conflict FAQ?:
    Shouldn’t be conflicts.
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    There do not even seem to be any logs for this under the logs for Tasks.
    Screenshots of the AV scheduled scan are attached to this post.

[ol]- Exact CIS version & configuration:
CIS 7.0.317799.4142

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    All except HIPS and Sandbox.
  • Have U made any other changes to the default config? (egs here.):
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    No, fresh install ~month ago and nothing was imported.
    [li]if so, have U tried a a clean reinstall - if not please do?:
    Tried it, but a clean install did not solve these issues.
    [/li]- Have U imported a config from a previous version of CIS:
    No imported stuffs.
    [li]if so, have U tried a standard config - if not please do:
    I have standard config in use.
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Win 7 Professional Sp1 64bit, UAC is set as its set by os, non-admin user, no virtual machines.
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=Spybot, Spywareblaster and Anti-Maleware Free (all latest versions) b=None

[attachment deleted by admin]

Did you try reinstalling CIS by following the advice I give in this post. If not please do try those methods. Very often a normal uninstall, or even one with other tools, but not the specific uninstall tool, can miss files which can cause issues like this.

Please let me know if reinstalling CIS by following the methods I describe is able to solve this issue.


did uninstall and reinstall as instructed (except no installation in safe mode since that hasn’t been possible since win9x-time) and with admin-account cause CIS hadn’t updated av-database for nearly 2 days (2nd comp had got same problem but it got fixed by rebooting comp and updating CIS databases) due some unknown reason (nothing weird in logs on 2nd comp which does full and quick scans as scheduled (and has been updated straight from CIS 5 to 6 and from 6 to 7) although 2 hrs earlier than set but its user-account has admin perms but on main comp user-account doesn’t have admin perms) but didn’t help on getting scan schedules to work (unless it did it in few secs).

as I have stated elsewhere checkmark on what to scan vanishes after clicking ok which seems weird to me but is apparently normal. both comps have same CIS conf except on 2nd comp schedules have been set by CIS.

My article does not ask you to install in Safe Mode. However, it does ask you to run the CIS removal tools in Safe Mode. Were you able to run those in Safe Mode? If not then please uninstall. Then run those removal tools in Safe Mode. Then reboot to normal mode and install CIS.

Is following those steps able to solve this problem?

ran cis removal in safe mode too before latest installation (didn’t find anything to remove after running it in normal mode as admin).

don’t have time to try again until weekend.

From what you said it sounds like you already did a clean install, and this continued anyway. If that is correct then there is no need to try it again.

Please create and attach a diagnostics report to your first post. If you are not sure how to do that please feel free to ask.
Also, please create a Process List through KillSwitch. To do this open KillSwitch through CIS and choose the option from the menu to Save Current View. Then put this in a zip file and attach it to your first post.
Please also export your current configuration, put it in a zip file, and attach it to your first post.
Finally, please find any logs relevant to the Full Scan scheduled scan. If there are any please take a screenshot of the logs and attach it to your first post.

I know that’s a lot of things, but I want to make sure the devs have enough information to hopefully understand this strange issue. Please let me know if you have any questions at all.

Thank you.

done, did clean reinstall since CIS diagnostics reported some errors which it couldn’t fix (earlieast attached report) but that either didn’t fix scheduling. no antivirus logs since av events is empty on both users (admin and non-admin).

Thanks for the files. Are there any events under Tasks if you show the entire period?

only events are under conf. changes, tasks (nothing about full scan only 1st quick scan after installation), def+ and alerts (found new network).

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

It’s been brought to my attention that it would be very helpful if you could create screenshots of what you see when you open the windows showing the scheduled scans, and also for the details of the scheduled scan. Please attach that to your next reply.


no problem.

screenshots below.

[attachment deleted by admin]

Can you please also attach a screenshot which shows the Schedule section for the Full Scan?


atm its set to 1 min before midnight saturday while in Win XP64 bit scans ran fine saturday midnight (except made computer barely usable but that’s history).

no any kind of alerts in logs nor any av activity nor fw activity.

[attachment deleted by admin]

Thanks for supplying these. I have added them to the first post and updated the tracker.

Thanks again.

Thank you for the previous screenshots. However, there are a few more which may help shed some light on this issue.

Please also take screenshots of the OS scheduled tasks in Control Panel ~ Task Scheduler ~ Comodo (folder). If you click on the Comodo folder you will immediately get a list of the Comodo scheduled tasks. Please take a screenshot of that list with all columns (in particular last run result) visible to work out what is happening.

Also, please then right-click on that and choose properties. You will then get a many tabbed properties dialog. Screenshots of all those tabs may be useful as well.

Let me know if you have any questions.

Thank you.

there’s only 1 comodo task in task scheduler and its autoupdater. admin has few comodo related tasks (updaters and scans and some other).

so scheduled scan tasks as non-admin user aren’t added to windows task, weird.

That’s very interesting information. Please take a screenshot of the scan tasks you did find, along with the properties. I will then update the information in the tracker.


admin or non-admin?

here’s non-admin.

history tab is empty since history is disabled (by default I guess).

[attachment deleted by admin]

What do you see if you run it as an Admin?