Resizing a column resizes all columns [M2174]

1: CIS version:
2: OS version:
Win XP SP3
3: What you did:
Changed a column size in firewall log file
4: What you actually saw:
All column sizes changed
5: What you expected to happen or see:
Only the column size I change should change
6: If possible attach a screenshot illustrating the GUI problem
Two screenshots of CIS Firewall Log screen attached. Had to break it into two images because it’s blown out to completely unusable size, as every time I change a column size, all other column sizes change, too. Same problem occurs in HIPs and AV log files, as well, or anywhere you can change a column size.

Which theme are you using?

Modern Theme

Same issue in all themes, but changing theme does reset column sizes, so is at least a work around.

Or not, going back to modern, column sizes are back to being blown out
Any way to reset them?

if you change theme for the first time, columns will reset.
but if you resize them, then change the theme, once you go back to the previous one, cis will keep memory of the column size.
you have to uninstall cis and install it again to reset columns size

Just installed Comodo Firewall 10 (not sure how to find exact vers #, installer is C
on Windows 7 Pro SP1 x64. This is on a PC with fairly fast processor w/2-heads and ■■■■■■ AMD on-board graphics.

What you did:

I was in the Advanced Settings File Rating-> File List screen, and attempting to expand width of File Path Column, by grabbing the divider between the “File Path” column heading, and the “Company” column heading. The divider appears to be only one pixel wide, making it difficult to “grab”. I repeatedly missed it, and that somehow was causing the UI to expand the column width a “whole lot” (one screen width maybe?). This caused the UI to increase the total width of the table of course. What is bad and appears to have maybe require me to re-install the product, and loose all my previous customizations is that now the table is many screen widths wide, even though I was laboriously able to reduce the widths of the columns I inadvartently expanded.

Now maybe this is not a big problem if you are using a gaming PC with a hot graphics card, but this is a machine for coding. Its got two heads, and is using the on-board AMD graphics. Now doing anything in this table can result in repaint times in the tens of seconds.

To add to that annoyance, the “physics” used in controlling the movement of the columns results in a UI stabilization time close to 30 seconds between column width adjustments. You painfully watch the UI repaint the column being moved, with the physics momentum slowly disapating. It takes tens of seconds between every column adjustment, because the stupid UI is still dealing with a table many screens wide (a lot of unused space to the right of the rightmost column.)

So this is actually a bug report for at least 5 different bugs of varying severity.

[ol]- There is the usability issue of difficulty grabbing the narrow 1-pixel column divider.

  • The unexpected and counterproductive result when you miss grabbing the divider. This results in the column expanding by one whole screen width. (Possibly due to hot-spot for search function starting one pixel away from column divider.)
  • The problem of failing to “garbage collect” the unused space to the right of the rightmost column, when right-most column is narrowed or moved left.
  • The ensuing UI horror-show of physics etc. causing 30-second repaint times for column moving or scrolling in either X or Y directions.
  • Inability to reset UI back to default column spacing. (I’ve tried exiting and restarting process, don’t know about reboot) but it looks like because column widths are “sticky”, CIS is remembering the goofy table width settings between runs and giving me no way to undo damage I created because of mistakes I made because of the earlier bugs. (Can I go into registry to change this? I’m not a Windows programmer, I don’t know where these sticky settings are kept.)

I don’t wnat to reinstall, please help

you can’t… the only workaround is to switch to a different theme, so that all the columns will go back to the original size. But then, don’t resize them, or you’ll get the same problem

I have merged similar topics into this one and have submitted a report in the tracker, thanks to all for explanation and screenshots showcasing the bug.

To reset it, go to : HKEY_CURRENT_USER\Software\ComodoGroup\CIS
for example, select : HKEY_CURRENT_USER\Software\ComodoGroup\CIS|lycia.set|COMODO View Logs|1033|96
Delete : WindowPlacement

Should be OK as work-around. Hope it helps.

Actually, this one resets the window size. My bad. Hmm! I’ll check for columns.

Here goes.

Go to : HKEY_CURRENT_USER\Software\ComodoGroup\CIS\Grids
Delete appropriate keys (for example, |lycia.set|res://logviewerbase.html/)

Logic behind is that it stores only customization. Upon deletion, it should restore defaults. Looks OK.

Hope it helps.

the Columns in “view logs”
when you just point them ,and they have A will of their own.the Columns just resizing without control without a way to reset theme back.

Bug 2174

I report a problem related to the “Advanced Settings > Rating File > File List” window, the resizing columns works bad, and leads to a progressive reduction of horizontal scrollbar, at the bottom of the window, if the scrollbar becomes very small, is impossible to moving in the window, because of heavy lags and freezes, with Comodo process that occupies the 20% of CPU, and then if I reopen it, the problem persists. At the moment to workaround the problem, I’ve changed the skin, because each skin, or language settings, seems manage the window independently, but I use a dark high contrast theme on Windows, and I get on well with the Classic skin of Comodo, because it’s the only that allows me to see well some parts of the text, in the settings window, that appearing on a dark background.

Sorry for my English, I’ve attached 2 screens to better illustrate the problem:

“Advanced Settings > Rating File > File List” Original with Modern Theme

“Advanced Settings > Rating File > File List” Classic theme, bug after tried to change the column sizing, with resulting freeze of the window

Another case of bug 2174. I am going to merge this topic with that one thanks.

Thanks. This worked for me. This problem has been sending me nuts for weeks. Nice to have it finally back to normal

Actually spoke too soon. It’s a fix of sorts but the columns go crazy again if you go anywhere near the headers. I can live with it for now. Thanks

Can you make a short video showing the issue so comodo can get a better idea on how to fix it.

Sure… Will send it later today. Thanks

Hi Supertech, I’ve uploaded the video you asked for… To show the problem from scratch (ie the default setup), I deleted the registry entry for the log file, then went into the firewall log and tried to move a few columns. Within half a dozen clicks I’d say the furthest columns had jumped at least a metre

For reference, my machine is using Windows 8.1 with 16GB RAM, SSDs and a GTX 1010. Hope this is what you’re looking for but if you need any logs, higher res video or other information, just let me know.