Remote Connection Alert due to Logitech software inside secure shopping [M2150]

A. THE BUG/ISSUE (Varies from issue to issue)

Can you reproduce the problem & if so how reliably?:
Yes, I can outline the steps below.

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Open CIS10 and enter Shopping Mode.
2: If you try to scroll on any page, the Remote Connection alert will always pop up.

One or two sentences explaining what actually happened:
Tested this with new update of CIS When I enter Secure Shopping Mode and I go to any website, as soon as I scroll
the page, the Remote Connection Alert pops up and interrupts the browsing. It doesn’t matter what page i am in and how much I scroll
or the direction… as soon as I scroll, it is there popping up every time.

One or two sentences explaining what you expected to happen:
The remote connection alert must not pop up at every millimeter of scrolling a web page since i am
sure it is a very common action

If a software compatibility problem have you tried the advice to make programs work with CIS?:

Any software except CIS/OS involved? If so - name, & exact version:

Any other information, eg your guess at the cause, how you tried to fix it etc:
I don’t know how to fix it. so far haven’t found any workarounds. Even after I check to remember
settings when i open secure shopping and browser is displayed there (to prevent further alerts),
the remote connection alert still pops up and interrupts the session.

EDIT: i have found a workaround. Don’t use the mouse wheel and drag the slider in the browser manually with the
mouse (while holding the left button)


Exact CIS version & configuration: and Slightly Tweaked Internet Security configuration

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:

Have you made any other changes to the default config? (egs here.):
No security-related changes, only cosmetic ones.

Have you updated (without uninstall) from CIS 5, 6 or 7?:
Clean installed CIS 10

 [b]if so, have you tried a a a clean reinstall - if not please do?[/b]:
 OK... ?
 [b]Have you imported a config from a previous version of CIS[/b]:
 [b]if so, have you tried a standard config - if not please do[/b]:

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Win10 64bit 10.0.14393, UAC at Default (Apps notify only), admin account, real machine

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=Cybereason RansomFree b=N/A

What browser does this occur in? Also can you attach the diagnostic report and export the follow registry key and attach as a zip folder HKEY_LOCAL_MACHINE\Software\ComodoGroup\CSB\remote


I will be unavailable to use my computer for a few days because of new year. However in a few days i will send all the requested logs. Thank you and happy new year to all :slight_smile:

I have returned and attached the logs.

There is no registry key in the mentioned subfolder as per the screenshots:

Which browser? You did not mention.

Sorry. Comodo IceDragon latest version as of today

I can’t reproduce but just attach your config so I can forward it to comodo maybe they can replicate it.

Sorry for the delay.

Here is the configuration.

P.S. with the latest version I think i have found a workaround.

Thank you

They state that they cannot reproduce but for you to create a video showing the issue. Also what was your workaround?

I have previously edited the first post with the workaround. I’ll share here again :slight_smile: if you use the mouse to hold the scroll bar in the browser and drag it, the message doesn’t appear any now. Only when the hardware mouse scroll is used.

I will try later today or tomorrow to place a video of the issue.

Thank you

Ok thanks for the update. Also I found the registry entry that should be checked its HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ComodoGroup\CSS\remote can you check again? Thanks.

I don’t mean to sidetrack this query, but this may help along the line.

I have also had the identical issue and tracked mine down to the mouse; specifically the Logitech SetPoint software used with the M705 wireless mouse (and keyboard)

I can use the browser back and forward buttons and also scroll with the mouse wheel without a problem, but as soon as I use either of the back and forward mouse buttons, then that Remote Connection alert pops up. It’s more an irritant than anything else!

Sorry I’ve had some urgent matters to be resolved. Will try to create the video later today if you still require it. I will also check the registry settings.

Thank you

Also I’ve set up a virtual machine as it will not let me record inside secure shopping… I may try to record this with my phone if i cannot set vm up in timely manner (sorry in advance)

Registry status

Video coming soon…

My Registry entry is very similar Logitech software . . .

Ok thanks I have let comodo know its due to logitech applications setpoint/logioptions.

Pesky little software; it was one of the first things you advised me on last year due to memory accesses and logs;msg833366#msg833366

Oh… I’ve just wanted to say that I’ve tested this in VM and it didn’t issue warning. So i suspected it must have been some software on my system.

And yes, I’m using a logitech wireless mouse.

Thank you.

Hello everyone!

Pretty much as the title suggests , after upgrading to version 10 and trying to use secure shopping I got the message

Remote Connection Detected
I tried to “debug” the error and analyze my current connection via

netstat -ano

and Comodo Killswitch. After closing active connections one by one and checking at each step I ended up having only the Secure Shopping process (with status established) but the message kept appearing and I could not bypass it.

Operating system is Windows 10 , latest build.

Any suggestions or a fix for this are welcome!