Program update fails at 4.1% download


I’ve read the post about uninstalling and reinstalling CIS to fix problems, and I understand it might be required to correct this, but if I can avoid it, I’d like to, so I don’t have to fix all my settings again. I’ve downloaded the related uninstall tool, and the newest version of setup just in case.

Problem is very simple in that when I click Update, it says there is an update, but the download fails at 4.1% every single time. Signature updates all work normally, and Windows is constantly telling me my AV is out of date.

Is there possibly a way to fix this so that I can update, as opposed to reinstalling?

OS version: Windows 10 1809 (Build 17763.475)
CIS product version:

Auto update tried 7 times this week, each time I get the big X pop-up (see screen cap).

try add in proxy and host setting: Comodo Internet Security Software Updates, Download Software Updates | COMODO

Either clean out C:\Windows\Temp or just export your settings and install using the offline or web installers.

I’m having the same problem with Comodo Firewall ver., and I noted the info in the release thread that the online update would be released later. Now, I get the pop up notification that the the online update is available, but it fails with this error message:

“Error: 0x80030201 - The file download was aborted abnormally. The file is incomplete.”

Can/should I use the full offline installer to install ver. over the older version?

Alternatively, can l uninstall ver. before installing ver.

Or should I continue using ver. until Comodo figures out how to remedy the problem?

You can always save your settings by using the export function, then after you install again, you use import. But you can try to delete all files and folders related to CIS in C:\Windows\Temp folder.

Honestly, when upgrading to a new major version number such as the case with v11 to v12, it is better to perform a clean install but you can do either once you have the standalone installer. The recommended steps is to export your settings, uninstall CIS, then install the new version using either the online or offline installer, then import after completed installation. Do not skip the reboots when uninstall and after when the new install finishes.

Hi all,
I am using the 64-bit free version of CIS (firewall on Windows 7. For several days now, CIS has been telling me there is an update available, but attempting to download the update fails every time with:

Error: 0x80030201 - The file download was aborted abnormally. The file is incomplete.

A search of the forums didn’t find any mention of this problem in the last week or so, and the release notes page says there has been no updates for v11 since February. Does anyone know what is going on?


Based on all of the feedback, looks like my best (safest) option is just to uninstall, then reinstall, and redo all my settings manually. I’ll just get to this in the next few days, and it will be done with.

Thanks, futuretech, Per your recommendation, I uninstalled CFW ver. completely and did a fresh installation on all three of my machines. All now appear to be stable. 8)

While I understand the thought process behind the recommendation… why is the update offered at all, then? I personally have a very custom configuration on 4 of my 5 machines and I somewhat loathe to redo it from scratch every “major” update. It felt like v12 GA came on the heels of v11 GA, so it feels like I just did this. :-\

Oddly, 1 of the 5 was able to download and install the update the first time it prompted me. The other ones nag me once a day and fail to update. Usually it’s the incomplete file error and occasionally it’s “Error: 0x800704ca - The network connection was gracefully closed.” None of the suggested workarounds seem to help the issue. As the transfer is over HTTPS, all I can do is monitor the IP address and the hostname requested in the SNI. Even when I try in the hosts settings, it seems to get redirected to / regardless.

After the download, cmdagent appears to use 7za.dll to extract some things to “C:\ProgramData\Comodo\Cis\Quarantine\Temp\TempFiles”, but then shows the incomplete message. I tried clearing out that folder manually but it doesn’t change much. It just repopulates the folder and fails again. Why a quarantine folder is used for this, I have no idea. Turning off AV, VirusScope, HIPS and Firewall do not help. (I do not use Auto-Containment)

Since other people are having this issue, I imagine a larger portion are having the same issue but have no idea this forum exists. (Normal end-users) I feel like suggesting to ignore the problem that more technically minded individuals are reporting is going to hurt Comodo’s image with those who do not know how to voice themselves. I feel like sweeping the issue under the rug is a bad idea overall.

Hi all,

Thank you for reporting, it seems for us as sync problem with some mirrors, our developers are investigating it.

Could you please tell us your IP location where you faced the issue.

[ol]- Almost gave in to doing a fresh install, instead tried one more time. Update worked all the way through this time, now running v12. Thanks devs.

On a side note, I’m using just the Firewall product - where can I download just that vs the whole suite?

It’s still failing for me in the NE USA, moderators should be able to see my IP in the corner of my posts? Or is that only admins?
As I mentioned before, the specific mirror that I seem to be directed to is I can’t find a common DNS server that reports it differently.

Having the exact same issue here, any update on this?

Hi jljtgr & PRYDA,

Please check your inbox for PM.

Well, I’m not super enthusiastic about you remoting into my computer to solve this somehow… but I think I found something more interesting for you to look at.

I started analyzing the update process and ran into something that didn’t add up. Long story short, one of the files the updater downloads fails its size/SHA-1 check and I believe the updater aborts there.

For the longer story…
cmdagent.exe downloads a file manifest cis_update_x64.xml.7z and starts requesting files from it.
The files it downloads are extracted to C:\ProgramData\Comodo\Cis\Quarantine\Temp\TempFiles.

The 4th file listed is x64/themes/lycia.set. The XML file says it should be 2522816 bytes with a SHA of 37a3f4d764594a8d45ca9df0221b10da4b3f237b.
C:\ProgramData\Comodo\Cis\Quarantine\Temp\TempFiles\themes\lycia.set has exactly those attributes.

The 5th file listed is x64/themes/default.set. The XML file says it should be 13404352 bytes with a SHA of 6c7d641877b3487f2fe0d892afc57ed0247905d9.
The file extracted to the same folder instead is 13,305,024 bytes with a SHA-1 of 2D73881A9CBD979169AE330D7F4047767A1C9232.

If I download default.set.7z manually with a web browser, there is nothing wrong with the 7z archive… it’s just that the contents are the wrong size and CRC compared to the update XML file.

If I copy C:\Program Files\COMODO\COMODO Internet Security\themes\default.set from another computer running v12 into the temp folder and re-run the updater, everything else downloads fine after that and the update succeeds.

For me, a fresh install of the latest version resolved the problem on my main PC. There are at least 2 others here (Probably more) that have the same problem. Redoing the settings is a tedious task, so I’m still open to resolving this, without a reinstall on other devices. (Remoting in is not an option)

I’m in Virginia, near the coast.

It always surprises me that people who make custom settings don’t know how to save those settings to use for new installs using the import/export function.

My impression from having read this forum over the years is that importing a configuration from an old “major” version is considered just as bad as installing over a previous version. The new version may have defaults the old version export doesn’t account for. But common sense would say that an updater should know what those changes are and be able to make modifications to the old configuration in-place where the defaults have changed. Similar to database up-version scripts that modify the schema depending on the version jump.

If importing is so safe and updating is so dangerous, why doesn’t the updater take an extra reboot to install cleanly and then import? Anyways, because of that impression, I never import the rules of an old version.