Post here if CTM distroyed your computer

COMODO, please read the posts in this forum relating to computers that will no longer boot (blank screen with blinking cursor in top left screen). This is happening upon install or uninstall of CTM.
You are destroying computers and many, many users are losing irreplaceable data.
Be responsible.

Title change by Moderator please read PM

Agreed. Remove this software asap.

also read:
Post here if CTM destroyed your computer -

Plus i posted on PCWorld about it and what it’s doing under the post about it. As that is how i found it threw a newsletter from them.

DO NOT allow this software to be downloaded until it’s fixed and ready. STOP using us and your clients as ginnypigs.

Your lucky you are not getting sued yet. Not to mention by me.

If you do not remove it though as tons of your members are saying. I bet you will be though soon. Plus since you have been told/asked/ and informed by your clients and users.


This is a good idea for a program. But does NOT need to be released until it’s correct. Test it yourselves GOOD. Do not use us and ■■■■■ up our machines by using us as [unknown] testers.

This forum is full of posts from people that installed (or tried to) CTM and the end result was disastrous. Many (including myself), had to do a reformat and complete reinstall of my OS and programs.

I tried to uninstall CTM from my laptop (problems with it). It crashed and wouldn’t boot up after that. I had to do a complete reformat and reinstall of my HDD.

What is your story and what can we do to prevent others from going through this costly mistake?

COMODO response
OK… this thing went sideways. As in “Not Helping Anyone”. Thread is Locked.

A dev has even politely responded to try to help get to the bottom of things.
Lotta good that did.
So now.
Two choices for concerned individuals.

  1. Take the offer of help, or offer to help by making a proper individual Bug Report.

  2. Start this as a new topic in Feedback Comments Announcements section.
    Where there is more room to build a warning monument to Failure.


Personally This product destroyed my computer. A DEV member PM’ed me once and commented he would help. Then nothing.

This issue is not sideways. The reason we are furious is because you continue to offer this dangerous product for download. You cannot solve this problem by locking threads!!!

We the Mods are, Not Comodo employees.
My response was, Not Comodo"s response.

The thread was in the wrong area for what you seem to want to accomplish.
The bug board is not for opinion pieces.

You’ve got feedback and want to make comments. Here we are.
Thank you.

In my opinion there should either have already been a fix for the uninstall problem or the product should have been moved back to Beta.

And by fix I mean that people are no longer experiencing the corruption of their MBR.

Not sure about the suing part, but in general I agree with you. When a bug this major is identified by numerous users the product should be quickly moved back into Beta.

With that said there’s always some risk when installing security software. What I don’t understand is why it’s still publicly available when it can cause so much damage.

I tried CTM however after a huge problem in the MBR and not able to boot my system I decided to uninstall this program… Thankfully I had Acronis image saved to an external and was able to boot from an Acronis boot disk… At one time I had Acronis in my MBR and that was also a huge mistake… I have decided that I will no longer install any program that does not give you the option not to run in the MBR…

While using CTM I felt it was an okay program and I do like the way the programmers are trying to resolve the issues we all have… Until CTM gives the option to create a bootable disk and not install CTM in the MBR I will continue to use Acronis and Macrium Reflect keeping the images on a external hard drive…

I would like to offer my open apologies to Masterblaster, and indeed anyone involved in a similar situation.

Also to whomever may look at these moderation’s that have occurred.
ie. sadly the following turn of events has transpired.

  • title edit (explained by PM, between OP and another mod)
  • redirection of peoples energies - the Bug Report board is used and seen as a tool for development.
    please imagine yourself at work trying hard to deal with a tool that’s lit up all day with new posts about how, I agree or disagree, and why the app is or isn’t poo.
    All within the realm of this Feedback Comments area. I’m sure they read here too.
  • merging - after the fact to the above, a second thread also opinion based, and involving the same people.
  • also in the wrong forum area Bug Reports.
    What to do? move it to Comments? but that would sort of be double posting on the OP’s behalf.
    Same players, same issues, cross referenced back and forth… oh my?
    So what we have here is a quick and dirty merge.

Moving and merging happens often, people seldom seem to notice or care unless it concerns unhappy people.
So if you would take this as stifling or censorship beyond the norm, my apologies for appearances.
And the choppiness till here.
The Forums are still completely open to all of these people and their opinions.
Provided they are within the Forum Terms and Conditions & are apropos for the area in which they are placed.

With that, I’ll leave you guys… unless I can figure out what is causing these problems that is :wink:

Thanks for listening.
Bad out

After booting up,Comodo time machine created such a large snapshots (dunno why) compared to previous snapshots,on my 160gb main drive,that I was getting write errors on windows due to low disk space.I deleted one snapshot in Comodo time machine to free up space but as I only had the last snapshot and the baseline,neither of which I could delete,I was stuck in no mans land.Comodo haven’t shared the whereabouts of saved snapshots so my PC was in effect hijacked by the program.
Only thing for it was to reset the baseline.Which as you can guess didn’t have enough space to complete but none the less it partly restored my system to God only knows where.Half way between the baseline and last saved snapshot I suspect.
And wouldn’t ya know it.Although Comodo time machine is present in my start menu when I try to start it I get a Critical error message:A critical subsystem required for the proper functioning of the product is not active message.A further kick in the nuts to add to everything else.
A silly conclusion maybe but ‘Maybe if all snapshots were deletable this wouldn’t happen’.Or delete old snapshots before resetting the baseline.If Comodo time machine hasn’t the space to do a full baseline reset Maybe It shouldn’t even try full stop.
Now you all know why you have to pay so much for rollback rx

Hi All
It would be VERY help full if you could post what applications you think you had installed on your PC when it got killed, I know there are some apps out there that tries to write to the MBR as it is seen as a “safe” way and space to write to as it is a place usually not written to. I think Apple products writes to this and maybe some Adobe apps as well. Usually this MBR or maybe Sector 0 of the HDD is not very big and if you write to it you could mess up the whole PC… I know TrueCrypt had similar problems but luckily got that fixed very quickly, TrueCrypt needed to write to this Sector 0 / MBR inorder to load before the OS (whole HDD encryption), So to help the Comodo guys it will be cool if you could post:
What OS you had,
What Service pack you had for the OS,
A list of software you had.
What was the exact steps you took untill it killed over…

AND you could use a Linux CD like Ubuntu to boot up to get your data off before you reformat and there are also some Linux tools that can fix MBR, not sure if they can fix Sector 0 though

Yes your posts did gave me a fright but still I tried it on 1 PC and all looked ok, it was a clean XP Pro SP2 PC but still it worked…


Use a tool like Space Monger : or TreeSizer: JAM Software Solutions | JAM Software

You could see where the Huge files are and then potentially delete them, Again you might need a Live Linux CD like Ubuntu to boot from to then look at the HDD and then delete the snapshot…

I’m afraid none of these nor any other program except CTM can manage and show what really is going on on a disk. Windows is absolutely Unaware of the snapshots and any program based on the data given by windows (or MFT) is useless. Besides, the first app is Not free - would you mind to warn about that.

I had the same thing. Black screen with a blinking cursor in the upper left screen. I lost everything. I PM’ed tech support several times. They responded with the exact message posted above yours. I have been criticized by both forum posters and CTM rep’s about my negative attitude about this. My biggest problem is they know they have a product that destroys disk drives and they leave the download up. No excuse for that.
Sorry but your Master Boot Record (MBR) is hosed and you will not be able to fix it.

Yeah, I agree with Masterblaster. The people at Comodo knew they have an uninstall problem with CTM, and yet went on to have it downloaded by interested users. They should have fixed it first and posted it for download.

Agreed, they should have moved removed it from the public until the problem could be solved. Either that or posted in VERY BOLD letters that there is a good possibility that uninstalling it can destroy your MBR.

I totally agree. You have post after post of this product completely screwing up peoples computers and you leave this up for download? BAD FORM >:(. I had my own problems with CTM and I find out that they’re throwing it into CIS, the flagship product. I get so sick of other people bashing Comodo on other forums but things like this make it hard to defend… :-TD

Absolute FUD (Fear, Uncertainty and Doubt). Can you please provide a link to a post or article where it is clearly, unambiguously stated that CTM will be built into CIS?

While we’re waiting for said link to appear …

CTM IS NOT being built into CIS.

CIS will be CTM AWARE.

If you install CIS without having already installed CTM, any alert will contain an option to perfrom a Windows System Restore snapshot.

If you install CIS and have already installed CTM, any alert will contain an option to perfrom a CTM snapshot.

Not built in.


There is a real and important difference.

Ewen :slight_smile:

Well the online installer that downloads and installs CIS V4 does also have a box marked Comodo Time Machine. This would encourage more users who would otherwise have only used CIS to also use CTM.

Maybe this is what Watasha is referring to.

That’s exactly what I was referring to. Thank you.