Please read this before posting an installation problem

Hi Guys
If you have a problem with CIS installation - the faster way developers will analyse and fix it is to support them with proper logs.
Please follow the steps below and attach created files to your report message.

  1. Download DebugView from Microsoft site: DebugView - Sysinternals | Microsoft Learn

  2. Run it with administrator privileges

  3. In the DebugView menu please select:
    a) menu File → Log to file as… → Log file edit box → select a file (or type a filename) which you will be able to find later
    b) menu Capture → Capture Win32
    c) menu Capture → Capture Global Win32 (dont worry if this submenu item does not exist)

  4. Using cmd.exe, run firewall installer with the following parameter: -log. This command will create log file in the your %temp% directory, called approx like this: cisinstaller_11-05-25 21.32.07.log

  5. After your installer shows an error message, close it, and wait for a few seconds to let all processes finish, then look for another log file:
    a) go to the your TEMP directory. Fastest way to do this is to write the following command in the cmd.exe: explorer %temp% (+ press enter). Alternatively you can write %temp% in the Windows explorer’s address bar.
    b) in the TEMP directory you will find a file called approx like this: cis_10-07-19 20.23.46.log, where “10-07-19 20.23.46” is the installation date and time (of course, your actual date and time will be different)

  6. a) Download Autoruns utility (Autoruns for Windows - Sysinternals | Microsoft Learn)
    b) In the downloaded archive you have two utilities: autoruns.exe and autorunsc.exe. You’ll need the 1st one (autoruns.exe), run it in the command line as follows:
    autoruns.exe -v -a autoruns.arn
    c) wait till the utility finishes scanning of the system and closes. After it closes, next to the utility you will find autoruns.arn file. Zip it and send it to me via e-mail skalenchuk[at] (please do not post it as an attachment on the the forum).

  7. As a result you will have 3 log files avaulable:

    • from point 3-a
    • from point 4
    • from point 5-b
    • from point 6-c
      Please zip these files and attach to the your message (except log from 6c). I will check these files and try to assist you.

Please do not hesitate to ask questions should you find above explanation not clear.

hi there! i’ve tried almost everything including manually removing cis3 and it still doesnt work for me!
please help!

attached are the logs. :slight_smile:

[attachment deleted by admin]

i have tryed this it does not work i cannot monitor an installation because im not getting one, i get nothing when i click on the setup i have tryed debugview before, it will not log anything there is nothing to log. i have checked the temp nothing there also… every other setup,msi, works. but the new one will not load.

i just used active bootdisk and did a restore to a fresh copy the new installer now works im going to remove the older 3.1 with revo uninstaller and install the new version 4 and see if the installer still works after that

all works good now, thanks all comodo staff for your time.


Hello and thank you for the quick reply.

FWIW I did not recognize a link this this page from the FAQ or did it come up when I searched.

I downloaded and ran Dbgview.exe

Step 6 asks for 3 log files available:
- from point 3-a
- from point 4
- from point 5-b

I did not find these.

On a second run I deleted (except JET2534.tmp) everything from C:\Documents and Settings\Owner\Local Settings\Temp before running “C:\Documents and Settings\Owner\My Documents\Downloaded\cfw_installer_x86.exe” " -log CFWlog.txt"

I attach my \ for your review.

Thank you for your help!

– Fred

[attachment deleted by admin]

I have move the above post so you may please reply to the member asking him to post any further replies here.

Post moved from here.

Thank you

I know that you asked for the Debug files however i cant even get that far the newist (just downloaed to night) installer gets as far as asking which langue to use then says.

This installation does not support the target platform.

this is a new computer with no Commodo installed before .

Running Windows 7 64 bit.

any help is apreciated as i have just unenstalled the trial form norton to load the comodo

hi Fire 1b,

To run installation under 64-bit Windows, you need to download and install x64-version of installer. Here is it:

If its wont work, run installer with logging parameter (see;msg418794#msg418794 for details, you need log from p.4):
cispremium_installer_x64.exe -log logfile.txt

this command will create logfile.txt file near the installer. Please attach this file to your post

Tried to install Comodo Firewall but install allways ends with error.
Log files attached.

[attachment deleted by admin]

hi, aarne

please see here:;msg418591#msg418591
You have the same problem - something in your system blocks installation.
Please check your registry permissions and send me an autorun log file

Please bear with me. I downloaded DeBugview.

  1. I do not know how to run it with Administrator priviledges. Also:

  2. In the DebugView menu please select:
    a) menu File → Log to file as… → Log file edit box → select a file (or type a filename) which you will be able to find later Do I make up one?
    b) menu Capture → Capture Win32 This one I found ok
    c) menu Capture → Capture Global Win32 (dont worry if this submenu item does not exist)

  3. Using cmd.exe, run firewall installer with the following parameter: “-log log.txt”. This command will create log.txt file near the firewall installer. Where/How do I do this?

This is where I stopped. Any Help?

i have tried repeatedly to install CIS with the 64bit installer on a new machine with Windows 7 64bit. Initially, the process would go through various screens and then grind to a halt at the installation stage. Then after several attempts it does not even go through the pre-installation screens. The Debug log is:

00000000 0.00000000 [2600] FTH: (2600): *** Fault tolerant heap shim applied to current process. This is usually due to previous crashes. ***

Any help in completing the insstallation wojuld be appreciated.

hi Y2KATC,

For windows Vista and Windows 7: Right click on the .exe file and select from context menu “Run as administrator”
For Windows XP: simply double click on the .exe file

You’ll not need to specially create the file in advance. It will be created by DebugView automatically with the name you type into ‘Log file’ window and it will be located in the place you select using browse (…) button

Press and hold ‘Windows’ button (the one between Ctrl and Alt) and press ‘r’ - it will open ‘Run’ window. In the ‘Open’ field type in cmd.exe and click OK which will open command line window. In my case I see this line:
c:\Users\Current>(and blinking cursor).
Type the full path and name of the installer + the parameter “-log log.txt”. On my computer the installer is located on Desktop, therefore the full command will look like this:
c:\Users\Current>c:\Users\Current\Desktop\cispremium_installer.exe -log log.txt
Press enter. If you typed in everything correctly, the installer will start and log file will be generated. In my case the location of log.txt file is this: c:\Users\Current\log.txt

Also, in this message you mentioned that you installed Microsoft Security Essentials. This product is an antivirus software and it might block installation of other antivirus program, in our case it might block installation of CIS. It’s strictly recommended not to install two antivirus programs, therefore we’d suggest to either deactivate or uninstall Microsoft Security Essentials prior to installing CIS

hi colion,

Please carefully read again the first message in this topic


I only want to install the Comodo Firewall like on my wife’s machine. Do I need to do somthing different?

Just install. This topic is about the situation where the installation goes totally astray.

If you happen to have a problem with the installation start a topic in this board (not this topic) and we will try to help you out.

Good luck.

I have the program but at the cmd you lost me sorry.

Sorry, I didn’t get what you mean… Could you explain again.