Patch for Comodo CAVL for Ubuntu/Debian with more recent libssl-version!

Hey there.

I was interested in Comodo Antivirus for Ubuntu-Linux. I was unable to install the deb-package as it requests libssl0.9.8 (required!) but I have the more recent version libssl1.0.0 (which obviously is even newer!).

Any tips or is there an alternative version?

Just noticed the “Beta version” thread and trying that version also failed! Same error!

cav-linux depends on libssl0.9.8 (>= 0.9.8m-1); but: package libssl0.9.8 is not installed.

Okay… solved it the “Nerd way”.

Extracted deb-package and edited DEBIAN/control file to add the missing dependency for “libssl1.0.0”

dpkg-deb -R cav-linux_1.0.220659-32_amd64.deb cav-linux_1.0.220659-32_amd64/
nano cav-linux_1.0.220659-32_amd64/DEBIAN/control
dpkg-deb -b cav-linux_1.0.220659-32_amd64/ cav-linux_1.0.220659-32_amd64_libssl1.0.0.deb

This has been patched in line “Depends:”

-- libssl0.9.8 (>= 0.9.8m-1) ++ libssl0.9.8 (>= 0.9.8m-1) | libssl1.0.0

After repack install and it seems to work so far!

So far so good…

GUI works, Manual scan seems to work somehow. But filesystem-driver cannot be loaded as it depends on driver.tar containing RedirFS which seems to be out of development?!

Any ideas? On my system using kernel version 5.1 it fails to compile.