I have found that a search engine (that can be seen in Internet Explorer) is blocked out in IceDragon, not due to IceDragon, but due to one of the settings in NoScript. I checked my add-ons, disabled another one, which made no difference, so it’s definitely NoScript that is blocking it.

NoScript is an excellent, but vast program, and I’m unsure which part of NoScript is blocking out the search engine, which should be on the top left hand side of the screen to type in searches for specific music.

Which setting needs temporarily unticking? or

Is there a section in NoScript which allows the Legsandcoblogspot search engine to appear and be accessible? That’s where that search bar appears to be from.

Ah ha. Unfortunately, despite temporarily disabling (trying one by one, to see if one program in particular was doing the blocking) Adblock Plus, Adblock Plus Pop-Up Addon, Greasemonkey and NoScript, the search engine on the top left window is still invisible. I even added to a Whitelist. Still to no avail.

Not sure exactly which program (or how to find out which program) is blocking the search engine, but it now only works in Internet Explorer, previously working in Firefox then IceDragon.

Depending on the filter lists you’re using in Adblock Plus, you’ll find both it and Noscript will block certain parts of blogger pages. Try leaving Adblock enabled, then selecting ‘disable on this page only’ from the toolbar button.

Whereabouts is the Adblock Plus toolbar button to “disable on this page only”?

I’ve tried “temporary allow” in No Script, but can’t find an option to do this in Adblock Plus.

Update: I’ve since found this option, but strangely, still to no avail as the search engine remains invisible.

Right-click on the ABP icon, then select the option from the drop down list.

I’ve right clicked on the ABP icon and have since found the option “Disable on this page only”.

I’ve tried this and disabling the filter but the search engine still doesn’t appear on the top left hand corner of the page.

I highlighted the option that Radaghast was asking if you’ve tried. In other words, go to that page and select this option. This way, ABP will be disabled when you go to that website.

“Disable on this page only” is the same option I tried earlier, which I’ve retried. Unfortunately, still no sign of the search engine after clicking on it. I don’t understand why it’s still blocked.

Montana 1,
Try disabling NoScript and check that JavaScript is enabled within IceDragon under content.
JavaScript is required for the search bar to be active/visible.

Hi Captainsticks

I’ve checked IceDragon, and the good news is that Javascript is enabled there.

Unfortunately, despite trying to unblock the NoScript protection, I’ve opted for “No, just stop blocking scripts”, the search engine remains invisible. Other than removing all protections, I’m still unsure how to enable the search engine.

"Do you really want to remove ALL the NoScript protections?

Yes, remove ALL protections No, just stop blocking scripts

I don’t use NoScript, but I know it can block XSS. Unfortunately, since I don’t use NoScript I can’t tell you what to change. I use the RequestPolicy extension to deal with XSS. With RequestPolicy enabled, I need to allow and to see the toolbar.

Edit: I use Firefox, not IceDragon, so this information may be a red herring…

That’s funny. I’ve tried NoScript on a couple of occasions, but something about it bothered me to the point that I ended up getting rid of it before long. I also ended up using RequestPolicy and I like it.

XSS rings a bell. Thanks for the link. I see it can put users’ computers at high risk, so hopefully it will be made more secure or not used in due course.

Meanwhile, I’ll seek the Request Policy extension, which may be the answer. I can still access the search engine in Internet Explorer, but as IE is slower and highly reported to be the most vulnerable browser around, I prefer to use an alternative browser, in this case IceDragon.

As IceDragon is based upon Firefox, your information may very well also apply to IceDragon. I’ll give it a go and see what happens. I can manually find the music clips from the right hand side of Legsandcoblogspot but if I can regain access to the search engine, with IceDragon instead of IE, all the better, as there are several hundred music clips to see.

I’ve just searched for the add-on and see there are two versions:

Request Policy and Request Policy Sync. :slight_smile:

I’d not heard of the one you both quoted or its supplementary add-on, but they both sound very good. Thanks to each of you for your recommendations. I’ll keep the Sync version in mind for another time but will install the main version shortly.

The main link, while entirely optional, recommends both No Script and Request Policy to be used in conjunction with one another, as they serve different purposes, but one can be used instead of the other. I’m not yet sure whether to uninstall No Script, as I don’t want to reduce my protection, which doesn’t look likely to be reduced, from your decision to delete No Script, but for now, I’ll install Request Policy and use both, and see how things go.

All going well, the Legsandcoblogspot blogger will be activated in IceDragon shortly.

The Sync version of Request Policy is to synchronize Request Policy rules between browsers and computers, which is currently under development, so recommends to back up your rules using Request Policy’s export feature.

I’ve just tried a default install of CID and NoScript - no other changes - and the only script I had to allow in NoScript, is

By the way, I use NoScript and RequestPolicy

[attachment deleted by admin]

From what you’ve said, it looks increasingly likely that the block to the search engine is coming from one of the Adblock Plus filters. A few months ago I added some Fanboy filters. I suspect that one of those is blocking this out.

In which case, the only way around this, unless you and/or others know otherwise is that I delete the Fanboy filters one by one until I find which one is doing the blocking, or hopefully, a better option (if possible) would be to add to a Whitelist. I tried this with Adblock Plus itself, which I have set to “Disable on this page only”, all to no avail, probably as this is not the source of the blockage.

I’ve checked my Adblock Plus filters, which have considerably reduced the number of ads that appear on my computer, but I feel sure at least one is blocking the search engine.

I currently have Easy List, Easy Privacy and three Fanboy filters, one of which is also an Easy List.

I would just disable (Not remove) each extension and find the offending extension first.
It maybe even be a combination of two extensions.

I use several of the Fanboy filters and if I select to ‘disable on this page only’ in conjunction with the Noscript item mentioned above, the search bar is displayed.

With regard to filters, you would be better making a choice between fanboy or easylist as they overlap in a number of areas.

It’s good that there is a Disable option, rather than uninstalling then reinstalling the programs.

I’ll work my way through these programs, keeping my fingers crossed that I find the one and ones doing the blocking and that I can still use them but removing the blocking to the Legsandcoblogspot Top of the Pops music clips web site.